TL-R600VPN VPN connects but unable to establish RDP or http sessions

TL-R600VPN VPN connects but unable to establish RDP or http sessions
TL-R600VPN VPN connects but unable to establish RDP or http sessions
2018-05-06 18:23:02
Model :

Hardware Version :

Firmware Version :

ISP :

I have just purchased and setup a TL-R600VPN router, Hardware version 4 and Firmware Version 4.0.1 Build 20171128 Rel.60595

I have created a Client-to-Lan IPSEC/IKE VPN, and I can connect to the TL-R600VPN using either Netgear VPN client software or the Shrew Soft VPN client.
Once connected, from the client I can ping my server on the Lan side of the VPN connection.
However, I cannot connect via RDP or via a web browser ( port 80 ) connection to the same server.

The RDP session will prompt me for a username/password, which I enter, and then will display a completely black RDP screen before failing with "An internal error has occurred"
The web browser fails with a "Can't reach this page" error.

On perhaps 1 in 100 attempts it will successfully connect via RDP or the web browser, but if you log out and then try to reconnect it will fail.

Note: if I create a port forward for TCP port 80 ( browser ) or TCP port 3389 ( RDP ) in the TL-R600VPN, then I can connect every time using RDP or a Web browser.
This would imply the server on the Lan side of the TL-R600 is configured an operating correctly.

The problem must be with the TL-R600VPN.

Any ideas or suggestions ?

Regards
Andrew
0
0
#1
Options
4 Replies
Re:TL-R600VPN VPN connects but unable to establish RDP or http sessions
2018-05-07 16:59:02
You are using IPsec Client to Lan VPN. It's suggested upgrade into the latest firmware 180126. Never heard something like that before. You could ping your server, but you cannot connect to the RDP. Is there any other device between the VPN client and the R600VPN, especially the NAT device?
0
0
#2
Options
Re:TL-R600VPN VPN connects but unable to establish RDP or http sessions
2018-05-07 17:01:37
Or any switch, management device? maybe the device forbids the port access.
0
0
#3
Options
Re:TL-R600VPN VPN connects but unable to establish RDP or http sessions
2018-05-07 22:31:04

fearthebeard wrote

You are using IPsec Client to Lan VPN. It's suggested upgrade into the latest firmware 180126. Never heard something like that before. You could ping your server, but you cannot connect to the RDP. Is there any other device between the VPN client and the R600VPN, especially the NAT device?


As far as I can tell from the website I am already running the latest firmware.

Basic diagram -

Client ----------> Site Firewall -------------------------------------------------------> R600VPN ---------------------------.> Server
......................WAN............ LAN...........................................................WAN.............LAN................................LAN
...............111.22.111.22......192.168.4.254/24...........................192.168.4.253/24....10.60.254.254/16...........10.60.1.198/16
...........WAN UDP port 500 forwarded to 192.168.4.253
...........WAN UDP port 4500 forwarded to 192.168.4.253

Client VPN connects every time without issue
A ping of 10.60.1.198 from the client works
An RDP session from the client to 10.60.1.198 fails.

As a test, I setup a port forward of TCP port 3389 from the Site Firewall WAN thru to the R600VPN LAN.
Without the client VPN connection running ( not required ) , an RDP session from the client to 10.60.1.198 works every time.
0
0
#4
Options
Re:TL-R600VPN VPN connects but unable to establish RDP or http sessions
2018-05-08 17:14:58
I have now upgraded to the latest firmware. - 4.0.2 Build 20180126 Rel.54530
It has made no difference - my issue still exists.
0
0
#5
Options