VLAN and Routing with T2600G-52TS

Re:VLAN and Routing with T2600G-52TS
2020-05-12 06:47:10 - last edited 2020-05-12 06:55:19

@rayendra 

From the configuration...

 

First off, it looks like you have not enabled ip routing, which is a global command (I didn't see it in the configuration):

 

Enable IP Routing

 

Next you have these static routes configured:

 

#
#
ip route 192.168.0.0 255.255.255.0 192.168.1.30
ip route 192.168.1.0 255.255.255.0 192.168.0.1

#

 

<snip>

 

#
interface vlan 10
  ip address 192.168.1.30 255.255.255.0
  description "PublicGateway"
  no ipv6 enable
  ip helper-address 192.168.1.1
#
interface vlan 20
  ip address 192.168.0.1 255.255.255.0
  description "LocalGateway"
  no ipv6 enable
#

 

Why do you have static routes for your two connected subnets pointing to each other?  That doesn't make sense.  Static routes are supposed to point to next hop routers, for reachability to networks that are not locally connected.  The switch knows what is directly connected, and knows how to route between the directly connected networks (provided you enable IP ROUTING).

 

It looks like your VLAN 20 is the local VLAN, and 192.168.0.1/24 is the default gateway for machines on that network.

 

Then, it looks like your VLAN 10 is the public facing side, and connects to your router to get to the rest of the world?

 

So, you first of all need a default route on the switch:

 

ip route 0.0.0.0 0.0.0.0 192.168.1.1

 

Then, on your upstream router (the one with 192.168.1.1 configured on VLAN 10), you need a static route pointing to the next hop (which is the VLAN 10 interface on your switch):

 

ip route 192.168.0.0 255.255.255.0 192.168.1.30

 

Delete the two routing entries you have, and just add the default route to the switch, and the static route, on your upstream router, for your local network.

 

And what is the IP Helper 192.168.1.1 for?

 

-rb
0
0
#14
Options