Router TL-R605 - Very slow login (22 + 22 secs)

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
12

Router TL-R605 - Very slow login (22 + 22 secs)

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Router TL-R605 - Very slow login (22 + 22 secs)
Router TL-R605 - Very slow login (22 + 22 secs)
2021-04-01 02:17:02 - last edited 2021-04-16 09:15:24
Model: Adapter  
Hardware Version: V1
Firmware Version: 1.0.1 Build 20210113 Rel.35074

Hi,

 

I have bought few day ago the TL-R605 (updated to the lastest firmware version) used as a connection failover router with two WANs (DSL + 4G).

 

What I'm noticing is that the login page appears after 22 seconds from the request (browser Chrome updated) and after inserted login and password, it takes 20-22 more seconds to show the status page.

So in total, to do a simple login it takes about 45 seconds (excluding typing).frown

 

Why is it so much slow?

I have an Asus WiFi router RT-AC68U and the login page appears instantly as well as the status page.

I have also a TP-Link 4G+ MR600 wifi router, and it show the login page fast as well.

 

So what's going on with this TL-R605 router?

Is it damaged?

Should i return it back to Amazon?

 

Thanks

Daniele

 

For moderators: why i cannot see the router model in the drop-down list?

I can see only 10 models (2 AC + 3 AP + 3 Archer + 1 AD + 1 Adapter). surprise

 

  0      
  0      
#1
Options
12 Reply
Re:Router TL-R605 - Very slow login (22 + 22 secs)
2021-04-07 19:44:18 - last edited 2021-04-16 09:15:24

Hi,

Will anyone be so kind to tell me if the same (his) router has a slow login as mine?

 

Thanks

Daniele

  0  
  0  
#2
Options
Re:Router TL-R605 - Very slow login (22 + 22 secs)
2021-04-09 20:18:19 - last edited 2021-04-16 09:15:24

@jdaniele 

 

Mine does the same thing on HTTPS via Chrome. Funny thing is its fine on Edge and didn't do it until I set redirect 80 -> 443 for the management interface.

 

I don't think its faulty, I think its HTTPS server and Chrome don't get along.

  2  
  2  
#3
Options
Re:Router TL-R605 - Very slow login (22 + 22 secs)
2021-04-09 20:55:37 - last edited 2021-04-16 09:15:24

@SteveB05 

Thanks a lot Steve, very interesting information.

 

Chrome is used to go in https online over an hundred sites every month so it would be strange if the flaw is inside it.

I usually have no issues with it.

 

I will try to disable 80-> 443 to see if something changes, as pointed by you.

It would be interesting to see what happens behind the scene capturing packets with WireShark.

Maybe we can identify different router behaviours depending on the browser used.

 

Thanks again.

Daniele

  0  
  0  
#4
Options
Re:Router TL-R605 - Very slow login (22 + 22 secs)
2021-04-12 19:55:59 - last edited 2021-04-16 09:15:24

I have the same issue... It is quite frustrating... 

  2  
  2  
#5
Options
Re:Router TL-R605 - Very slow login (22 + 22 secs)
2021-05-16 02:52:55

@SteveB05 Thank you so much for proving this info.

I have a brand-new router and has been driving me crazy for a couple of days (3 mins. to load or longer after login). Once I disabled the 80 re-direct, it started working again as expected. Thsanks

  0  
  0  
#6
Options
Re:Router TL-R605 - Very slow login (22 + 22 secs)
2022-01-09 13:21:32

@jdaniele 

Hi,

 

I have the same exact problem. Sometimes can't even login.

 

Firmware Version:     1.1.1 Build 20210723 Rel.64608

 

Hardware Version:      ER605 v1.0

 

Anyone with solution? 

  0  
  0  
#7
Options
Re:Router TL-R605 - Very slow login (22 + 22 secs)
2022-01-11 14:00:13

@antoniodafonsec 

 

Hi Antonio, as it posted by someone, disabling the automatic redirection from http to https solves the problem accessing by http (fast response).

The issue is still there trying to access by https.

The browser says the certificate has not a valid CA, so it suggests to install the certificate to the "Trusted root certificate authorities".

So i exported the certificate and tried to install it, following a tutorial ("How Do I Add Certificates to the Trusted Root Certification Authorities Store for a Local Computer")

 

After that, the browser now says the certificate is valid (when i try to show it) but it stil report the connection is not secure (red https mark) because the certificate "is not valid"...very strange.indecision

Anyway, the https login time is still about 42 + 23 seconds.

I don't know if it is the browser that slows down the login process, trying to fulfill the certificate validity in any way at any request or is the Router that is not able to manage the https connection correctly

 

I had no time to analyze the browser<->router https handshake using Wireshark, sorry.

Maybe one day i will... cool

 

Firmware version: 1.0.1 Build 20210113 Rel.35074

Hardware version: TL-R605 v1.0

 

Thanks

Daniele

  0  
  0  
#8
Options
Re:Router TL-R605 - Very slow login (22 + 22 secs)
2022-01-28 17:59:36

Any more insights on this issue?

 

I don't see any delays when I use Safari. I feels like a certificate storage/handshake problem.

 

thanks,

-jake

  0  
  0  
#9
Options
Re:Router TL-R605 - Very slow login (22 + 22 secs)
2022-01-29 03:18:02

@jfrodge 

 

Have you tried this BETA firmware...

 

https://static.tp-link.com/upload/beta/2021/202110/20211021/ER605(UN)_v1_1.1.1_20211012(beta).zip

 

 

  0  
  0  
#10
Options
Re:Router TL-R605 - Very slow login (22 + 22 secs)
2022-01-29 04:17:23

@RacerX 

Thank you for the code. I am running it now; but unfortunately, the login is still slow.

  0  
  0  
#11
Options

Information

Helpful: 0

Views: 1775

Replies: 12

Related Articles