Configure ER605, so that some devices can only use one particular WAN interface

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Configure ER605, so that some devices can only use one particular WAN interface

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Configure ER605, so that some devices can only use one particular WAN interface
Configure ER605, so that some devices can only use one particular WAN interface
2022-09-17 12:37:33 - last edited 2022-09-20 05:10:36
Model: ER605 (TL-R605)  
Hardware Version: V2
Firmware Version: 2.0.1 Build 20220223 Rel.68551

I have two Internet connections at my home. I have configured TP-Link ER605 load balancing router to use both the connections simultaneously. Now I have two smart televisions at my home and I want both of them to use one particular wan interface to connect to the Internet. Anyone having an idea, how can I achieve this?

  0      
  0      
#1
Options
1 Accepted Solution
Re:Configure ER605, so that some devices can only use one particular WAN interface-Solution
2022-09-18 20:15:08 - last edited 2022-09-20 05:10:36

  @SamikB 

 

For the instructions below I used ER605 V1 (Current Firmware) with the Web GUI, not Omada Controller: I also assumed the following:

 

WAN-1 = Primary WAN

WAN-2 = Backup WAN

 

The instructions show how to add a TV to use WAN-2. You need to do the same for the other TV, just switch WAN-2 with WAN-1 in the instructions. In the future if you have other devices that need to go out a specific WAN, you can add there IP Address Objects to the Group you create in Step 3 below.

 

1. Go to Network>LAN>DHCP Client List
a. Click the SAVE Icon next to the TV you want to go out on WAN-2.
Note: This will reserve the IP. You should not have to manually set the IP on the TV as long as it does not use a randomized MAC address. Next reboot the TV and make sure it gets the reserved IP.

 

2. Go to Preferences>IP Group>IP Address
a. Add a new IP Address Object:
- Name: TV Name
- IP Address Type: IP Address Range (In the range fields put the reserved address from step 1 in both fields.)

 

3. Go to Preferences>IP Group>IP Group
- Add a Group for WAN-2 and add the IP Address Object you created in step 2.

 

4. Go to Transmission>Routing>Policy Routing
a. add a Policy Route:
- Source IP: use the IP Group from step 3.
- Destination IP: WAN-2_Group
- WAN: WAN-2

 

I'm not sure if your Smart TV shows what WAN IP your connected to, but if it does not, it might be hard to see if it is working. Also, these instructions have not been tested because I do not have two WAN's, but they should point you in the right direction. Good Luck!

Recommended Solution
  4  
  4  
#2
Options
3 Reply
Re:Configure ER605, so that some devices can only use one particular WAN interface-Solution
2022-09-18 20:15:08 - last edited 2022-09-20 05:10:36

  @SamikB 

 

For the instructions below I used ER605 V1 (Current Firmware) with the Web GUI, not Omada Controller: I also assumed the following:

 

WAN-1 = Primary WAN

WAN-2 = Backup WAN

 

The instructions show how to add a TV to use WAN-2. You need to do the same for the other TV, just switch WAN-2 with WAN-1 in the instructions. In the future if you have other devices that need to go out a specific WAN, you can add there IP Address Objects to the Group you create in Step 3 below.

 

1. Go to Network>LAN>DHCP Client List
a. Click the SAVE Icon next to the TV you want to go out on WAN-2.
Note: This will reserve the IP. You should not have to manually set the IP on the TV as long as it does not use a randomized MAC address. Next reboot the TV and make sure it gets the reserved IP.

 

2. Go to Preferences>IP Group>IP Address
a. Add a new IP Address Object:
- Name: TV Name
- IP Address Type: IP Address Range (In the range fields put the reserved address from step 1 in both fields.)

 

3. Go to Preferences>IP Group>IP Group
- Add a Group for WAN-2 and add the IP Address Object you created in step 2.

 

4. Go to Transmission>Routing>Policy Routing
a. add a Policy Route:
- Source IP: use the IP Group from step 3.
- Destination IP: WAN-2_Group
- WAN: WAN-2

 

I'm not sure if your Smart TV shows what WAN IP your connected to, but if it does not, it might be hard to see if it is working. Also, these instructions have not been tested because I do not have two WAN's, but they should point you in the right direction. Good Luck!

Recommended Solution
  4  
  4  
#2
Options
Re:Configure ER605, so that some devices can only use one particular WAN interface
2022-09-19 06:27:10

  @SamikB 

Try to disable Link Backup function.

 

Under my test(although I'm using Controller to manage the ER605), the Backup WAN will not be useful until Primary WAN disconnect from Internet.

So you Policy Routing won't take effect since your backup WAN is not actuive.

 

But if you disable Link Backup function, both of the WAN ports will be active at the same time, and the TVs will be able to go to WAN2

  1  
  1  
#3
Options
Re:Configure ER605, so that some devices can only use one particular WAN interface
2022-11-03 12:23:18

  @HellBent Only one change I had to do and that was - Destination IP: IPGROUP_ANY. 

Thanks for the support.

  1  
  1  
#4
Options