TL-SG-108E V2 - VLAN 1 tagging
Re:TL-SG-108E V2 - VLAN 1 tagging
2018-01-10 21:11:15

johnsnow wrote

Have you removed the port as a member of vlan1? I haven't tried but i hope the web admin is not accessible once a port is removed from vlan1, proper fix would be a management vlan but i'm okay if removing vlan1 from a port works.

upgraded, config is okay but admin password reset to default, was just about to order a different brand switch.


Yes, I did! Unfortunately, you still can access web admin tool via any VLAN since you are in same IP network. This is sad. I hope TPLink fix this also.
0
0
#32
Options
Re:TL-SG-108E V2 - VLAN 1 tagging
2018-01-18 22:24:41
Any support for v1.0?
1
1
#33
Options
Re:TL-SG-108E V2 - VLAN 1 tagging
2018-02-02 23:45:03

Rain_TP-Link wrote


Besides, if your TP-Link devices are TL-SG108PE or TL-SG1016PE, I'm afraid it would still need a few days for the official firmware released, maybe at the end of this month if all goes well.


Hello Rain,

any news about the firmware for TL-SG108PE fixing the VLAN1 problem?
༺ 0100 1110 0011 0010 10ཏ1 0010 0110 1010 1101༻
1
1
#34
Options
Re:TL-SG-108E V2 - VLAN 1 tagging
2018-02-03 05:55:42

R1D2 wrote

Hello Rain,

any news about the firmware for TL-SG108PE fixing the VLAN1 problem?


Could I please expand upon the last question to include the SG-1024DE?
0
0
#35
Options
Re:TL-SG-108E V2 - VLAN 1 tagging
2018-04-13 19:18:50

Timbergetter wrote

Please tell me this update is available or about to become available for the SG1024DE V3.


Any plans or progress on getting the VLAN1 changes for SG1024DE switches? I'm about to deploy a mix of SG108E and SG1024DE switches across a non-profit's campus and hate the idea of leaving this one gaping security issue unaddressed.

Thanks in advance.
0
0
#36
Options
Re:TL-SG-108E V2 - VLAN 1 tagging
2018-05-10 03:54:50
I see they have released an update for the SG1016DE V3 and SG1024DE V3.

Nothing for older hardware versions yet, doesn't look like the V2 supports the V3 firmware either. Really hoping we see an update for the older hardware versions I've got 10 of the SG1016DE and they are a mixture of V3 and V2.
0
0
#37
Options
Re:TL-SG-108E V2 - VLAN 1 tagging
2018-05-10 20:37:34

grahamspr wrote


Nothing for older hardware versions yet, doesn't look like the V2 supports the V3 firmware either.


Did you try that or are you just guessing? The new version numbering for older devices was just because of the change of the CI and the logo on behalf of the 20th anniversary. This caused changes in the HTML code of the web UI, but not in the firmware's driver code.

Therefore, Vn firmware often installs fine on Vn-1 hardware (except on TL-SG105E, CPE210 and the new line of EAPs).
༺ 0100 1110 0011 0010 10ཏ1 0010 0110 1010 1101༻
0
0
#38
Options
Re:TL-SG-108E V2 - VLAN 1 tagging
2018-05-10 20:40:08

R1D2 wrote

Did you try that or are you just guessing? The new version numbering for older devices was just because of the change of the CI and the logo on behalf of the 20th anniversary. This caused changes in the HTML code of the web UI, but not in the firmware's driver code.Therefore, Vn firmware often installs fine on Vn-1 hardware (some exceptions are TL-SG105E, CPE210 and new line of EAPs).
Support told me to try the V3 firmware but it reports invalid image when I try. I advised them of this and they then said it wasn't compatible. Can the V3 firmware be made to work?
0
0
#39
Options
Re:TL-SG-108E V2 - VLAN 1 tagging
2018-05-10 20:44:29

grahamspr wrote

Support told me to try the V3 firmware but it reports invalid image when I try. I advised them of this and they then said it wasn't compatible. Can the V3 firmware be made to work?


Not recommended to fiddle with the firmware signature. If it reports "invalid image" there might be incompatible changes (only TP-Link can tell). In this case I would ask support for a backport of this bug fix to V2 devices.
༺ 0100 1110 0011 0010 10ཏ1 0010 0110 1010 1101༻
1
1
#40
Options
Re:TL-SG-108E V2 - VLAN 1 tagging
2018-05-11 02:30:08

grahamspr wrote

I see they have released an update for the SG1016DE V3 and SG1024DE V3.


Great news for me. Now I can begin implementing the needed VLANs. Next highest thing on my priority list is updating the config utility to match the firmware...
0
0
#41
Options