TL-WR740N loses wireless connectivity

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

TL-WR740N loses wireless connectivity

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Re:TL-WR740N loses wireless connectivity
2013-04-30 23:56:58
I have the same problem with TL-WR740N and Xperia mini pro.

My solution was to disable WMM. But in this way my laptop wireless card, intel 5100, fallbacks at 54Mbps 802.11g.

Now I'm trying to activate WMM and disable 40Mhz mode. But in this way all wireless devices stuck at 65Mbps.

I would access to the router with telnet or ssh, so I could see the kernel messages to understand what happens with xperia mini pro and 40Mhz and WMM both activated, but this router hasn't telnet or ssh access.

What else can I try?
  0  
  0  
#12
Options
Re:TL-WR740N loses wireless connectivity
2013-05-01 22:45:36
First you have to make firmware update on your router, second make router configuration without "Automatic", something like in my tutorial - LINK
  0  
  0  
#13
Options
Re:TL-WR740N loses wireless connectivity
2013-05-07 03:25:40

jimasek wrote

First you have to make firmware update on your router, second make router configuration without "Automatic", something like in my tutorial - LINK


How do you supposed that i used automatic configuration?

And what is special in your config? The use of channel 2? I will not use channel 2 because it overlaps with many other routers in the area. Moreover, the images that you posted are of 740N version 1 or 2 or maybe 3, but not 4. My router is TL-WR740N v4.

Did you read my message?

I have a problem with xperia mini pro sk17i and TL-WR740N. After a while that Xperia mini pro is connected, router's wifi doesn't work at all for every device that was connected. I need to reboot the router to have wifi working again.

The only solution that I found for now was to disable WMM. But I dont like this solution.

I'd like to have telnet access to the router to know what's happen when wifi crash.
  0  
  0  
#14
Options
Re:TL-WR740N loses wireless connectivity
2013-05-07 03:39:25
This is only proposition, configuration without "Automatic" settings do you understand? It's very often main issue in wireless.
  0  
  0  
#15
Options
Re:TL-WR740N loses wireless connectivity
2013-05-08 10:36:01
Hi Elmad,
Could you please upgrade your TL-WR740N to the newest firmware and try again? http://www.tp-link.com/resources/software/TL-WR740N_V4_130329.zip
If the problem still exists, could you please provide me the wireless adapter's model number of your xperia mini pro sk17i ?
Thank you!
  0  
  0  
#16
Options
Re:TL-WR740N loses wireless connectivity
2013-05-08 19:59:22

Aldrich wrote

Hi Elmad,
Could you please upgrade your TL-WR740N to the newest firmware and try again? http://www.tp-link.com/resources/software/TL-WR740N_V4_130329.zip
If the problem still exists, could you please provide me the wireless adapter's model number of your xperia mini pro sk17i ?
Thank you!


Ok, last time I checked the newest firmware was 130322. I'll try now with this new firmware.
  0  
  0  
#17
Options
Re:TL-WR740N loses wireless connectivity
2013-05-08 21:17:59

Aldrich wrote

Hi Elmad,
Could you please upgrade your TL-WR740N to the newest firmware and try again? http://www.tp-link.com/resources/software/TL-WR740N_V4_130329.zip
If the problem still exists, could you please provide me the wireless adapter's model number of your xperia mini pro sk17i ?
Thank you!


Nothing, the new firmware didnt fix this.

These are the info on the wireless adapter that I got from my sk17i:

PCI vendor/device: 0097:4076, so seems TI wl1251/wl1271, from here http://cateee.net/lkddb/web-lkddb/WL12XX.html
Linux module used: wl12xx

Are you a tp-link's developer? Please, let me know if you need other infos.
  0  
  0  
#18
Options
Re:TL-WR740N loses wireless connectivity
2013-05-09 11:03:17

elmad wrote

Nothing, the new firmware didnt fix this.

These are the info on the wireless adapter that I got from my sk17i:

PCI vendor/device: 0097:4076, so seems TI wl1251/wl1271, from here http://cateee.net/lkddb/web-lkddb/WL12XX.html
Linux module used: wl12xx

Are you a tp-link's developer? Please, let me know if you need other infos.


Hi Elmad,
What you provide me is the chipset of the wireless adapter, I want to know the model number of the wireless adapter.
please check if they are the same.
  0  
  0  
#19
Options
Re:TL-WR740N loses wireless connectivity
2013-05-09 23:02:21

Aldrich wrote

Hi Elmad,
What you provide me is the chipset of the wireless adapter, I want to know the model number of the wireless adapter.
please check if they are the same.


I'm not sure that I understood what you want to know.

In my android device I'm getting the info on wireless adapter via sysfs linux filesystem. Here the content of /sys/devices/platform/wl1271/ directory:

[CODE]
app@android:/ $ ls /sys/device/platform/wl1271/
bt_coex_state
fwlog
hw_pg_ver
modalias
power
subsystem
uevent
[/CODE]

and hw_pg_ver says "7"
[CODE]
app@android:/ $ cat /sys/device/platform/wl1271/hw_pg_ver
7
[/CODE]

And, as I said before, the chipset:
[CODE]
app@android:/ $ cat /sys/class/ieee80211/phy0/device/device
0x4076
[/CODE]

[CODE]
app@android:/ $ cat /sys/class/ieee80211/phy0/device/vendor
0x0097
[/CODE]
  0  
  0  
#20
Options
Re:TL-WR740N loses wireless connectivity
2013-05-21 21:44:48
Finally I have fixed the problem and the solution was... Changing the firmware to OpenWrt. Now my router is out-of-warranty, but at least it's working.
Anyway this confirms that it's a firmware problem.
  0  
  0  
#21
Options