TL-WR740N loses wireless connectivity

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

TL-WR740N loses wireless connectivity

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
I face the same problem .
2014-03-24 11:25:20
I have a TL WR740N v4 , drops connection randomly. Both my laptops detect the signal but can't connect to it. My phone doesn't even detect it . Only solution is to reboot the router manually.

I had even tried DDWRT, faced the same problem.
  0  
  0  
#35
Options
I get disconnected if I use new Wireless adapter
2014-03-30 01:19:25
Hi, people.

I own a small network with over 30 TL WR740N / WR741ND (both are pretty the same, the 741ND just have a detachable antenna.
I started to experience this freezing and losing connectivity recently (few months ago).

TP-WR741ND: Firmware version 3.16.6 Build 130524 Rel.58577n
(All routers behave exactly the same, so it doesn't matter if I use a 740N or 741ND)

What I learned so far:
I own a HP Laptop with the Intel 7260-N wireless adaptar and when it is in the very initial driver installed (version 10.0.0.6) I only get problem when my TP-Link get over 6 clients connected, but I can manage to get reconnected simply using the diagnotic function from Win8.1 (but just when it "reset" the adapter), or switching the wireless off and on (a few times) or restart the laptop, or also restarting the router.

But if I try any newer driver it will crash the router and all clients will lose connectivity and the only way to get it working again is to restart the router.
I just installed the version 17.0.0.34 (released in February) and the problem got worst, in the older driver it took a few minutes to eventualy freezes, but now it intantly freezes.
Ok, I can roll back to my old's network adapter driver and it works for a few hours.

What I've found so far:
The problem is related to some new technology to reduce power consumption. I did try to disable all configurations on windows side related to this in power options and device manager, but none worked for me.

I tried dd-wrt, but the problem persists, I don't rember which version I tried, but I got the latest one on their website.

So, if I have over 6~8 devices connected to the wireless router, it will start to drop packs, or if I connect my Intel 7260-N it will freezes instantly.

I tried ALL possible combination of configuration from the router side:
- Disabled WMM
- Disabled DHCP (using fixed ip/gateway/dns)
- Disabled AP Isolation
- Disabled Short GI
- Changed MTU / Beacon / RTS / DTIM
- Tried G (not acceptable, but for testing) / 20mhz
- Tried no encryption / wep / wpa / wpa2

I did try ALL possible combinations as I have a lot of this equipment on my network and my users are driving me crazy and I found no solution so far.
I would appreciate if anyone else has any idea, for the smallest to the most complicated one, I accept all of them, because I can't get rid of this brand/model for now.

I have also bought a TL-1043ND and it gets partially the same error (it doesn't disconnect me right away, it takes a few minutes, but if over 6~8 devices are connected it starts to drop a device to allow a new one to connect).

THANK YOU SO MUCH for your help.
I'm desperate.

Leo
  0  
  0  
#37
Options
Re:TL-WR740N loses wireless connectivity
2014-04-03 09:18:31
Hey guys,I have a Intel 7260 adapter,but this adapter is really a junk too! The intel adapter have lots of problem with other brands router.Now I use a netgear adapter.
  0  
  0  
#38
Options
Re:TL-WR740N loses wireless connectivity
2014-04-23 03:11:57
Hello,

I have same issue and some setting it wont let me connect at all

if i use settings like :
bgn mixed mode
no security
channel auto

It just wont connect my laptop at all ( both using intel wireless, one has b/g/n availability)

if i change settings to
bg mixed mode
auto channel
no security

i works some time, then suddenly connection is lost and get limited connection some time and works again
i thing its searching channel or somethin like that, because

when I use :

bg mixed mode
security off
manual channel ( example 1)

it works like charm, lets me connect every time and doesnt disconnect ( havent experienced it yet)

QSS is disabled every time
and I always upgrade firmware (if available) before setting up a router)
At the moment using same four routers (740N v4) but with differennt channels( just in case)

yet been able to get bng mixed mode working and dont have another wireless adapter exept intel to test.

also havent changed other settings except date/time and password.

maybe someone stumbled on a new solution to fix bgn connectivity issue
  0  
  0  
#39
Options
Re:TL-WR740N loses wireless connectivity
2014-04-24 11:50:01
I don't know exactly what solved my problem, but I can asure you if you do these three steps, your wireless will work like a charm:

1) My Windows was updated to Windows 8.1 Update
2) My Intel Wireless driver was updated to 17.0.0.34
3) My TP-Link WR740N was updated to 3.16.6

After this, I have never had any single drop of my wireless =D
I think steps 2 and 3 is enough, but I did those at the same time.
  0  
  0  
#40
Options
online videos wont stream
2014-07-19 11:42:07
I had the same problem as braincrasher
Facebook and youtube wouldnt load
and so i went through this forum
And tried the settings that were mentioned here and it worked :D
but still i have one problem which persists
Online videos wont steam on my android tablet :(
and yes it is very much capable of playing vidoes online
Could anyone please help me ?? d34
  0  
  0  
#41
Options
Re:TL-WR740N loses wireless connectivity
2014-07-19 20:07:04
I installed OpenWRT and ALL, I mean, ALL problems disappeared, no conexion dropping, no slowness, no reboots, no wireless problems at all ..
  0  
  0  
#42
Options
Changing default channel worked.
2015-04-14 17:21:49
I had the same problem. So I tried all possible solutions mentioned in above replies. At last I changed channel to value 2 from default value 'Auto' keeping mode in bgn mixed.
It works like charm. I think the wireless interference was causing the problem and changing it to other value made solution worked.
  0  
  0  
#43
Options
TP-LINK WIFI signal disconnecting frequently
2015-10-21 11:04:54
By switching from 11bgn to 11bg mode in your TP-LINK setup, you WIFI will work properly.
  0  
  0  
#44
Options
Re:TL-WR740N loses wireless connectivity
2016-03-23 15:07:55
In my case - Hardware Version: WR720N 1.0 and firmware 4.19.62 Build 130719 Rel.50877n + Phone Sony Z3 Compact. Problem solved by only changing mode do 11bgn -> 11bg
  0  
  0  
#45
Options