Windows 10 1809 - Archer T9UH v1
Windows 10 1809 - Archer T9UH v1
Windows 10 1809 - Archer T9UH v1
2018-12-30 21:53:38

I recently updated Win 10 to 1809 and am having problems now with the adaptor losing wifi connection.  Sometimes it happens once, sometimes it happens multiple times within a few minutes.  

If I try and update the driver Win10 says it has the best one installed.

 

 

If I try and update this driver then Win 10 keeps coming back saying the best one is already installed.

Would really appreciate any help you can give.

 

0
0
#1
Options
4 Replies
Re:Windows 10 1809 - Archer T9UH v1
2018-12-30 22:53:17 - last edited 2018-12-30 23:04:32

Hi there

 

I am on 1803 and have a similar disconnecting issue.

 

When I run troubleshooter it comes back with the Adapter does not have a Valid IP Configuration, this error sometimes requires network resets along with clearing DNS cache and removing IP leases, however the troubleshooter fixes it and I can continue until the next occurrence.

 

I have disabled all power saving features for USB and the Adapter as that was my inital suspicion.

 

As with the OP I have also checked for newer drivers via control panel. Current driver is version 1030.11.503.2016 from the 26th October 2016 and is provided by Microsoft.

I will continue to check for alternatives in the mean time

 

Hope someone has an answer

 

Best

Bakerman

 

ok so Christmas brain still in effect, I have been to the webpage and downloaded the November 2018 driver from the site, it's still installed a driver from 11 Sept 2017 though version 1030.22.405.2017

 

Adapter is V2.0 just in case, only bought it last week.

 

Cheers

Bakerman

0
0
#2
Options
Re:Windows 10 1809 - Archer T9UH v1
2019-01-10 07:56:50

Reinstall driver from tplink site.

0
0
#3
Options
Re:Windows 10 1809 - Archer T9UH v1
2019-03-11 03:21:52

Did anyone solve this? This is happening to me too - on 1809 and the adapter keeps disconnecting randomly.

 

Thanks,

Lyndon

0
0
#4
Options
Re:Re:Windows 10 1809 - Archer T9UH v1
2019-03-25 08:33:25

Lyndon wrote

Did anyone solve this? This is happening to me too - on 1809 and the adapter keeps disconnecting randomly.

 

Thanks,

Lyndon

hey, try to update the OS version of Windows laptop; and then reinstall the driver for TP-Link. 

0
0
#5
Options