Deco M5 connection issues immediately after updating to 1.2.5
Deco M5 connection issues immediately after updating to 1.2.5
Deco M5 connection issues immediately after updating to 1.2.5
2019-03-21 11:14:55 - last edited 2019-04-16 07:51:30
Model: Deco M5
Hardware Version:
Firmware Version: 1.2.5 Build 20181227

 

*NOTE* If your Deco app shows you are running 1.2.4 and it is up to date this post does not apply to you. The post below only pertains to users who updated to 1.2.5 through the Deco app. Following the procedure below while you are on 1.2.4 may cause unintended problems.

We have received inquiries by customers of connection issues soon after updating to the latest release of the firmware for the Deco M5.

In general, customers may encounter the following two types of situations:

 

1. After upgrading to the firmware ver 1.2.5, one of the Deco unit cannot be added to the Deco network. And when the customers try to re-add the Deco unit to the network, it will pop up "Too Far" even if the problematic Deco unit is actually very close to the main Deco. 
 


2.  After upgrading to the firmware ver 1.2.5, the performance of the whole Deco system will become not that good as it used to be. And some of the clients may drop out. When trying to reconnect, you may get the error message "Incorrect password".

Solution: Please upgrade the latest firmware for your Deco on Deco app.

If you still are experiencing connection issues, please send an email to: feedback.deco@tp-link.com

0
0
#1
Options
5 Replies
Re:Deco M5 connection issues immediately after updating to 1.2.5
2019-03-29 10:58:58

Hi, is the latest version for M5 and M9 plus the same? Or the latest version for M9 is 1.2.4? Because I currently on the latest firmware but its 1.2.4

0
0
#2
Options
Re:Re:Deco M5 connection issues immediately after updating to 1.2.5
2019-04-01 02:01:08

Ian_Verar wrote

Hi, is the latest version for M5 and M9 plus the same? Or the latest version for M9 is 1.2.4? Because I currently on the latest firmware but its 1.2.4

Hi,

 

They are different, For Deco M9 Plus, the latest version is 1.2.4.

 

Nice day. 

0
0
#3
Options
Re:Re:Deco M5 connection issues immediately after updating to 1.2.5
2019-04-16 01:27:38

Dear customer,

 

Currently the latest version for Deco M9 Plus is 1.2.6, while the latest version for Deco M5 is 1.2.8.

0
0
#4
Options
Re:Deco M5 connection issues immediately after updating to 1.2.5
2019-04-17 04:20:25

When trying to reconnect, you may get the error message "Incorrect password".
 

 

I never had this issue on 1.2.5 but now updated the M5 to 1.2.8 and am having this issue with Apple products specifically. Both iPhones and iPads are doing this 

0
0
#5
Options
Re:Re:Deco M5 connection issues immediately after updating to 1.2.5
2019-04-25 03:16:57

Try to disable Beamforming option in Deco app. Tap "More" -> "Advanced" -> "Beamforming".

Will a reboot of the total system fix the problem?

0
0
#6
Options