Poor WiFi with TL-WPA4220KIT
Poor WiFi with TL-WPA4220KIT
Poor WiFi with TL-WPA4220KIT
2019-04-06 19:38:03
Model: TL-WPA4220-KIT
Hardware Version: V1
Firmware Version: 1.2.9 build

I have owned this for about 3 years. It does the job nicely. Hardwired I get very close to the speed of being connected to my router. It drops about 5mbps. However the WiFi has never been quite as good. I tend to get a third of the hardwired speed. Does anybody know a way to improve it?

0
0
#1
Options
1 Reply
Re:Poor WiFi with TL-WPA4220KIT
2019-04-10 09:17:14

Hi,

 

With one computer connected to the 4220 by cable, please go to speedtest.net and run it for 3 times and please show me the pictures. 

 

To do a comparison analysis, please connect to the wifi network and run the speed test also, please show me the pictures.

 

Meanwhile, please check the wireless link speed of your device, here is the instruction:https://www.tp-link.com/en/support/faq/2265/

 

Then, please download the tpPLC utility and tell us what the powerline rate is.  
https://www.tp-link.com/en/support/download/tl-wpa4220t-kit/#Utility

 

For your informatoin, there is an instruction  you can refer to to narrow down the root cause:

https://www.tp-link.com/en/support/faq/2231/ 

 

Good day. 
 

Cillitbango wrote

I have owned this for about 3 years. It does the job nicely. Hardwired I get very close to the speed of being connected to my router. It drops about 5mbps. However the WiFi has never been quite as good. I tend to get a third of the hardwired speed. Does anybody know a way to improve it?

 

0
0
#2
Options