Archer T9UH(EU) ver 2.0 on Mac lost connection
Archer T9UH(EU) ver 2.0 on Mac lost connection
Archer T9UH(EU) ver 2.0 on Mac lost connection
2019-04-17 09:29:51 - last edited 2019-04-17 17:16:58
Model: Archer T4UH
Hardware Version: V2
Firmware Version:

Bought Archer T9UH(EU) ver 2.0

Using on new mac with MacOS 10.14

 

Keep losing connection and have to physically remove the adapter every ~30 min and replug to connect again. Very annoying.

 

On the page for drivers:

https://www.tp-link.com/us/support/download/archer-t9uh/#Driver

 

It says it was released 2018.11.09 and a new formal version is coming soon.

I wonder when 'soon' is and if there is any solution to this problem right now.

 

0
0
#1
Options
2 Replies
Re:Archer T9UH(EU) ver 2.0 on Mac lost connection
2019-04-18 07:52:02

Hi,

 

Sorry for the trouble caused, we are not sure the exact date to launch the new formal drvier, while we can do some troubleshooting regarding to the current unstable connection issue first. 

 

How often it drops out the connection?

What about the wireless signal strength? How far away does it from the main router?

What about other wireless devices? Do they drop the connection?

Besides, if possible, we suggest you to change another USB port or another computer to do a comparison analysis.

 

Have a great day.
 

JimmyK wrote

Bought Archer T9UH(EU) ver 2.0

Using on new mac with MacOS 10.14

 

Keep losing connection and have to physically remove the adapter every ~30 min and replug to connect again. Very annoying.

 

On the page for drivers:

https://www.tp-link.com/us/support/download/archer-t9uh/#Driver

 

It says it was released 2018.11.09 and a new formal version is coming soon.

I wonder when 'soon' is and if there is any solution to this problem right now.

 

 

0
0
#2
Options
Re:Re:Archer T9UH(EU) ver 2.0 on Mac lost connection
Friday

Thank you for the reply.

 

I really hope that the new driver is coming soon.

Right now its like this:

 

Plug in USB-cable, get strong signal and then I can use it between 2-15 minutes. Then it disconnects and I remove the cable and reconnect for the same procedure.

Signal strength is really good when its working, other devices are working fine.

 

What I do when I lose connection is that I wait for around 10 seconds and plug in in another USB-port, just to lose contact after 2-15 minutes.

 

It was working fine on a PC, but it aint working on mac with MacOS 10.14.

I tried TP-Link_Installer_Mac 10.14_beta but that one didnt find any available WIFI at all, the one I use now is Archer T9UH(EUUS)_V2_181023_Mac.

0
0
#3
Options