T4U V3 EU - Not Working in USB 3.0 port, dissapearing from USB when trying to connect to network
T4U V3 EU - Not Working in USB 3.0 port, dissapearing from USB when trying to connect to network
T4U V3 EU - Not Working in USB 3.0 port, dissapearing from USB when trying to connect to network
2019-05-10 08:51:50
Model: Adapter
Hardware Version: V3
Firmware Version: 2.1.0

HI

one of my greatest dissapointments!!

every USB 3.0 Port (i have two) i connect it to doesnt wok. it recognizes the adapter but when i try connecting to WIFI network it diappearing from USB and comes back again.. 

and vise versa.

in USB 2.0 port it works but i still get disconnections all the time and slow speeds in time to time

 

BR

0
0
#1
Options
1 Reply
Re:T4U V3 EU - Not Working in USB 3.0 port, dissapearing from USB when trying to connect to network
2019-05-13 03:44:14

Hi,

 

What is the operating system of your computer? And what do you mean by it diappearing from USB and comes back again? Do you mean that it disappeared under network and adapters and then show up again?

 

Besides, we can do some troubleshooting regarding to the unstable connection issue. 

 

How often it drops out the connection? How do you make it back to work?

 

What about the wireless signal strength? How far away does it from the main router?

 

What about other wireless devices? Do they drop the connection?

 

How did you install the driver? Use the CD or download the driver from the official website.

 

Thanks in advance, and have a nice day. 

 

 

0
0
#2
Options