Speed issue Deco M9

Speed issue Deco M9
Speed issue Deco M9
2019-06-15 13:59:27

Good afternoon, i recently bought and installed a Deco M9 system including 4 satellites. I experience since the beginning speed issues with the main deco. Although my internet speed is 250 down (confirmed by the deco speed test), a speed test from any device (mostly mobile phone) to the main deco results in 70 at the best and most time lower. This is also the case when i am very close to the main deco. When near other satellites then the main speed is fine and close to 250. How is this possible and what is the solution? I am using the very last firmware released last week (did not solve the problem). Main deco is wired to my internet router in bridge mode and wired to a switch that connects all kind of other devices including xbox, nas etc. Mobile use includes netflix, nintendo switch etc etc. One other satellite is connected by wire (to the switch), the other 2 are wireless.

 

Do you have a solution?


Regards Gerben

0
0
#1
Options
10 Replies
Re:Speed issue Deco M9
2019-06-17 02:19:16

Hi,

 

So the current network topology is internet router in bridge mode--main Deco--slave deco/)))((( 2 slave decos  --- means ethernet cable, )))((( wireless. 

                                                                                                                      \ switch--Xbox,nas

 

So the issue is that the speed you get from the main deco is slow, about 70, while near to the satellite nodes, you can close to 250.  

 

Have you ver tried to turn off the satellite nodes and connect your device to the main deco to test the speed.

 

Meanwhile, you can exchange their position to verify whether you have the same problem. 

 

Any updates, please let us know.

 

Good day. 

 

Gerben wrote

Good afternoon, i recently bought and installed a Deco M9 system including 4 satellites. I experience since the beginning speed issues with the main deco. Although my internet speed is 250 down (confirmed by the deco speed test), a speed test from any device (mostly mobile phone) to the main deco results in 70 at the best and most time lower. This is also the case when i am very close to the main deco. When near other satellites then the main speed is fine and close to 250. How is this possible and what is the solution? I am using the very last firmware released last week (did not solve the problem). Main deco is wired to my internet router in bridge mode and wired to a switch that connects all kind of other devices including xbox, nas etc. Mobile use includes netflix, nintendo switch etc etc. One other satellite is connected by wire (to the switch), the other 2 are wireless.

 

Do you have a solution?


Regards Gerben

 

0
0
#2
Options
Re:Re:Speed issue Deco M9
2019-06-17 09:14:07

Hi Kevin, indeed. Internet Ziggo router in bridge modus (giving 250 down and 25 up) -- main deco -- switch -- 1 slave deco )))((( 2 slave deco's. To the switch also other wired devices are attached such as Xbox, NAS, Sonos, TV. Speed test by Deco app is fine, i assume this is a test from the main deco itself to internet. Speed tests from my phone using own speedtest app through the main deco regularly show lower speeds (17, 20, 25 etc), especially when traffic is heavy on the 'deco network'. I did turn off Beamforming yesterday. Can this be of influence (since i have a few wireless devices on fixed locations such as printer, Imac and a few chromecasts)? Or is there a defect in the main deco? Or maybe another firmware version as i can read in other posts? I only have this system for a few weeks, so i have no experience with the performance under older firmware versions.

 

Regards Gerben

 

Kevin_Z wrote

Hi,

 

So the current network topology is internet router in bridge mode--main Deco--slave deco/)))((( 2 slave decos  --- means ethernet cable, )))((( wireless. 

                                                                                                                      \ switch--Xbox,nas

 

So the issue is that the speed you get from the main deco is slow, about 70, while near to the satellite nodes, you can close to 250.  

 

Have you ver tried to turn off the satellite nodes and connect your device to the main deco to test the speed.

 

Meanwhile, you can exchange their position to verify whether you have the same problem. 

 

Any updates, please let us know.

 

Good day. 

 

Gerben wrote

Good afternoon, i recently bought and installed a Deco M9 system including 4 satellites. I experience since the beginning speed issues with the main deco. Although my internet speed is 250 down (confirmed by the deco speed test), a speed test from any device (mostly mobile phone) to the main deco results in 70 at the best and most time lower. This is also the case when i am very close to the main deco. When near other satellites then the main speed is fine and close to 250. How is this possible and what is the solution? I am using the very last firmware released last week (did not solve the problem). Main deco is wired to my internet router in bridge mode and wired to a switch that connects all kind of other devices including xbox, nas etc. Mobile use includes netflix, nintendo switch etc etc. One other satellite is connected by wire (to the switch), the other 2 are wireless.

 

Do you have a solution?


Regards Gerben

 

 

Regards, Gerben

0
0
#3
Options
Re:Re:Re:Speed issue Deco M9
2019-06-18 07:30:14

Hi,

 

With main Deco connected to the Ziggo router only, please connect your computer to the main Deco by wired cable and then test the speed; At the same time, please run a speed test with computer connected to the wireless. Please show us the speed tests results. 

 

Please check the wired/wireless link speed as well. instruction as below:

https://www.tp-link.com/support/faq/2265/

 

Meanwhile, you can run a speed test on Deco app and do a comparison analysis. 

 

What is the model number of the switch? 

 

With the computer connected to  the slave deco, what is the speed you can get? 

 

What is the current hardware and firmware version of the Deco?You can find it on the Deco app.

 

Good day. 

 

0
0
#4
Options
Re:Re:Re:Re:Speed issue Deco M9
2019-07-04 13:54:09

Hi, apologies for not responding in the past two weeks. In the meanwhile i changed the location of my main deco, changed the bridged router in front of the main deco and purchased a 4th deco to cover a weak spot in the house. All works better now, although i still see that the main deco degrades when traffic is high. Then performance, measures via a speedtest on the mobile phone, drops significantly. I am aware about lower speeds on wireless links (as you linked). I use a switch of tplink as well. The firmware of my deco is the latest (1.2.8 build 20190403 Rel 43515). Before the changes i regularly had that mobile devices experienced loss of internet with the message that they could not get an ip address or that authentication failed; after some time this was automatically corrected. Regards, Gerben

0
0
#5
Options
Re:Re:Re:Re:Re:Speed issue Deco M9
2019-07-05 06:55:29

Hi Gerben,

 

Thanks  for your feedback, great to know that it works better now. 

 

For the mobile devices who lost connection and unable to obtain IP address, you can try to setup a static IP for them or reserve an IP for them via Deco app. 

 

After that, you can test the performance and stability.

 

If the mobile devices still lose connection and unable to connect with the authentication error/incorrect password( even though it is correct), you can email our tech support cause we have an internal firmware released can be installed to give it a go. 

 

Good day. 

 

0
0
#6
Options
Re:Re:Re:Re:Re:Re:Speed issue Deco M9
2019-07-14 10:52:03

Hi Kevin, thank you. How can i get hold of this firmware release? Regards, Gerben

0
0
#7
Options
Re:Re:Re:Re:Re:Re:Re:Speed issue Deco M9
2019-07-15 02:28:50

@Gerben 

 

Hi Gerben, you can email our tech support  to get this firmware. Please attach this thread link. 

https://www.tp-link.com/support/contact-technical-support/#E-mail-Support 

0
0
#8
Options
Re:Re:Re:Re:Re:Re:Re:Speed issue Deco M9
2019-09-19 09:59:15

@Kevin_Z 

 

Hi, for some time now i tested with the mobile devices using static adresses assigned via the Deco. Unfortunately this did not work. On regular basis the devices get the message Internet maybe not available or cannot obtain IP address. Very strange. I tried to obtain this internal firmware release via the contact link but they did not want to provide it to me. Can you help me with this?

 

Regards, Gerben

Kevin_Z wrote

@Gerben 

 

Hi Gerben, you can email our tech support  to get this firmware. Please attach this thread link. 

https://www.tp-link.com/support/contact-technical-support/#E-mail-Support 

 

0
0
#9
Options
Re:Re:Re:Re:Re:Re:Re:Speed issue Deco M9
2019-09-20 08:39:12

@Gerben 

 

You can follow the instruction below to install the old firmware via firmware recovery. 

https://community.tp-link.com/en/home/stories/detail/582

 

May it help and have a good day. 

 

0
0
#10
Options
Re:Re:Re:Re:Re:Re:Re:Speed issue Deco M9
2019-09-20 10:36:25 - last edited 2019-09-20 10:39:00

@Kevin_Z 

 

Hi Kevin, you recommended to obtain a newer version of the firmware which is still internal and that i had to get by sending an email to your support. They did not give me this, they have sent a message with a download link to the current released firmware version (see below). So i don't want to go back to an older version of the firmware, i wanted to see if the newer internal version of firmware solved my problems. How can i get it?

Regards, Gerben

 

=======

Geachte Gerben Nelemans,

​Dit is voor nu d laatst recente firmware.

Er zal vast wel beta firmware in testing staan.
Maar zodra ze nog in testing staan worden ze nog niet vrij gegeven aan consumenten

Met vriendelijke groet,

TP-Link Customer care

======

Geachte Gerben Nelemans,

​Bedankt voor de mail


De laatst recente firmware voor de Deco M9 plus kunt u hier downloaden https://static.tp-link.com/2019/201905/20190515/Deco%20M9%20Plus_V1_190403.zip


Met vriendelijke groet,

TP-Link Customer care

0
0
#11
Options