UE300 TP-LINK Gigabit Ethernet USB Adapter less than 100Mbps

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
UE300 TP-LINK Gigabit Ethernet USB Adapter less than 100Mbps
UE300 TP-LINK Gigabit Ethernet USB Adapter less than 100Mbps
2019-07-10 12:38:04 - last edited 2021-06-23 01:05:48
Model: UE300
Hardware Version: V2
Firmware Version: 10.34.603.2019

My home broadband is supplied by Virgin Media 350Mbps fibre.

I have a Dell Inspiron 15 5570 laptop. It comes witha Dell GigabitEthernet adapter but I am told this is limited to 100Mbps by the Realtek PCle FE Family Controller.

I therefore bought  the UE300 TP-LINK Gigabit Ethernet USB Adapter

PnP worked but there was no improvement in speed - approx 95Mbps - which is the best I was achieving before

I updated the driver to Realtek 10.34.603.2019 but still no change

 

What else could be stopping the adapter from giving me faster speeds?

I see in Device Manager 2 * VirtualBox Host-Only Ethernet Adapter. Task Manager shows them as connected but there's no activity. Are they relevant to this problem?

0
0
#1
Options
8 Reply
Re:UE300 TP-LINK Gigabit Ethernet USB Adapter less than 100Mbps
2019-07-12 05:52:15 - last edited 2021-06-23 01:05:48

@alitor99 

 

With your computer connected to the main router by wired cable, please check the wired negotiation speed as the following instruction: 

https://www.tp-link.com/support/faq/2265/

Note: The steps are the same, while you need right click on local area connection or ethernet connection to get it. 

 

Meanwhile, if there is a built-in network adapter, it is suggested to disable it and use the UE300 to provide wired connection via USB port for you. 

 

0
0
#2
Options
Re:Re:UE300 TP-LINK Gigabit Ethernet USB Adapter less than 100Mbps
2019-07-12 18:23:10 - last edited 2021-06-23 01:05:48

Thanks for your help, Kevin.

 

However, I have found a solution. I was posting originally in the support site of my ISP. It was the guys there that suggested I get the adapter.

They also advised I get a CAT6 cable.

Once I installed that my speed soon shot up to 290Mbps

 

0
0
#3
Options
Re:Re:Re:UE300 TP-LINK Gigabit Ethernet USB Adapter less than 100Mbps
2019-07-17 02:41:38 - last edited 2021-06-23 01:05:48

@alitor99 

 

Thanks for your reply. Glad to hear that you got it fixed finally. 

 

Nice day. 

 

0
0
#4
Options
Re:Re:UE300 TP-LINK Gigabit Ethernet USB Adapter less than 100Mbps
2019-12-07 14:09:02 - last edited 2021-06-23 01:05:48
Hi! Can you tell exactly what have you done? I have exactly the same problem.
0
0
#5
Options
Re:Re:UE300 TP-LINK Gigabit Ethernet USB Adapter less than 100Mbps
2019-12-11 11:00:05 - last edited 2021-06-23 01:05:48

@majlo 

 

He changed the cable to a better one, cat6. 

 

If you use the cat5 or below cable, the speed you get won't be higher than 100Mbps. Try to get a better one. 

 

Good day. 

0
0
#6
Options
Re:Re:UE300 TP-LINK Gigabit Ethernet USB Adapter less than 100Mbps
2019-12-11 16:33:14 - last edited 2021-06-23 01:05:48

@Kevin_Z 

When i'm using this cable straight to the computer without the adapter it is totally okay, and the connection speed reaches 300mb/s which is exactly the speed that im paying for. 

0
0
#7
Options
Re:UE300 TP-LINK Gigabit Ethernet USB Adapter less than 100Mbps
2020-06-19 00:44:19 - last edited 2021-06-23 01:05:48

@Kevin_Z 

 

I purchased this from Amazon yesterday and after connecting i am getting only 100Mbps link speed. However i have directly connected the ethernet cable from my ISP provider and link speed shows as 1Gbps. What is the issue , can you please help me fix. 

Please note that my Asus Vivobook Ultrabook do not have a built in ethernet port, hence I bought this.

 

0
0
#12
Options
Re:UE300 TP-LINK Gigabit Ethernet USB Adapter less than 100Mbps
2021-06-23 00:12:29 - last edited 2021-06-23 01:05:48

@Kevin_Z Thanx for your help. I have a Dell Inspiron 15R N5110 and when I disabled the built-in network adapter Realtek PCIe FE Family Controller it worked like a charm!

0
0
#14
Options