set top box problems when deco m4 is in accespoint mode
set top box problems when deco m4 is in accespoint mode
set top box problems when deco m4 is in accespoint mode
2 weeks ago - last edited 2 weeks ago
Model: Deco M4
Hardware Version:
Firmware Version: 1.1.0 Build 20190620 Rel. 45372

My Deco m4 is in access point mode and connected to my router via an ethernet-cable. When i connect my set top box to the Deco also with an ethernet cable i'm experiencing problems with the iptv signal.  When the Deco is  in router mode there's no problem. Also when i connect both Deco and set top box to a separate switch via an ethernet cable no problem. Are there any known issues regarding IGMP Snooping? Any other idea's?

0
0
#1
Options
9 Replies
Re:set top box problems when deco m4 is in accespoint mode
2 weeks ago

@jaaps123 

 

With Deco M4 works as access point, can you get internet from it with computer connected to it? 

 

Have you enabled VLAN ID or IPTV feature when Deco M4 works as a regular wireless router? 

 

Besides, you can contact the tech support of IPTV to verify is there any settings need to be done on the router to make it work.

 

Best regards. 

 

 

0
0
#2
Options
Re:Re:set top box problems when deco m4 is in accespoint mode
2 weeks ago

@Kevin_Z 

With Deco M4 in acces mode i can get internet with a computer connected to it. But watching TV (via set top box) i'm experiencing bad signal quality: delay's and freezes.

In router mode the VLAN and IPTV settings are the default (out of the box) settings, and there's no delays or freezing. But I wish to use the Acces mode.

 

iptv support recommends using a seperate switch supporting IGMP snooping,  but I would like to use the Deco M4 without an additional switch. Deco M4 should theoretically support IGMP Snooping both in router mode and in acces mode, isn't it?

0
0
#3
Options
Re:Re:Re:set top box problems when deco m4 is in accespoint mode
2 weeks ago

@jaaps123 

 

Theoretically, it has nothing to do with the Deco when it works as an access point. It can be regarded as an ethernet cable in that case. 

 

Could you please connect the Deco M4 to the main router and connect the IPTV to the Deco M4 only without any other devices connected, and then verify whether the IPTV works well. 

 

For the IGMP snooping issue, I'm confirming it now.

 

Good day. 

 

 

0
0
#4
Options
Re:Re:Re:Re:set top box problems when deco m4 is in accespoint mode
2 weeks ago

@Kevin_Z 

You mean no wifi connections, only the cable connections router >> M4  >> set top box?

 

regards

0
0
#5
Options
Re:Re:Re:Re:Re:set top box problems when deco m4 is in accespoint mode
2 weeks ago

@jaaps123 

 

Yes, no other devices connected to the Deco M4, except the set top box. And then please verify whether the IPTV works well. 

 

Nice day. 

 

 

0
0
#6
Options
Re:set top box problems when deco m4 is in accespoint mode
a week ago

@Kevin_Z 

with no wifi clients attached, only the set top box connected by ethernet cable to the main deco, same problem. Same thing with no wifi clients attached and no other deco m4 attached.

 

 

regards 

0
0
#7
Options
Re:Re:set top box problems when deco m4 is in accespoint mode
a week ago

@jaaps123 

 

Thanks for your reply.

 

With the set top box connected to the main router directly, bypass the Deco m4 and switch, does it work properly? 

 

What is the model number of it as well?

 

Have you setup any IPTV settings on the main router?

 

Good day. 

 

 

0
0
#8
Options
Re:Re:Re:set top box problems when deco m4 is in accespoint mode
Sunday

@Kevin_Z 

connected to the main router directly everything works fine. It works also fine when connected via a switch (n@#*&$r gs105ev2, supports igmp snooping)

the router/ modem is provided by the iptv & internet provider. I can’t change iptv settings on it, but it uses multicast and vlans (vlan 4 for iptv)

 

i have tested 2 more things to check if the settings made in router mode have any effect when the deco is switched back to access mode.

1. Iptv enabled, bridge mode

2. Iptv enabled, vlan 4, priority 0 

 

after changing back to access mode, the glitches and freezes still occur, these settings have no effect.

 

regards

0
0
#9
Options
Re:Re:Re:Re:set top box problems when deco m4 is in accespoint mode
21 hours ago

@jaaps123 

 

Thanks for your reply.

 

The current issue is a little weird, we have tested that the multicast works well when Deco works in AP mode. 

 

Back to your case, is it possible for you to catch the data packets between the STB and the Deco M4 which works in AP mode?

 

If so, you can give it a go and send us the results. 

 

Best regards. 

 

0
0
#10
Options