How to install Tl-WN822N v5 WiFi adaptor in Kali Linux
How to install Tl-WN822N v5 WiFi adaptor in Kali Linux
How to install Tl-WN822N v5 WiFi adaptor in Kali Linux
2 weeks ago
Model: TL-WN822N
Hardware Version: V5
Firmware Version:

The driver in the tplink website is a beta one and gives me errors when I make it.

I am trying to install it on a freshly downloaded and updated Kali Linux x64 on my laptop.

 

The WiFi adaptor is being detected as wlan1 and monitor mode works fine. But I am not able to connect to a AP even though it is able to scan and show lost of AP. 

 

I installed realtek drivers from GitHub and the WiFi adaptor is showing v4 and still not able to connect to any AP.

 

On windows and Mac it worls fine.

0
0
#1
Options
3 Replies
Re:How to install Tl-WN822N v5 WiFi adaptor in Kali Linux
2 weeks ago

@AndeYashwanth 

 

As an open system, the linux OS is more complicated than Windows or Mac; we will do our best to help, but if still cannot be resolved, it is suggested to ask for some help from linux or github.

 

What is the kernel version of the kali linux laptop? What is the error with the beta driver installed? 

 

Is there any error message if you failed to connect to any AP? Have you ever tried to enter the wifi name and password manually to give it a shot? 

 

Besides, the chipset of the 822N V5 is Realtek RTL8192EU, try to find another driver for your linux laptop.

 

May it work. Good day. 

 

 

 

 

1
1
#2
Options
Re:Re:How to install Tl-WN822N v5 WiFi adaptor in Kali Linux
2 weeks ago - last edited 2 weeks ago

I did a fresh install of Kali linux and it's kernel version is 4.19.0-kali4-amd64.

I upgraded and updated and installed latest linux headers. I also installed dpkg.

I downloaded the driver and tried these commands in the terminal.

 

root@kali:~/Downloads/TP-Link_Driver_Linux_series8_beta/rtl8192EU_WiFi_linux_v5.2.19.1_25633.20171222_COEX20171113-0047# make clean
#make -C /lib/modules/4.19.0-kali4-amd64/build M=/root/Downloads/TP-Link_Driver_Linux_series8_beta/rtl8192EU_WiFi_linux_v5.2.19.1_25633.20171222_COEX20171113-0047 clean
cd hal ; rm -fr */*/*/*.mod.c */*/*/*.mod */*/*/*.o */*/*/.*.cmd */*/*/*.ko
cd hal ; rm -fr */*/*.mod.c */*/*.mod */*/*.o */*/.*.cmd */*/*.ko
cd hal ; rm -fr */*.mod.c */*.mod */*.o */.*.cmd */*.ko
cd hal ; rm -fr *.mod.c *.mod *.o .*.cmd *.ko
cd core/efuse ; rm -fr *.mod.c *.mod *.o .*.cmd *.ko
cd core ; rm -fr *.mod.c *.mod *.o .*.cmd *.ko
cd os_dep/linux ; rm -fr *.mod.c *.mod *.o .*.cmd *.ko
cd os_dep ; rm -fr *.mod.c *.mod *.o .*.cmd *.ko
cd platform ; rm -fr *.mod.c *.mod *.o .*.cmd *.ko
rm -fr Module.symvers ; rm -fr Module.markers ; rm -fr modules.order
rm -fr *.mod.c *.mod *.o .*.cmd *.ko *~
rm -fr .tmp_versions
root@kali:~/Downloads/TP-Link_Driver_Linux_series8_beta/rtl8192EU_WiFi_linux_v5.2.19.1_25633.20171222_COEX20171113-0047# make
make ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/4.19.0-kali4-amd64/build M=/root/Downloads/TP-Link_Driver_Linux_series8_beta/rtl8192EU_WiFi_linux_v5.2.19.1_25633.20171222_COEX20171113-0047  modules

make[1]: Entering directory '/usr/src/linux-headers-4.19.0-kali4-amd64'
  CC [M]  /root/Downloads/TP-Link_Driver_Linux_series8_beta/rtl8192EU_WiFi_linux_v5.2.19.1_25633.20171222_COEX20171113-0047/core/rtw_cmd.o
In file included from /root/Downloads/TP-Link_Driver_Linux_series8_beta/rtl8192EU_WiFi_linux_v5.2.19.1_25633.20171222_COEX20171113-0047/include/osdep_service.h:47,
                 from /root/Downloads/TP-Link_Driver_Linux_series8_beta/rtl8192EU_WiFi_linux_v5.2.19.1_25633.20171222_COEX20171113-0047/include/drv_types.h:27,
                 from /root/Downloads/TP-Link_Driver_Linux_series8_beta/rtl8192EU_WiFi_linux_v5.2.19.1_25633.20171222_COEX20171113-0047/core/rtw_cmd.c:17:
/root/Downloads/TP-Link_Driver_Linux_series8_beta/rtl8192EU_WiFi_linux_v5.2.19.1_25633.20171222_COEX20171113-0047/include/osdep_service_linux.h: In function ‘_init_timer’:
/root/Downloads/TP-Link_Driver_Linux_series8_beta/rtl8192EU_WiFi_linux_v5.2.19.1_25633.20171222_COEX20171113-0047/include/osdep_service_linux.h:299:8: error: ‘_timer’ {aka ‘struct timer_list’} has no member named ‘data’
  ptimer->data = (unsigned long)cntx;
        ^~
/root/Downloads/TP-Link_Driver_Linux_series8_beta/rtl8192EU_WiFi_linux_v5.2.19.1_25633.20171222_COEX20171113-0047/include/osdep_service_linux.h:300:2: error: implicit declaration of function ‘init_timer’; did you mean ‘_init_timer’? [-Werror=implicit-function-declaration]
  init_timer(ptimer);
  ^~~~~~~~~~
  _init_timer
In file included from /root/Downloads/TP-Link_Driver_Linux_series8_beta/rtl8192EU_WiFi_linux_v5.2.19.1_25633.20171222_COEX20171113-0047/include/drv_types.h:30,
                 from /root/Downloads/TP-Link_Driver_Linux_series8_beta/rtl8192EU_WiFi_linux_v5.2.19.1_25633.20171222_COEX20171113-0047/core/rtw_cmd.c:17:
/root/Downloads/TP-Link_Driver_Linux_series8_beta/rtl8192EU_WiFi_linux_v5.2.19.1_25633.20171222_COEX20171113-0047/include/wifi.h: At top level:
/root/Downloads/TP-Link_Driver_Linux_series8_beta/rtl8192EU_WiFi_linux_v5.2.19.1_25633.20171222_COEX20171113-0047/include/wifi.h:1031: warning: "IEEE80211_MAX_AMPDU_BUF" redefined
 #define IEEE80211_MAX_AMPDU_BUF 0x40
 
In file included from /root/Downloads/TP-Link_Driver_Linux_series8_beta/rtl8192EU_WiFi_linux_v5.2.19.1_25633.20171222_COEX20171113-0047/include/osdep_service_linux.h:83,
                 from /root/Downloads/TP-Link_Driver_Linux_series8_beta/rtl8192EU_WiFi_linux_v5.2.19.1_25633.20171222_COEX20171113-0047/include/osdep_service.h:47,
                 from /root/Downloads/TP-Link_Driver_Linux_series8_beta/rtl8192EU_WiFi_linux_v5.2.19.1_25633.20171222_COEX20171113-0047/include/drv_types.h:27,
                 from /root/Downloads/TP-Link_Driver_Linux_series8_beta/rtl8192EU_WiFi_linux_v5.2.19.1_25633.20171222_COEX20171113-0047/core/rtw_cmd.c:17:
/usr/src/linux-headers-4.19.0-kali4-common/include/linux/ieee80211.h:1442: note: this is the location of the previous definition
 #define IEEE80211_MAX_AMPDU_BUF  0x100
 
cc1: some warnings being treated as errors
make[4]: *** [/usr/src/linux-headers-4.19.0-kali4-common/scripts/Makefile.build:309: /root/Downloads/TP-Link_Driver_Linux_series8_beta/rtl8192EU_WiFi_linux_v5.2.19.1_25633.20171222_COEX20171113-0047/core/rtw_cmd.o] Error 1
make[3]: *** [/usr/src/linux-headers-4.19.0-kali4-common/Makefile:1535: _module_/root/Downloads/TP-Link_Driver_Linux_series8_beta/rtl8192EU_WiFi_linux_v5.2.19.1_25633.20171222_COEX20171113-0047] Error 2
make[2]: *** [Makefile:146: sub-make] Error 2
make[1]: *** [Makefile:8: all] Error 2
make[1]: Leaving directory '/usr/src/linux-headers-4.19.0-kali4-amd64'
make: *** [Makefile:1828: modules] Error 2

 

 

________________________________________________________________________________________________________________________

I also installed 2017.1 version which has kernal 4.9 but still dosent work.

 

I also tried using this forum https://forums.linuxmint.com/viewtopic.php?f=239&t=268034&p=1461575&hilit=Rtl8192eu#p1461210

 

sudo apt-get update && sudo apt-get install git dkms build-essential
git clone https://github.com/jeremyb31/rtl8192eu-linux-driver.git
sudo dkms add ./rtl8192eu-linux-driver
sudo dkms install rtl8192eu/1.0

restart

 

But I still cant connect to a wireless AP.

I will tried to mauallly connect to an ap using

nmcli dev wifi connect <mySSID> password <myPassword>

but it still says

Connection failed.

 

0
0
#3
Options
Re:Re:Re:How to install Tl-WN822N v5 WiFi adaptor in Kali Linux
a week ago

@AndeYashwanth 

 

The current official driver does not support the kernel version of your own computer; meanwhile, from the error message you posted, the linux/slab.h. file was missed.

 

To solve it, please find the kmalloc and kfree file and include them to install the driver.

 

Still the same, I'm afraid that there is not much, try to contact the tech support of linux or ask for help from some linux users will be a good choice. 

 

Best regards. 

 

0
0
#5
Options