Archer C60 unable to login via IP address

Archer C60 unable to login via IP address
Archer C60 unable to login via IP address
2019-08-13 18:43:45 - last edited 2019-08-13 19:23:05
Model: Archer C60
Hardware Version:
Firmware Version:

I'm trying to login to my router using its IP address so I can change some of the advanced settings. However, when I type the email/password and click 'Log In' I get a popup after a few seconds saying "Request timed out.". I can log in using the android app so know that the email/password are both correct but am limited as to what settings I can change.

 

Thanks in advance if anyone can help!

Simon

0
0
#1
Options
6 Replies
Re:Archer C60 unable to login via IP address
2019-08-14 02:59:20

@Smithy6682 

 

Please reboot the Archer C60 first; and then try to access the web UI.

 

Meanwhile, is Archer C60 detected as a local device or cloud device on the Tether app? Try to use the default login username and password to give it a go which are both admin. 

 

Or you can change another web browser or device to access it. 

 

Still the same, please reset the router by holding the reset button/hole for 10s with it powered on and then try to change another NTP server and bind the router to the TP-Link ID back. 

 

May it help and have a nice day. 

0
0
#2
Options
Re:Archer C60 unable to login via IP address
2019-08-14 19:10:37

Having exactly the same issue , C60 ..have restarted the router completely but exactly the same thing happens , type in username and password and hit enter and after about 10 - 20 seconds it comes up with a 'request timed out' message .

same with when connecting from a different browser (tried Chrome and Edge), and also from a different machine on the same network.

Same when connecting via tplinkwifi.net or ip address.

Can connect in with the tether app as a local device so username and password is fine

 

 

0
0
#3
Options
Re:Re:Archer C60 unable to login via IP address
2019-08-15 01:25:17

@bob_l 

 

What are the username and password you used? If Archer C60 was detected as a local device on Tether app, try to use default ones, which are both admin. 

 

Still the same, you can hard reset it by holding the reset button/hole for 10s with the router powered on and relogin.

 

After that, you can change another NTP server and correct the time settings of the router. 

 

May it help and have a nice day. 

 

 

0
0
#4
Options
Re:Re:Re:Archer C60 unable to login via IP address
2019-08-20 09:28:43

hi 

the default password /username admin/admin  isnt going to work here , as its'll only accept an email address as a username

(anything else just gives an invalid email format message)

I'd rather not hard reset the modem yet as It means I'll have to set it up from scratch with my internet router and setup ports etc again which is a big job

Is there a way to telnet onto it to reset the ntp settings ?

(if its a time server issue thats causing the problem)

0
0
#5
Options
Re:Re:Re:Re:Archer C60 unable to login via IP address
2019-08-21 01:11:50

@bob_l 

 

Hello, the Archer C60 does not support telnet. And as my knowledge, it has nothing to do with the NTP settings.

 

Meanwhile, you mentioned that the username should be an email address, may I know have you ever bound this Archer C60 to your TP-Link cloud account? 

 

If so, you can give it a go; otherwise, I'm afraid that we have to hard reset the router to access the web UI.

 

Good day. 

 

0
0
#6
Options
Re:Re:Re:Re:Archer C60 unable to login via IP address
2019-11-02 23:13:56
Ok so it was an NTP issue! FYI what causes this is the time/date being wrong on the c60. It cant connect to the tplink cloud server to confirm the admin username and password if c60's time and date is out .The NTP server's listed in its settings should help it keep correct time , but in my case they didnt (when I finally did get in the date was august 2016!!!). THE FIX FOR THIS!! is to disconnect the c60 from the internet (i.e. literally unplug the internet router cable) , this makes the c60- fall back to stored credentials , which lets you connect in. (you can plug the internet cable back in then) Then ..under advanced -> system tools-> time settings you can either set the date manually or add in working NTPs (eg : 0.pool.ntp.org) , then hit obtain, the time should update, then hit save. I'm just adding this here incase anyone has this problem in future.
1
1
#7
Options