Deco M4 slow speed

Deco M4 slow speed
Deco M4 slow speed
2019-11-04 14:55:31
Model: Deco M4
Hardware Version: V1
Firmware Version:

Hello all!

 

 I have installed 2 deco M4 units. I have a 500Mbps connection. When I plug the ethernet cable that feeds my main M4 node (that comes from the router) directly to a laptop I can get 499Mbps, but when I connect to the main M4 node with an ethernet cable I only get 160 Mbps, is this normal? Also wifi connection with the laptop (AC1200) near the main M4 node I can't get more than 150Mbps on 5Ghz, is this normal too? The firmware is the latest...

 

Thanks

0
0
#1
Options
44 Replies
Re:Deco M4 slow speed
2019-11-05 02:26:51

@JFil 

 

The Deco M4 has the gigabit ethernet port, compared the bandwidth and actual speed, we can do some troubleshooting first and try to fix it. 

 

What is the current network diagram? 

 

With your device connected to modem and main Deco by wired cable directly, please click here to check the wired negotiation speed.
Note: The steps are the same, while you need right click on local area connection or ethernet connection.         
                                                                  
Try to swap the locations of the 2 Deco M4 and verify whether it works. To configure slave Deco as main Deco, you can refer to : https://www.tp-link.com/support/faq/2400/

 

Try to change DNS server under advanced>>IPv4>>Internet connection type and uncheck obtain DNS automatically and change the primary DNS to 8.8.8.8 and click save.

 

And try to disable fast roaming and set QoS as standard and clear all the high priority rules.

 

After that, please run the speed test again and check whether it work.

 

Have a great day.

 

0
0
#2
Options
Re:Deco M4 slow speed
2019-11-05 14:14:20

@Kevin_Z 

Hello

 

My main deco is connected directly to a port on my router via ethernet cable. Connecting that cable direcly to my pc ethernet adapter I get 499Mbps. Connecting that cable coming from my router to port1 on main deco and my pc ethernet adapter to port2 on main deco I get 280Mbs (so almost half lost).

 

Wireless speeds:

Samsung Galaxy A50 connected wiressely near main deco: connection speed 433Mbps on android info tab, I get Wifi speed 180Mbps.

 

Change DNS and same results.

 

Best Regards

0
0
#3
Options
Re:Deco M4 slow speed
2019-11-06 03:00:52

@JFil 

 

With PC -- main Deco--router connected by wired cable, please click here to check the wired negotiation speed of the PC. 

Note: Steps are the same, while you need click on ethernet connection. 

 

Try to swap the locations of the 2 Deco M4 and verify whether it works. 

 

Besides, you can change another ethernet ports on both router and Main Deco to connect them  together. 

 

Good day. 

0
0
#4
Options
Re:Deco M4 slow speed
2019-11-19 23:12:09

@JFil is your NIC card capable of such speeds?

0
0
#5
Options
Re:Deco M4 slow speed
2019-12-05 20:35:22

The same is happening to me. If I connect either wirelessly or wired, I get half the speed I get when connecting directly to my modem.

Tried setting up bandwidth in QoS, setting my device with high priority, etc. but nothing seems to work. Keep in mind you can't choose a QoS profile in M4, you just get device QoS

0
0
#6
Options
Re:Deco M4 slow speed
2020-01-05 09:52:30

Has anyone had any luck solving this issue?

0
0
#7
Options
Re:Deco M4 slow speed
2020-01-14 12:41:05

@JFil I also experience this issue. Full speed (300Mbps+) directly connected to Virgin Super Hub v3 in modem mode. QoS switched off for all devices.

 

Half speed (if that) when connected to wired ethernet through Deco M4 (yes my device has Gigabit LAN). Will try suggestion of swapping Deco units (https://www.tp-link.com/uk/support/faq/2400/) round (thought they were all identical) to see if that helps and report back.

0
0
#8
Options
Re:Deco M4 slow speed
2020-01-20 09:45:09

@Andy_H any luck?

0
0
#9
Options
Re:Deco M4 slow speed
2020-02-01 15:34:42

@JFil 

 

Remember to check the Deco M4 setting under the QOS option. There is a spot to enter the total bandwidth up/down.

1
1
#10
Options
Re:Deco M4 slow speed
2020-03-04 01:36:24

@JFil 

 

Exact same problem here! I think it's disapointing buying something to improve your internet and then get half of your speed.

 

I'm surprised that other people have this issue?

 

Did anyone have any luck trying to solve this??? 

0
0
#11
Options