TL-WR840N cuts speed (wifi)

TL-WR840N cuts speed (wifi)
TL-WR840N cuts speed (wifi)
a week ago
Model: TL-WR840N
Hardware Version: V6
Firmware Version: 0.9.1 4.16 v0283.0 Build 180622 Rel.55259n

Model purchased around 5 months ago. All worked fine until now.

 

Now I notice that after certain intervals of time after I connect to wifi network the router cuts down speed, sometimes pages just got stuck. I notice a torrent download goes down from 5Mb/s to around and below 300Kb/s. It does not reconnect automatically though. Once I manually click Disconnect button and then Connect - it works at normal speed immediately and for some time period until it is stuck at low speed again.

I tested this using cable connection. Cable shows stable speed.

 

Can this be fixed at home or needs service center to check the device?

0
0
#1
Options
2 Replies
Re:TL-WR840N cuts speed (wifi)
a week ago

@ArtemD 

 

May I know how often does this issue happen? 

 

What is the actual wifi speed you can get from the TL-WR840N? What about the wired speed? Are they normal compared with the bandwidth you paid for your ISP? 

 

Try to customize the wireless settings of the router, like wireless channel and channel width. 

 

And please ensure that the firmware is up to date. 

 

Good day. 

0
0
#2
Options
Re:TL-WR840N cuts speed (wifi)
a week ago - last edited a week ago

@Kevin_Z 

 

1. Hard to say how often. I would say it holds normal speed/response for 20-40mins and then I feel lags and slow down.

2. https://www.speedtest.net/ shows:

- Download 42.32Mbps

- Upload 42.14 Mbps

3. Firmware was updated to most up to date - did not work

4. Played with channels (was channel 11), set channel 1. Did not help much.

 

I was googling for possible problems with my wifi card on notebook (lenovo e495) and tweeked it as well. Stiil testing results.

0
0
#3
Options