tpPLC utility for MAC 10.15

tpPLC utility for MAC 10.15

58 Reply
Re:tpPLC utility for MAC 10.15
2020-07-11 11:25:13

@Kevin_Z 

I am running macOS 10.15.5 and have the downloaded (beta?) tpPLC version V1.2.3596.1 -- it has a watermark "Confidential Only For Test" and provides some diagnostic information.  It, however, does NOT permit me to upgrade the firmware on my recently purchased TL-PA9020P AV2000 devices.

 

When will there be a production version available, or at least a version that permits firmware upgrade installation?  This situation has lasted for approximately a year, with tp-link continuing to sell new products to clients without providing them with a means to upgrade firmware.

  0  
  0  
#38
Options
Re:tpPLC utility for MAC 10.15
2020-07-13 06:21:06

@AndreasW 

Hello,

 

What error information did you have when you try to upgrade the firmware? May I have a photo of it?

 

Are you able to upgrade the firmware on this Utility before?

 

Please try to uninstall it and install it again:

 

https://static.tp-link.com/2019/201911/20191128/PowerlineUtility-ForMACOS.zip

 

Thank you for your cooperation and have a nice day!

 

Meet Us at CES 2023 | Featuring Wi-Fi 7, EasyMesh, Matter, and a New HomeShield Security
  0  
  0  
#39
Options
Re:tpPLC utility for MAC 10.15
2020-07-13 09:26:25 - last edited 2020-07-13 09:27:20

@Solla-topee 

 

Thank you for the reply.  I uninstalled my existing version of tpPLC and installed it afresh using the link you posted.

 

With the newly installed tpPLC app on my macOS 10.15.5, I observe the same "update failed" error as before, when trying to install the firmware update using the file BCM60500_v4.0.1d_20190523_US_PA9020Pv4.0.ggl

 

(For information, my current installed firmware is 3.2.4_902104_190506_901)

 

No, I was never able to upgrade the firmware, neither on this device nor using this application, ever before.

 

I have attached a file showing a screenshot photo of the error.

 

Best regards,

Andreas

 

File:
tpPLC error.pngDownload
  0  
  0  
#40
Options
Re:tpPLC utility for MAC 10.15
2020-08-07 10:46:05

@Kevin_Z 

 

SO im running 10.15.5 and get this app running by opening under gen and allow

 

get the screen with both my V1 TL-PA4010

 

For some reason last few weeks only been getting 5-10mb from the homeplugs

Nothing has changed and before was 25-35mbs

 

On opening the app, i see no speed or anything listed ?

 

Every option i pick says failed?

 

 

  0  
  0  
#43
Options
Re:tpPLC utility for MAC 10.15
2020-09-08 09:16:32

@Kevin_Z 

 

Hi Kevin,

 

The beta version has an issue that is affecting performance. I cannot turn off "Lower PLC-to-VDSL Interference Mode" using this version of the app. While you can toggle the setting, it will not in fact turn the setting back off—the reported transfer speed is about half of what it should be (314 Mbps vs 653 Mbps). In order to correct this, I had to install the Windows version of tpPLC in a virtual machine in order to revert the setting.

 

Thanks,

Jasper

  0  
  0  
#44
Options
Re:tpPLC utility for MAC 10.15
2020-09-09 12:24:51

@Kevin_Z and @Solla-topee 

 

My Mac is now at version 10.15.6 and the "beta" Mac version of tpPLC is still not able to perform a firmware update on my TL-PA9020P(US) Ver. 4.0 kit.

 

As a workaround, similar to an earlier poster, I also set up a Windows10 implementation in a Virtual Machine on my Mac, and communicated with the pair of powerline adapters using the Windows version of the tpPLC utility.  Using this approach, I attempted to update the firmware from 3.2.4 to 4.0.1d using the available .ggl file provided by your support site.  The firmware update appeared to proceed successfully; however, when I then went to check the "Version", using either the Windows or Mac implementation of the tpPLC utility, they both still showed the firmware as 3.2.4_902104_190506_901.

 

Please advise.

 

Best regards,

Andreas Warburton

 

  0  
  0  
#45
Options
Re:tpPLC utility for MAC 10.15
2020-09-11 16:21:56

@Kevin_Z 

 

Do you happen to have an update on this link? as I am unable to open it.

  0  
  0  
#46
Options
Re:tpPLC utility for MAC 10.15
2020-09-16 23:29:00

I've been having issues with power saving mode problem since I got my TP-WPA8630P KIT since I bought it. It's very frustrating, even more so when working from home these days. We only have Macs and Linux machines in the house so don't have the option of trying the Windows utility.

 

Like others we have issue running the Mac utility, including the latest one given as a link in this thread. I tried to update the firmware but go a 'Update Failed'. Even trying to set any of the QoS values, changing the Lower PLC-to-VDSL interference mode, or the Power Saving Mode returns a very uninformative 'Failed' error message. I can't even run the Windows version of tpPLC on the Linux machine under Wine as the 'packet.dll' is not available.

 

This is very frustrating, need a fix, and more than happy to throw the powerlinks out the window and go get something that is supported by the vendor.

 

  0  
  0  
#47
Options
Re:tpPLC utility for MAC 10.15
2020-09-24 08:39:27

@KlingonSpy it didn't for me. Same rubbish prompting for admin pw then crashing

  0  
  0  
#48
Options
Re:tpPLC utility for MAC 10.15
2020-10-04 02:56:23

@Kevin_Z 

 

I was able to download the tpplc utility for MAC 10.15. It runs and can see my TL-WPA4220  AV500 wifi access point plc adapter. However, the settings in the app does not let me

 

   a. change the wifi ssid

   b. change the IP address of the device

 

These options do not appear in either the Basic or Advanced menu/icons.

 

I have tried connecting directly with the device using wifi and typing in "tplinkplc.net" in the browser, but it does not work. It says I am connecting directly to my main router, which I am not doing. I think it is because my main router and the default IP address of the device are the same (192.168.0.1)

 

Is there any other way to change the IP address and ssid of the AV500 PLC wifi access point?

 

Miguel

  0  
  0  
#49
Options
Related Articles