Archer C6 v.2 firmware issue in Accces Point mode

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
12

Archer C6 v.2 firmware issue in Accces Point mode

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Re:Archer C6 v.2 firmware issue in Accces Point mode
2020-03-28 10:11:41

@FlorinHiT There are firmware upgrades coming / promised (OneMesh, WPA3, etc.)

 

It's a pity because currently there's nothing similar for the price and as access point works great, except for that. Turns out some competitors' routers have the same problems when working as access point or not main router. They use to relay on DHCP server data, when they're not the DHCP server they're blind.

 

It must be something very easy to fix if the feature broke after a power failure. Maybe there's a race condition somewhere when starting up or depends on some initialization that sometimes fails on boot and doesn't retry. I haven't been able to make the list work again, even switched to router mode, there the Wireless Station list is perfect, but that data is not available in the client list or Tether App, which still displays an empty list (or just shows the device used to configure the router)

  0  
  0  
#12
Options
Re:Archer C6 v.2 firmware issue in Accces Point mode
2020-03-31 09:42:13

@FlorinHiT See my reply to this thread

 

I think I've found the bug is related to DHCP, I got my list back while playing setting the DHCP Server to On, Off and Auto. Every time it was in Off, a reboot would result in an empty list. Setting it to Auto would get the list back. Try!

  1  
  1  
#13
Options
Re:Archer C6 v.2 firmware issue in Accces Point mode
2020-04-04 12:30:19

@mocelet 

Indeed with this setting discovered by you, the problem of the connected clients was practically solved.
Congratulations and thank you for your help. Given that you moved faster than TP Link moderators, I think you deserve at least thanks to them.

Thank you again.

mocelet wrote

@FlorinHiT See my reply to this thread

 

I think I've found the bug is related to DHCP, I got my list back while playing setting the DHCP Server to On, Off and Auto. Every time it was in Off, a reboot would result in an empty list. Setting it to Auto would get the list back. Try!

 

  1  
  1  
#14
Options
Re:Archer C6 v.2 firmware issue in Accces Point mode
2020-04-04 12:38:10

@Kevin_Z  

The problem with this bug was discovered and shared by the mocelet.
Thank you in this way. The same thing should be done by moderators on this forum.

 

The problem was solved by checking the AUTO box in the menu Network --> DHCP Server.
  0  
  0  
#15
Options
Re:Archer C6 v.2 firmware issue in Accces Point mode
2020-04-04 13:11:53 - last edited 2020-04-04 13:34:15

@FlorinHiT You're welcome, however it's just a workaround with tradeoffs, their engineers have to fix it.

 

DHCP Auto is evil, pretend there's a power outage and, upon restore, the main router takes more time to boot than the Archer. The Auto setting will check that there's no DHCP server in the network and launch its own, and later the main router's DHCP server will launch as usual resulting in a network madness with two DHCP servers serving the same range.

 

Please @Kevin_Z , notify your engineer that setting DHCP Server Off and rebooting breaks the client list that is shown in both the web UI and Tether App.

 

 

  0  
  0  
#16
Options
Re:Archer C6 v.2 firmware issue in Accces Point mode
2020-04-26 04:15:11

I have the same issues with C60 v.3 (US), client list not shows at all on AP MODE

 

I have listed here https://community.tp-link.com/en/home/forum/topic/205242

 

I have WR840N on AP MODE and run flawlessly rather than C60

 

much cheaper but much powerfull than C60

 

.: udah capek ngoceh gratis gak dapat cendol :. Router: HEX RB750GR3 AP: Archer C60 and WR840N
  0  
  0  
#17
Options
Re:Archer C6 v.2 firmware issue in Accces Point mode
2020-05-24 06:06:57

@FlorinHiT 

I have the same problem with only 4 wired and 3 wireless clients. Setting DHCP to auto is not a solution as it is interferring with the primary router DHCP

I have last firmware 1.3.0 Build 20200402 rel.52000(4555)

  0  
  0  
#18
Options
Re:Archer C6 v.2 firmware issue in Accces Point mode
2021-05-06 19:48:39 - last edited 2021-05-10 20:29:37

@FlorinHiT 

 

Same problem here, the C6 firmware quality is quite horrible. My C6 V2 EU runs in Access Point mode on the latest official firmware version: 1.3.6 Build 20200902 rel.65591(4555).

The problems I encounter:
- System Log does not work (No items are added and shows only items with date 2020-09-02, the date I started to use this router is 2021-05-02 )

- Wireless Clients do not show up (This mentioned problem in this topic)

 

I've done a hard reset but this didn't solve any of the problems.

  0  
  0  
#19
Options
Related Articles