New Firmware - Deco P9

Re:New Firmware - Deco P9
2020-05-09 23:35:05

@HopSaSam 

Really useful information appreciate you taking the time to reply.

 

I just tried one more time to set up my 6 x P9 network, all have been upgraded to the beta firmware.  I also set up the units in the same room so they are all close to the main unit which is in access point mode connected to my Apple router.  All was stable and working fine with fast internet speeds (naturally I guess as close by!) but after about an hour or so I noticed that the automatic wireless light switches had all diappeared from the wireless network.  When I ran a utility (Inssider) to see the wireless networks transmitting basically the TP Link 2.4 Hz network has disappeared so the only visible TP Link wireless network is the 5 Ghz.  Those adapters and a few other devices I have can only connect to 2.4.  I also notice that two of the units has now gone flashing red.

 

I am thinking its time to give up but wondered if this is something anyone else has seen and any pointers as to the cause?

 

Thanks  

0
0
#12
Options
Re:New Firmware - Deco P9
2020-05-13 12:04:18

@HopSaSam 

Thanks for the link to the beta firmware, seems to be better and more stable but still getting intermittent issues with wireless internet access, but hard to know whether that is conflicting wireless networks, noise on the main electricity etc.  It seems that my set up works OK with three units but as soon as I add the other 3 that I have things go pear shaped, mainly in the form of some of the P9's dropping off connection and sometimes not coming back without restarting them.  I suspect it is because the wireless connectivity to each other is weak or broken and the powerline is not working well on certain circuits and locations.

 

Question I have is whether I can get hold of the original firmware file in case I decide to return the units as would want to return them to factory config.  TP Link support say that there is no firmware for the P9 to provide or download and that it can only be updated via the app, which we know is not the case thanks to the beta firmware and tools to update.  

 

If you or anyone knows where I can get the original version of the firmware in the form of a .bin file I can try and update backwards?

 

Otherwise I will keep trying to test the new beta and report back

0
0
#13
Options
Re:New Firmware - Deco P9
2020-05-13 12:34:18

@GrahamPat 

 

Check the support page for your country. I seem to only find an even older version of the firmware in the support page for my country:

 

https://www.tp-link.com/pt/support/download/deco-p9/#Firmware

 

Maybe you can update to that one, and then it will receive the current official one via the app.

0
0
#14
Options
Re:New Firmware - Deco P9
2020-05-14 22:46:21

@jpasan 

Thanks for the information on the firmware, interesting that the UK support site does not have any firmware file available.

0
0
#15
Options
Re:New Firmware - Deco P9
2020-05-16 16:55:55

@timp78

 

I just updated mine to the beta firmware today. All seems to work well, so far.

 

It's nice to have more options to configure and additonal information to see what's going on.

 

I was also able check the Web Interface using Firefox. This is router mode. Strangely the CPU meter kept saying it was at 100% usage, which isn't a good thing. Some infinite loops must be running.

 

It's just been one day, but they might as well release as it is. It's not worse than the official one, which is more than one year old now.

0
0
#16
Options
Re:New Firmware - Deco P9
2020-05-16 18:08:18

@jpasan 

 

Check your logs, I'm constantly getting the following error ("daemon.err /usr/bin/apsd: apsd_get_active_ports:214: Error: No such interface 24" appear in log files?) and also seeing 100% CPU utilisation. Wondering if the two are connected, but have yet to identify how to resolve the error.

0
0
#17
Options
Re:New Firmware - Deco P9
2020-05-16 18:57:55

@FireDZ 

 

I see no errors in my logs. Only in the DEBUG option something is constantly repeating:

 

Sat May 16 19:54:07 2020 user.debug syslog: dhcp6_reset_timer: reset a timer on br-wan, state=SOLICIT, timeo=99, retrans=113160
Sat May 16 19:54:07 2020 user.debug syslog: copy_option: set client ID (len 10)
Sat May 16 19:54:07 2020 user.debug syslog: copy_option: set server ID (len 10)
Sat May 16 19:54:07 2020 user.debug syslog: copyout_option: set status code
Sat May 16 19:54:07 2020 user.debug syslog: copyout_option: set identity association
Sat May 16 19:54:07 2020 user.debug syslog: copy_option: set elapsed time (len 2)
Sat May 16 19:54:07 2020 user.debug syslog: copy_option: set option request (len 4)
Sat May 16 19:54:07 2020 user.debug syslog: copy_option: set vendor class (len 4)
Sat May 16 19:54:07 2020 user.debug syslog: client6_send: send request to ff02::1:2
Sat May 16 19:54:07 2020 user.debug syslog: dhcp6_reset_timer: reset a timer on br-wan, state=REQUEST, timeo=360, retrans=32400
Sat May 16 19:54:07 2020 user.debug syslog: copy_option: set client ID (len 10)
Sat May 16 19:54:07 2020 user.debug syslog: copy_option: set server ID (len 10)
Sat May 16 19:54:07 2020 user.debug syslog: copyout_option: set status code
Sat May 16 19:54:07 2020 user.debug syslog: copyout_option: set identity association
Sat May 16 19:54:07 2020 user.debug syslog: copy_option: set elapsed time (len 2)
Sat May 16 19:54:07 2020 user.debug syslog: copy_option: set option request (len 4)
Sat May 16 19:54:07 2020 user.debug syslog: copy_option: set vendor class (len 4)
Sat May 16 19:54:07 2020 user.debug syslog: client6_send: send request to ff02::1:2

 

 

0
0
#18
Options
Re:New Firmware - Deco P9
2020-05-16 22:35:37

@jpasan 

I upgraded the firmware and noticed the same errors and 100% processor use.  My three units still intermittent disconnecting, i think wireless connectionbetween the units is not very strong and seems powerline not working to keep them connected.  I have since tried another solution the Ubiquiti Amplifi HD Games edition a nice looking cube router and two wireless adapters, so far it is fantastic.  i could get connected to the router on its own everywhere in my house without using the two adapters.  when i added the two adapters in the hall and landing the speed in every room is all 100+ mbps.  The app is great, full of information.  It really looks worlds ahead and refecting the business grade expertise of Ubiquiti.  It is expensive but so far worth it.  Plug and play up and running in an hour.  

 

 

0
0
#19
Options
Re:New Firmware - Deco P9
2021-02-01 11:06:26

@timp78 

 Just received a firmware update. V1.1.3 Build 202001228 rel 55057.

I run in  AP mode so I can't say anything about improvements. When there are problems, I will report back here. 

0
0
#20
Options