Signal LED blinking and no internet connection

Signal LED blinking and no internet connection
Signal LED blinking and no internet connection
2020-10-24 21:57:10
Model: TL-WA850RE
Hardware Version: V1
Firmware Version: Latest

Hello guys 

These days am having a problem with my tplink extender that even in related forum topics can't find any solution.

 

The problem is that when connecting my extender with the router after a while or sometimes after hours the led light of the the signal strength starts flashing -bliking as a result there is no internet connection .I have to take off the power and plug it back in the extender to go all the way again that I described and so on .

 

What might it be ? Is the extender dead ? Should I buy new one ?

 

 

Well I can't show the flashing thing but the led lights in the corner up and left are flashing 

0
0
#1
Options
3 Reply
Re:Signal LED blinking and no internet connection
2020-10-26 03:26:11

@GTR-890 

Good day,

Thanks a lot for your time and patience.

Sorry for the delay.

How long have you had the extender and when did this issue start?

 May I know the model number of your home router as well?

If you did not unplug it and plug it back, would it blink all the time?

Have you factory reset the extender from scratches and set it up again to have a look?

Thanks a lot.

0
0
#2
Options
Re:Signal LED blinking and no internet connection
2020-10-28 09:41:55

@Solla-topee 

Solla-topee wrote

@GTR-890 

Good day,

Thanks a lot for your time and patience.

Sorry for the delay.

How long have you had the extender and when did this issue start?

 May I know the model number of your home router as well?

If you did not unplug it and plug it back, would it blink all the time?

Have you factory reset the extender from scratches and set it up again to have a look?

Thanks a lot.

I have this extender years now and it started blinking for about 1-2 months now .The model is TL-WA850RE .I have done lots of factory resets but still the same .

What else can I do ? Should I replace it because maybe it's old or that's not a problem ?

0
0
#3
Options
Re:Signal LED blinking and no internet connection
2020-10-30 06:52:38

@GTR-890 

Good day,

Thank you for your kind reply.

It has large possibility that the range extender might be broken and needs to be replaced for a new one;

Thanks a lot for your understanding and support.

0
0
#4
Options