iPhone shows as connected but has no LAN or Internet access and not appearing in router status table

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
iPhone shows as connected but has no LAN or Internet access and not appearing in router status table
iPhone shows as connected but has no LAN or Internet access and not appearing in router status table
2021-01-05 08:52:29 - last edited 2021-01-21 09:15:00
Model: Archer C60
Hardware Version: V3
Firmware Version: 1.1.0 Build 20191106 rel.36548(4555)

I have an iPhone XR (latest IOS) and an Archer C60 V3 broadcasting only 5ghz WiFi.

 

Security: WPA2-PSK (AES)

Channel: Auto

Channel Width: Auto

 

iPhone connects fine to the router and receives IP address etc. After a few hours of not using the iPhone, Internet and LAN are not accessible, but iPhone still has the same IP address, dns, etc. and shows as connected.

 

So, I login to my router from my PC and find that the iPhone is not even showing in the table of connected clients, as if the router kicked it off or something. In the DHCP lease table, my iPhone still has 37 hrs of lease time left. It is confusing me why the iPhone shows as connected to WiFi but is not showing in the router's connected clients table.

 

The only way to solve this issue is to turn WiFi off and on again on my iPhone. Then it appears again on the router's status page and I can access LAN and Internet. 

 

I tried to debug from router's side but for some reason, the Archer C60 does not log DHCP requests and other LAN activities. 

 

Didn't experience this issue with my iPhone before on other networks.

 

Did anyone else experience a similar issue? Also, does this seem like a problem related more to my iPhone not behaving correctly (as a result of IOS update maybe), or is it just router related?

0
0
#1
Options
1 Accepted Solution
Re:iPhone shows as connected but has no LAN or Internet access and not appearing in router status table-Solution
2021-01-21 09:14:54 - last edited 2021-01-21 09:15:00

@Kevin_Z 

 

Issue was not related to TxBF and MU-MIMO thankfully. I think it is just related to my phone only.

 

However, two days ago, I noticed there was a cloud firmware update for my Archer C60 (new firmware was 1.2.0 Build 20201231 rel.39772) and I applied the update.

 

I also manually updated my Archer VR600 to latest beta firmware: 4.0.0.9.1 (200701)

 

After doing these updates, I haven't noticed my phone losing access to internet and LAN in the past two days so I think all is good now.

 

Thank you !

Recommended Solution
0
0
#9
Options
9 Reply
Re:iPhone shows as connected but has no LAN or Internet access and not appearing in router status table
2021-01-06 06:55:42

@hass_m 

 

Are you able to ping the C60 on this iPhone XR when it is not accessible to the internet and LAN? Can you ping it on the C60 System Tools>>Diagnostics page?

 

Are there any other devices or iPhones having the same issue? 

 

What if you disable the Private MAC address on the iPhone XR? You can check this: https://support.apple.com/en-us/HT211227.

0
0
#2
Options
Re:iPhone shows as connected but has no LAN or Internet access and not appearing in router status table
2021-01-06 08:07:36

@Kevin_Z

 

I am unable to ping the c60 from my iPhone XR when this issue occurs, but haven't tried pinging the iPhone from the C60's Diagnostics page. Will try that next time when the issue happens.

 

So, far it is just my iPhone, as I always keep it connected to the WiFi, most of the other people in the house put their phones on airplane mode when sleeping and reconnect in the morning.

 

I heard about the new Private MAC addresses in the new IOS and about the issues it can cause, so I disabled it first thing when I updated software, so it's not it.

 

I reset my network settings on iPhone yesterday, because I read that it could be a VPN configuration that is causing this (even though my VPN was off before the issue occurs), and so far internet and LAN still accessible after leaving iPhone locked for 6+ hours. Will see how it goes for the rest of the week.

3
3
#3
Options
Re:iPhone shows as connected but has no LAN or Internet access and not appearing in router status table
2021-01-08 16:42:40

@Kevin_Z 

 

Okay, it happened again, after leaving my iPhone locked for 2 or 3 hours. Tried to ping it from C60: it sent 4 pings to the iPhone and none of them had a reply.

 

iPhone still shows as connected to the router, with ip address and everything, but no access to LAN or internet.

 

For more detail, I noticed this problem started happening after cascading routers as we needed two separate networks in the house, both with different SSIDs

 

Main network connected to DSL

Router: tp-link archer vr600 v2

IP / DHCP range: 192.168.1.100 - 192.168.1.199

 

2nd network (WAN port connected to archer vr600's LAN port):

Router: Archer C60 v3

DNS (for router's WAN): 192.168.1.1 (primary) and 8.8.8.8 (secondary)

IP / DHCP range: 192.168.2.100 - 192.168.2.199

DNS given to clients: 192.168.2.1 (primary) and 8.8.8.8 (secondary)

 

 

Archer C60 has a static WAN IP of 192.168.1.2 (so it isn't affected by QoS or other rules on vr600)

DMZ host is enabled for 192.168.1.2

 

So far, only my iPhone is affected. Don't know if it is a problem with this setup, or just my iPhone?

 

0
0
#4
Options
Re:iPhone shows as connected but has no LAN or Internet access and not appearing in router status table
2021-01-08 17:42:48

Seems like other people are having the same issue on latest IOS for iPhone

 

Are people still having wifi issues on iOS 14.3? : ios (reddit.com)

 

ios 14.3, 12 pro max wifi idle connectivity issues. : ios (reddit.com)

 

The weird thing is, it never happened to me before on previous versions of IOS 14 and I tried: 

  1. Disabling private mac address
  2. Resetting network settings (then disabling private mac address again when reconnecting to my separate networks, i mostly use second C60 network and I notice the wifi issue there)

 

0
0
#5
Options
Re:iPhone shows as connected but has no LAN or Internet access and not appearing in router status table
2021-01-11 03:27:04

@hass_m 

 

Have you confirmed this issue with Apple support? It is suggested to seek some suggestions from Apple, as this issue only happens on it, and there are others customers reporting it.

 

Also, you can try to connect the XR to the VR600 wireless network directly to check if there is an issue. You can also test it with other wireless networks.

0
0
#6
Options
Re:iPhone shows as connected but has no LAN or Internet access and not appearing in router status table
2021-01-12 11:57:25

@Kevin_Z 

 

I posted on Apple Support Community Forum, but got little help.

 

I think I know what the issue might be: The Archer C60 V3 has TxBF,MU-MIMO feature, which I had enabled, and in this post here:

 

https://forums.macrumors.com/threads/disconnects-from-wifi.2224853

 

they mention that disabling this feature helped them. So I did the same, and so far, not having any issues. Will wait and see if that completely solves it. It would also explain why I wasn't seeing this problem with the VR600 V2, as it doesn't have this feature.

3
3
#7
Options
Re:iPhone shows as connected but has no LAN or Internet access and not appearing in router status table
2021-01-13 07:46:10

@hass_m 

 

Great job. yes

 

Please monitor if the issue is fixed by disabling TxBF and MU-MIMO, if yes, please mark this as the Recommended Solutions, which may help others more efficiently.

 

Thanks a lot.

0
0
#8
Options
Re:iPhone shows as connected but has no LAN or Internet access and not appearing in router status table-Solution
2021-01-21 09:14:54 - last edited 2021-01-21 09:15:00

@Kevin_Z 

 

Issue was not related to TxBF and MU-MIMO thankfully. I think it is just related to my phone only.

 

However, two days ago, I noticed there was a cloud firmware update for my Archer C60 (new firmware was 1.2.0 Build 20201231 rel.39772) and I applied the update.

 

I also manually updated my Archer VR600 to latest beta firmware: 4.0.0.9.1 (200701)

 

After doing these updates, I haven't noticed my phone losing access to internet and LAN in the past two days so I think all is good now.

 

Thank you !

Recommended Solution
0
0
#9
Options
Re:iPhone shows as connected but has no LAN or Internet access and not appearing in router status table
2021-01-21 10:20:06

@hass_m 

 

Thank you very much for this valued update, it's glad to know that the issue was resolved with the latest firmware.

 

Have a nice day.

0
0
#10
Options