RE650 extender showing obtaining IP address/IP configuration failure in andriod phones

RE650 extender showing obtaining IP address/IP configuration failure in andriod phones
RE650 extender showing obtaining IP address/IP configuration failure in andriod phones
2021-01-14 08:31:16
Model: RE650
Hardware Version: V1
Firmware Version: 1.0.9 Build 20201112 Rel 66232 (6985)

Hello ,

 

Im not able to connect my andriod phones to the extender wifi. Its showing IP address obtaining and later fails with IP configuration failure. Sometimes it connects after waiting for 15-20 mins. I have changed the settings of DHCP in the extender to auto,on,off but still same issue. If i give static IP in the phone it works fine. In laptop its working fine. Issue is only for mobile phones. Speed and coverage is excellent. Can you please help.

0
0
#1
Options
5 Reply
Re:RE650 extender showing obtaining IP address/IP configuration failure in andriod phones
2021-01-15 07:43:12

@Rthomas 

Thanks for your patience.

May I know the model number and operating system of your smartphone?

No matter the DHCP is auto/on/off, the error message is almost the same: IP configuration failed , right?

Did you have the same issue on both 2.4ghz and 5ghz?

By the way, have you set up the MAC filtering on the main router?

 

Thank you and wait for your reply.

0
0
#2
Options
Re:RE650 extender showing obtaining IP address/IP configuration failure in andriod phones
2021-01-15 08:22:05

@TP-Link  1)My phone model is nokia 8 sirroco and operating system is Andriod 10 but this is happening to all phones not specific to mine. Oneplus 6T etc.

2)Yes correct even if DHCP is off.on.auto this issue is  happening. 

3) Now connection is router to extender with 5Ghz and extender to clients is 2.4Ghz. I remember trying to select both bands and checking it out.

4) I have not setup any filtering on the main router other than recommended channels provide by tp link. 

2.4ghz
channel = 11

5ghz
channel ==44

 

When i give static ip in the phone, its working fine not issue. But in re200 which i had earlier i did not face these issues.

 

0
0
#3
Options
Re:RE650 extender showing obtaining IP address/IP configuration failure in andriod phones
2021-01-15 16:49:09

@TP-Link Today once while i was using laptop internet was not working even though it was connected to extender wifi. Tried rebooting the laptop, extender and modem but same issue. When i checked the properties of the extender wifi in laptop, it was assigned ipv6 address via DHCP. Later after sometime it started after sometime somehow. Dhcp v6 is enabled on the main router when i checked and on extender dhcp is off. Im not sure what is happening. It seems laptop also i might need to give manual.IP. DHCP on the extender is doing something even though its off. Is it a product issue?

0
0
#4
Options
Re:RE650 extender showing obtaining IP address/IP configuration failure in andriod phones
2021-01-21 09:17:53

@Rthomas 

Hi, sorry for the delay.

For your case, we would like to follow up by email and ask for more advice from the senior engineers.

Please have a check of your email box later.

At the same time, could you please help me check the following information:

1.What is the model number of your home router?

 

2.As for the android phones, did they have a feature called private address?

--if yes, please turn it off;

( Android: Settings app -> Network and Internet -> Wi-Fi ->Connect to deco Wi-Fi -> Tap the gear icon next to the current Wi-Fi connection -> Advanced ->  Privacy -> "Use device MAC")

Window 10: Setting -> Network and Internet -> "Wi-Fi" tab -> "Advanced Options." -> "Off" under "Random Hardware Address."  -> Restart your computer.

(Picture refer to https://it.nmu.edu/docs/disable-random-hardware-address-windows-10  )

 

3. If possible, could you please connect a wired laptop to the RE650 to check the Ethernet connection as well?

Thank you very much and wait for your reply.

0
0
#5
Options
Re:RE650 extender showing obtaining IP address/IP configuration failure in andriod phones
2021-01-21 17:12:06

@TP-Link thanks for reply. Few days back i changed tye settings of dhcp to on on the extender and gave static ip to the extender in the network settings, after that its working fine. Mobile is getting the ip without aby delay. Looks like issue is solved by setting the DHCP on instead of off/auto in the re650 extender. If the issue comes back, i will come back. 

2
2
#6
Options