Deco with Ethernet Backhaul connected directly on ISP router

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
12

Deco with Ethernet Backhaul connected directly on ISP router

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Deco with Ethernet Backhaul connected directly on ISP router
Deco with Ethernet Backhaul connected directly on ISP router
2022-02-03 05:30:53 - last edited 2022-02-03 06:38:38
Model: Deco X20  
Hardware Version:
Firmware Version:

Hi.

 

I want to buy a deco system (thinking in the x20 wifi 6) to do a mesh with Ethernet Backhaul.

 

I will use the ISP router and put all deco units as an AP. My question is:

 

Do I need to use a switch as the previous image or can I connect all them directly to the my ISP router like the image below?

 

 

PS: The ISP router doesn't have bridge mode.

 

Thank you.

  0      
  0      
#1
Options
11 Reply
Re:Deco with Ethernet Backhaul connected directly on ISP router
2022-02-03 14:26:51
In Access Point mode, you can wire Deco units directly to router. In fact, you can wire them any way you want, in AP mode. As long as there is Ethernet port providing connection to your home network, you can wire Deco unit to it.
  0  
  0  
#2
Options
Re:Deco with Ethernet Backhaul connected directly on ISP router
2022-02-04 04:22:44
Thank you for your reply 😀
  0  
  0  
#3
Options
Re:Deco with Ethernet Backhaul connected directly on ISP router
2022-07-16 15:25:33 - last edited 2022-07-16 15:26:37

  @tugastuga 

 

Hi! 
 

I am trying to setup the exact same thing. I want to have 2 Deco Nodes with access point both connected to Ethernet and both connected to the router directly. I tried to do that but the secondary node keeps having the signal source wifi from the primary node even though it's connected to Ethernet. I made sure the Ethernet cable is working by connecting my laptop with it.

 

Am I missing any configuration? I turned on the access point node. Did you manage to accomplish this setup? 
 

I have 2 Deco M9 plus

 

  0  
  0  
#4
Options
Re:Deco with Ethernet Backhaul connected directly on ISP router
2022-07-16 19:33:05 - last edited 2022-07-16 19:35:16

  @Lneves12 

 

I have three Deco nodes that are Ethernet wired: one directly to router and two - through the switch connected to router. 

 

If you connect Satellite Deco directly to the router and it still uses WiFi as Signal Source, I can think of three possibilities. Your Deco mesh still runs in router mode, Satellite Deco has an issue with Ethernet cable, or ISP Router is not Deco mesh compatible. Each one of these is easy to check.

 

Even if you configured Deco mesh to run in Access Point mode, the change needs to go to TP-Link cloud and back before it is propagated to all Deco nodes. If there is an issue with Deco cloud, that may take time.

To make sure Deco mesh is properly setup, power off both Deco nodes you have. Then, power on Main Deco and wait till its LED is green. Check in Deco app that Main Deco is online and Satellite Deco is offline.

Connect Satellite Deco by Ethernet cable to ISP Router and power Deco on. Wait till its status in Deco app changes to online. Check its Signal Source, and Deco app Advanced configuration settings:

 

 

 

If Satellite Deco still does not report Ethernet as Signal Source, power it off, take together with its Ethernet cable you used to connect it to ISP router to where Main Deco is. Check in Deco app that Satellite Deco is offline. Connect its Ethernet cable to second Ethernet port of Main Deco. You now daisy chained them as following:

 

 

Power on Satellite Deco. Wait till its status in Deco app changes to online. Check its Signal Source. It should be Ethernet, example:

 

 

If it is still WiFi, there may be an issue with Ethernet cable. Even if your laptop can use it, Deco might refuse for whatever reason. Try different, short Ethernet cable of good quality.

In this setup, unless something is terribly wrong with Deco hardware or cable, you should get Ethernet as signal source.

 

If Satellite Deco connects to Main Deco by Ethernet just fine in daisy chain, then it is possible your ISP Router is not compatible with Deco mesh Ethernet backhaul protocols. What is router brand name and model number?

 

----------------------

 

On a side note. Are you sure you have two Deco M9 Plus? With two Deco M9 Plus, which are tri-band, Satellite Deco Signal Source should look like this:

 

 

What you have on your screenshot appears as two-band Deco node, such as Deco M5. Which looks very much like M9 Plus, just a bit smaller. For M5, you should expect its WiFi Signal Source to look like this:

 

 

  0  
  0  
#5
Options
Re:Deco with Ethernet Backhaul connected directly on ISP router
2022-07-16 23:39:00

  @Alexandre. 
 

Thanks for such a detailed response!!

 

I tried the daisy chain. It didn't work at first, but after trying turning off both decos and turning them one by one I managed to see the Ethernet cable, so it means the cables are okay. I tried connecting both to the router and repeat the same process that worked and it was still connecting through wifi, so as you said it might be something in my router. 
 

it's a deco m9 plus. The other band eventually appeared, but it took a while for it to appear.
 

My router is a new router from Altice Meo: FiberGateway GR241AG. Quite surprising if it doesn't support a mesh connected directly to it. Could it be just a configuration thing in the router ? I would like to avoid buying a switch.

  0  
  0  
#6
Options
Re:Deco with Ethernet Backhaul connected directly on ISP router
2022-07-17 13:27:56

  @tugastuga 

 

I am not familiar with that router model, check if it can run with its own WiFi mesh extenders. If it can, find WiFi mesh configuration settings in router and toggle them on/off. It may be possible they conflict with Deco mesh. 

 

The thing I want to mention, when I told you to power off/on Deco in specific order - this is the right way for remote troubleshooting. This is not the step that must be performed every time to make Deco use Ethernet backhaul. With my Deco M9 Plus, when I plug Ethernet cable to it, Deco switches to Ethernet backhaul immediately and without hesitation. It might take a moment to have that reflected in Deco app, but this is because an app gets status update from TP-Link cloud.

 

Which means, if you have daisy chained Decos, keep Decos powered on, removed Ethernet cable from Satellite Deco, confirmed with Deco app that Deco switches to WiFi backhaul, plugged Ethernet cable back and Ethernet backhaul never appears - something might still be wrong with the cable. Try the one that should have come in a box with Decos.

 

Other than that, the troubleshooting steps I provided confirmed your Decos can use Ethernet backhaul, which means Deco hardware is working and firmware seem to be OK. You may need to get a switch, just like you suggested.

If your ISP offers different brands of routers, and you can exchange different brand with what you now have, this is also an option. While ISP router could be incompatible with Deco mesh protocols, that is rarity. Having two different incompatible brands is extremely rare. Also, if your ISP offers router that comes without WiFi, try that, too. 

 

  0  
  0  
#7
Options
Re:Deco with Ethernet Backhaul connected directly on ISP router
2022-07-18 23:31:07

  @Alexandre. 
 

I can finally see Ethernet as the signal source!!
 

Thanks for all the help. All the troubleshooting steps were super useful. 
 

As we suspected the problem was on the ISP router. It seems the router came with an internal mesh configured to mix the 2,5 and 5 ghz networks. After calling my ISP to disable the mesh and any wifi network from the router everything started working after a restart 

  2  
  2  
#8
Options
Re:Deco with Ethernet Backhaul connected directly on ISP router
2022-07-20 22:30:41

  @Lneves12 one thing I noticed is that even though the signal is ethernet I only have 500 mb speed for like an hour, then it seems to change and be capped on 95mb. If I reboot I see the same behavior. It goes back to 500mb and changes back to 100mb after a while. 
 

The same cable connected to my laptop is always 500mb 

  0  
  0  
#9
Options
Re:Deco with Ethernet Backhaul connected directly on ISP router
2022-07-21 14:37:30

  @Lneves12 

 

Lneves12 wrote

  @Lneves12 one thing I noticed is that even though the signal is ethernet I only have 500 mb speed for like an hour, then it seems to change and be capped on 95mb. If I reboot I see the same behavior. It goes back to 500mb and changes back to 100mb after a while. 

 

That could mean Router and Deco renegotiated Ethernet connection speed down from gigabit to 100Mbps. That usually points at Ethernet cable as a cause. Try replacing it with different cable.

 

Also, if your router Web page happened to have screen reporting on status of wired connections to it, check what it says there. Here is how that screen looks in my router Web page.

 

  0  
  0  
#10
Options
Re:Deco with Ethernet Backhaul connected directly on ISP router
2022-07-22 03:12:58

 

Alexandre. wrote

  @Lneves12 

 

Lneves12 wrote

  @Lneves12 one thing I noticed is that even though the signal is ethernet I only have 500 mb speed for like an hour, then it seems to change and be capped on 95mb. If I reboot I see the same behavior. It goes back to 500mb and changes back to 100mb after a while. 

 

That could mean Router and Deco renegotiated Ethernet connection speed down from gigabit to 100Mbps. That usually points at Ethernet cable as a cause. Try replacing it with different cable.

 

Also, if your router Web page happened to have screen reporting on status of wired connections to it, check what it says there. Here is how that screen looks in my router Web page.

 

 @Alexandre. Hi. I'm having the same issue with my new XE75, where I have high speeds for a while and then just shy of 100. Had a thought it could be the cable, so I plugged a laptop in instead of the Deco and speeds were high again.

 

Any other thoughts would be greatly appreciated. 

 

Thanks!

  0  
  0  
#11
Options

Information

Helpful: 0

Views: 2096

Replies: 11

Related Articles