How to get my router to report WAN public IP

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
12

How to get my router to report WAN public IP

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
How to get my router to report WAN public IP
How to get my router to report WAN public IP
2022-03-12 00:33:51 - last edited 2022-03-13 14:01:02
Model: Archer AX3200  
Hardware Version:
Firmware Version:

Hello all,

 

My router is AX5400 Wi-Fi 6 Router.

 

I've got the following setup at home:

 

 

                                      DMZ   ---->   DHCP and DNS Server

{{internet}      - {ISP modem/router} - {TpLink Router} - {my PC}
200.250.9.1  

NAT 1           - 192.168.0.1              - 192.168.0.2
NAT 2                                              - 192.168.50.1     - 192.168.50.2

 

The issue is apps asking for WAN IP are getting ISP IP (private IP 192.168.0.2) and they fail.

 

What should I do to get tplink router to report the correct WAN public IP?

 

I tried tplink DDNS with tplink account and noip WAN IP binding on but it doesnt work.

 

Also tried NAT feature on but it seems it doesnt do anything.

 

Any ideas?

 

LOG:

2022-03-11 21:10:31 Dynamic DNS INFO [21196] Dynamic dns noip registered ip: {IPS private IP}

2022-03-11 21:10:31 Dynamic DNS NOTICE [21196] Dynamic dns noip login succeed

2022-03-11 21:10:31 Dynamic DNS INFO [21196] Dynamic dns noip return code nochg

2022-03-11 21:10:29 Dynamic DNS INFO [21196] Dynamic dns noip login start

  0      
  0      
#1
Options
14 Reply
Re:How to get my router to report WAN public ip
2022-03-12 10:31:50 - last edited 2022-03-14 12:52:08

  @RobDev 

 

To avoid double NAT in your network you should either:

 

  • Set your ISP modem/router in bridge mode (modem only) - check this story for details on how you can do that.
  • Set AX3200 in AP mode (Case 1) - Operation mode is located in Advanced=>System for AX3200.

 

After using one of these two scenarios you should be able to avoid the double NAT and receive your public IP address either on the AX3200 WAN (Internet) port or on the ISP modem/router WAN port.

For either of these to work you should have a public IP address on your ISP modem/router WAN port in your current setup.

For Dynamic DNS (NO-IP) to report your public IP address when you're behind double NAT uncheck the 'WAN IP binding' option and then press 'login and save':

 

If this was helpful click on an arrow pointing upward. If this solves your issue, click the star to mark it as a "Recommended Solution".
  0  
  0  
#2
Options
Re:How to get my router to report WAN public ip
2022-03-12 12:42:10 - last edited 2022-03-12 13:12:59

  @terziyski 

 

Thank you for your reply. 
 

1) I cant turn my ISP modem/router to bridge mode because it has got other features that wont work once bridge mode is on.

 

2) I wont switch tplink router to AP mode because it will loose the purpose of having a powerful router to handle my LAN wireless and wired completely detached from the ISP router that is inferior in every single way.

 

There must be another way. I still don't understand why tplink router DDNS isn't working.

 

What about Routing?

 

What about VPN?

 

Cheers

  0  
  0  
#3
Options
Re:How to get my router to report WAN public ip
2022-03-12 15:03:56 - last edited 2022-03-12 15:04:53

  @RobDev 

 

Regarding the DDNS I'd like to add two comments.

 

First. The option "WAN IP binding" needs to be disabled (=off) on TP-Link routers for the router to poll the actual public Internet IP address if you are using NAT.

 

Second. If for some reason even with "WAN IP binding" disabled the AX5400 is still unable to get the actual public Internet address to update the DDNS record with it, then check if your ISP's modem router maybe has a DDNS feature which you could use. (or any other device inside your network, like security camera, NAS, etc.)

 

 

  0  
  0  
#4
Options
Re:How to get my router to report WAN public ip
2022-03-12 16:00:50 - last edited 2022-03-12 16:39:34

  @woozle 

 

Thank you for your suggestion unfortunately change the WAN IP Binding to false didnt give me the public IP.

 

Cant I get the public IP from DDNS Tp-Link.

 

I 've noticed DDNS Tp-Link option always request login when landing on the page. Is this correct.

 

---

 

2022-03-12 12:53:12 Dynamic DNS INFO [21110] Dynamic dns noip registered ip: {{ISP Private IP}}

2022-03-12 12:53:12 Dynamic DNS NOTICE [21110] Dynamic dns noip login succeed

2022-03-12 12:53:12 Dynamic DNS INFO [21110] Dynamic dns noip return code nochg

2022-03-12 12:53:11 Dynamic DNS INFO [21110] Dynamic dns noip login start

 

---

 

------ NAT PMPP Diagnostics ------
initnatpmp() returned 0 (SUCCESS)
using gateway : 192.168.100.254
sendpublicaddressrequest returned 2 (SUCCESS)
readnatpmpresponseorretry returned 0 (OK)
Public IP address : {{ISP Private IP}}
epoch = 556
closenatpmp() returned 0 (SUCCESS)

 

 

  0  
  0  
#5
Options
Re:How to get my router to report WAN public ip
2022-03-12 16:51:56 - last edited 2022-03-12 16:52:44

  @RobDev 

 

Please do a "ping [my domain name]" command or log into your no-ip account to verify the actual IP address that is stored for your domain name. Don't just trust the router's own logs.

  0  
  0  
#6
Options
Re:How to get my router to report WAN public ip
2022-03-12 17:01:35

  @woozle 

 

 

pinging from outside returns the public ip but thats not a valid test.

  0  
  0  
#7
Options
Re:How to get my router to report WAN public ip
2022-03-12 17:29:14

  @RobDev 

 

Why not?

  0  
  0  
#8
Options
Re:How to get my router to report WAN public ip
2022-03-12 17:34:44 - last edited 2022-03-12 17:35:09

  @woozle 

 

because you are tracing the IP from outside.

 

 

[Internet]      [LAN]
                     ping

response  ---->

  0  
  0  
#9
Options
Re:How to get my router to report WAN public ip
2022-03-12 17:58:47

  @RobDev 

 

"ping my_hostname_at_no-ip" returns the IP address that was previously uploaded to the associated No-IP account for the hostname "my_hostname_at_no-ip". No more, no less.

 

But maybe I have just misunderstood what is the actual goal you want to achieve.

 

  0  
  0  
#10
Options
Re:How to get my router to report WAN public ip
2022-03-12 19:52:44 - last edited 2022-03-12 19:55:11

  @woozle 

 

The goal I'm trying to achieve is in the thread header.

 

Hopefully we get other ideas to try out.

 

 

  0  
  0  
#11
Options

Information

Helpful: 0

Views: 1612

Replies: 14

Related Articles