Virtual Servers (Port Forwarding) RANGE issue on TP-Link Archer VR1210v

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Virtual Servers (Port Forwarding) RANGE issue on TP-Link Archer VR1210v

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Virtual Servers (Port Forwarding) RANGE issue on TP-Link Archer VR1210v
Virtual Servers (Port Forwarding) RANGE issue on TP-Link Archer VR1210v
2022-08-29 19:07:33 - last edited 2022-09-02 11:24:28
Model: Archer VR1200  
Hardware Version: V1
Firmware Version: 2.0.0 0.9 v6041.0 Build 220304 Rel.6349n

Hi Everyone.

 

I'm writing to report an issue I found regarding the "Virtual Servers" configuration into the "NAT Forwarding" section of the EVDSL Modem TP-Link Archer VR1210v. Below the information of the hardware and software used.

 

Device: TP-Link Archer VR1210v

Hardware Version: Archer VR1210v v1 00000001

Firmware Version: 2.0.0 0.9 v6041.0 Build 220304 Rel.6349n

 

The issue I've found is the following:

I am used to attribute sequential ports to the same private IP, so I can unlock all the port for the same device/IP defining only one entry in the modem configuration GUI and using the port range definition instead of defining a single entry per port.

 

I make an example: for the device with the private IP 192.168.1.177 I've a series of exposed services which runs in the port range 7430-7468. What I usually do is to define a single rule with the port range definition, inserting the port range in the option "External Port", leaving Blank the option "Internal Port".

 

Below I report a screenshot of the rule on the same Archer VR1210v device I am referring to

To define the port range, I leave the option "Internal Port" as empty. In the past I did for an old router (Archer C2) and this configuration worked as expected.

However on the VR1210v device, when I confirm this configuration pressing the OK button, the entry automatically populates the option "Internal Port", inserting the first port of the "External Port" range defined (example reported below, as the entry appears in list after pressing "OK")

 

I tried to figure out if the automatic fill-in of the option "Internal Ports" is just a matter of easthetic representation of the entry or it affects the performances/configuration of the "Port Forwording" and, unfortunately, it does. In fact, if from the extranet I direct traffic to one of the ports of the range, traffic is not blocked but it is all redirected to the first port of the range which has been automatically added to the voice "Internal Port".

 

Referring to the example reported above: If I direct traffic to myip:7445 (where we assume "myip" is my public IP address), traffic is correctly directed to private IP 192.168.1.177 BUT the port which is used is 7430 and not 7445 (the one automatically defined as "Internal Port"). So every call directed to one of the ports of the range will result in a call directed to the port 7430 (first port of the range).

 

Can somebody suggest me a solution to let "Internal Port" option stay blank? I tried in many ways but I didn't figure it out to how make it work.

 

I hope somebody might help me.

 

Thank you

  0      
  0      
#1
Options
1 Accepted Solution
Re:Virtual Servers (Port Forwarding) RANGE issue on TP-Link Archer VR1210v-Solution
2022-09-01 20:56:38 - last edited 2022-09-01 20:59:06

Hi Everyone,

 

I'm posting once more to notify that I've solved the issue explained above, since I've found a workaround to allow port forwarding of port ranges.

I specify once again that this solution is valid for Archer VR1210v. I decided to post it since maybe someone who is dealing with the same problem could fix it.

 

Before to start, I want to express my disappointment to the Technical Support of TP-Link. It was obvious that this issue was related to a bad firmware and not related to hardware, so I suppose that someone of the company surely would be able to help and at least would be able to fix it for a further release. However, I wrote to the official support page, as suggested by @terziyski which I thank for the answer, and I've been ignored.

The one I reported was no a big issue, but what if I needed help for a bigger issue which would have compromised the correct functionality of the device at all? I would have changed my device, wasting my money. In my opinion, this is not how a serious company behaves!

 

Now, let's get back to the issue.

 

As i supposed, the firmware wasn't working. I had the latest version installed: 2.0.0 0.9 v6041.0 Build 220304 Rel.6349n. This release is not good at all, so the port forwarding / virtual servers section does not work as it should. I though that the previous version would also be affected, that's why I asked for a beta version (usually older version should be worst, you know, expecialy if in the changelog there are no updates related to the functionality which is not working).

Whatever, I downgraded the firmware to version 2.0.0 0.9 v6041.0 Build 210701 Rel.27192n and now all is working as expected. If i leave the "Internal Port" field blank then all the "External Port" range is mapped. That's another point against TP-Link. Newest versions are worst then the previous ones and firmware testing is very well-made. Congratulations!

 

I attach a screenshot to show how it should work and how it works with this firmware Installed.

 

 

The firmware can be downloaded at this page: https://www.tp-link.com/it/support/download/archer-vr1210v/#Firmware.

 

I hope it could help and a personal suggestion to who like me had this problem: next time try another network devices brand.

Recommended Solution
  2  
  2  
#5
Options
6 Reply
Re:Virtual Servers (Port Forwarding) RANGE issue on TP-Link Archer VR1210v
2022-08-29 20:12:30 - last edited 2022-08-30 22:18:20

  @DavmoNet 

 

Such behavior can be seen when the device doesn't support configuring virtual servers with port ranges - this can be fixed only by a new FW release.

If the device is provided to you by your ISP, you should contact them for further assistance.

If you bought it from a retailer, you can contact your local support (here) and ask them for assistance on that matter.

If this was helpful click once on the arrow pointing upward. If this solves your issue, click once the star to mark it as a "Recommended Solution".
  3  
  3  
#2
Options
Re:Virtual Servers (Port Forwarding) RANGE issue on TP-Link Archer VR1210v
2022-08-29 22:58:46

  @terziyski 

 

Thank you for the very rapid answer.

 

I bought the TP-Link modem to replace the one provided by my ISP, which is very limited in configuration options. So, I can do every update/edit I want on the TP-Link modem.

 

I've already updated to the latest version available for this device. I have downloaded the latest firmware via the official support page of the VR1210v on the TP-Link website.

 

I've seen in many threads that a beta version, not available on the official website, has been provided. Someone knows if a beta version for the TP-Link VR1210v in which this issue has been fixed is available?

 

I am also thinking: creating port forwarding rules via CLI (using Putty) could allow the correct generation of the entries? Maybe it's just a bug of the GUI. Or this could not be possible?

 

  0  
  0  
#3
Options
Re:Virtual Servers (Port Forwarding) RANGE issue on TP-Link Archer VR1210v
2022-08-30 21:30:38

Nobody knows if there is a firmware (beta) that could help me?

 

Previous model worked fine. It seems strange to me that now this functionality does not work anymore

  0  
  0  
#4
Options
Re:Virtual Servers (Port Forwarding) RANGE issue on TP-Link Archer VR1210v-Solution
2022-09-01 20:56:38 - last edited 2022-09-01 20:59:06

Hi Everyone,

 

I'm posting once more to notify that I've solved the issue explained above, since I've found a workaround to allow port forwarding of port ranges.

I specify once again that this solution is valid for Archer VR1210v. I decided to post it since maybe someone who is dealing with the same problem could fix it.

 

Before to start, I want to express my disappointment to the Technical Support of TP-Link. It was obvious that this issue was related to a bad firmware and not related to hardware, so I suppose that someone of the company surely would be able to help and at least would be able to fix it for a further release. However, I wrote to the official support page, as suggested by @terziyski which I thank for the answer, and I've been ignored.

The one I reported was no a big issue, but what if I needed help for a bigger issue which would have compromised the correct functionality of the device at all? I would have changed my device, wasting my money. In my opinion, this is not how a serious company behaves!

 

Now, let's get back to the issue.

 

As i supposed, the firmware wasn't working. I had the latest version installed: 2.0.0 0.9 v6041.0 Build 220304 Rel.6349n. This release is not good at all, so the port forwarding / virtual servers section does not work as it should. I though that the previous version would also be affected, that's why I asked for a beta version (usually older version should be worst, you know, expecialy if in the changelog there are no updates related to the functionality which is not working).

Whatever, I downgraded the firmware to version 2.0.0 0.9 v6041.0 Build 210701 Rel.27192n and now all is working as expected. If i leave the "Internal Port" field blank then all the "External Port" range is mapped. That's another point against TP-Link. Newest versions are worst then the previous ones and firmware testing is very well-made. Congratulations!

 

I attach a screenshot to show how it should work and how it works with this firmware Installed.

 

 

The firmware can be downloaded at this page: https://www.tp-link.com/it/support/download/archer-vr1210v/#Firmware.

 

I hope it could help and a personal suggestion to who like me had this problem: next time try another network devices brand.

Recommended Solution
  2  
  2  
#5
Options
Re:Virtual Servers (Port Forwarding) RANGE issue on TP-Link Archer VR1210v
2022-09-02 11:30:20

  @DavmoNet 

Thank you very much for the sharing and I am sure it will help many other users.yes

Best regards.

  0  
  0  
#6
Options
Re:Virtual Servers (Port Forwarding) RANGE issue on TP-Link Archer VR1210v
2022-11-12 22:20:31

  @DavmoNet 

 

IMPORTANT EDIT!

 

As far as concerns the issue reported in the thread the solution I reported (downgrade to the lowest version) is the one which currently I use to solve the problem. There are no other updates about that. However there are few thing I need to say: I had another severe issue, for which I also opened a dedicated thread (here: https://community.tp-link.com/en/home/forum/topic/583574). TP-Link staff has been very kind to support me and solved the problem. So, I want to rectify my opinion over TP-Link support team which revealed to be really efficient, kind and available. I stressed them for an entire month (and I'm sorry for that) and they've been very kind to support me every time, provide me feedbacks and also custom firmwares/Betas.

 

Even if the first time things didn't go as expected, I can't deny that their Support is very professional and accurate. I feel obliged to review my first feedback/opinion on the TP-Link support.

 

Thank you everyone

 

  0  
  0  
#7
Options

Information

Helpful: 0

Views: 759

Replies: 6

Related Articles