'Authentication failed, Server TLS version is too low' appears when connecting OpenVPN of DSL Modem

'Authentication failed, Server TLS version is too low' appears when connecting OpenVPN of DSL Modem

15 Reply
Re:'Authentication failed, Server TLS version is too low' appears when connecting OpenVPN of DSL Modem
2024-01-31 00:14:00 - last edited 2024-01-31 00:17:43

  @stu1234 

stu1234 wrote

  @Sunshine 

 

Is there no fix for the Archer VR 2800 coming? I see it's still listed as a current product on TP-Link's website and remains for sale. Enabling insecure protocols is not a suitable long term workaround for a VPN, TLS 1.0 has been deprecated for 3+ years now due to vulnerabilities and the current version TLS 1.3 has been in available for 5 years. Do TP-Link have plans to provide firmware that supports TLS 1.3?

 

 

Agreed, I'm also looking at Archer VR600 v2 (Australian version) and worried about the vulnerabilities now.

  1  
  1  
#27
Options
Re:'Authentication failed, Server TLS version is too low' appears when connecting OpenVPN of DSL Modem
2024-02-08 17:22:37 - last edited 2024-02-08 17:23:59

  @stu1234 Archer VR2800 V1. Have Updated the routher firmware but I'm also having the exact same issue. Openvpn Android Client Version 3.4.0 allows to enforce to TLS version 1.3. Is there an update to the firmaware Coming?? I really need this working

  2  
  2  
#28
Options
Re:'Authentication failed, Server TLS version is too low' appears when connecting OpenVPN of DSL Modem
3 weeks ago

  @Sunshine 

 

I have an Archer VR2800 and still can't use VPN on my Android phone unless I switch the OpenVPN client to 'Insecure'.

 

It really is about time this problem was solved! Telling us to use an insecure link simply isn't acceptable.

 

Because I have OpenVPN enabled on my VR2800 it leaves me vunerable to hacking attacks via the VPN server built into the router.

 

Come on Tp-Link, GET THIS SORTED OUT IMMEDIATELY!

  0  
  0  
#29
Options
Re:'Authentication failed, Server TLS version is too low' appears when connecting OpenVPN of DSL Modem
3 weeks ago

  @Istari @Jack360 

 

Hi, upon consulting, there is a plan to address this issue in a future firmware update of VR2800 V1. Please be patient and wait for the update.

Once there is any update, we will update this thread as well.

  0  
  0  
#30
Options
Re:'Authentication failed, Server TLS version is too low' appears when connecting OpenVPN of DSL Modem
2 weeks ago - last edited 2 weeks ago

  Hi @Sunshine ,
any plan to release a firmware update also for VR1210 v1 to address the issue?
I really don't like the "Insecure" solution.

Thank you

  0  
  0  
#34
Options
Related Articles