TL-PS310U causing blue screen errors on Win7 Pro 64x
TL-PS310U causing blue screen errors on Win7 Pro 64x
TL-PS310U causing blue screen errors on Win7 Pro 64x
2014-01-10 19:59:22
Region : Australia

Model : TL-PS310U

Hardware Version : Not Clear

Firmware Version :

ISP :


The problem isn't that it doesn't work when installed. The problem is that it causes frequent blue screen errors on this OS. I have mini-dump files available if anyone wants to check them out. I'm installing this on an Inspiron 7720 laptop. The same software works perfectly fine without errors on my old XP machine, but it's six years old, and I wanted to replace it with this laptop, if only the print server would work. I've tried installing it without the antivirus, I've tried installing it without the firewall, but these don't help. The blue screens still happen. Anyone got any advice on how to get it working on this laptop without the blue screen errors?
0
0
#1
Options
3 Replies
This used to happen to me, I fixed it
2014-05-15 23:19:00
Hi, this information might be coming to you abit late, but I figured it might help those that are still having this issue.

So when I first purchased my TP-link 310U, it worked flawlessly for the first year. Then recently for some reason, I kept getting a blue screen every time I tried to connect to my printer through my 310U.

So this is what was happening on my side:
- I get blue screen everytime I connect to my printer through 310U
- I can print if I connect printer directly to my computer
- the bluescreen I get says genhc.sys error
- it was working, but not anymore

I found something on the internet saying that genhc.sys errors often happen when there are registry or viruses on your computer.

Registry
- I downloaded CCleaner, and it found and fixed 1,300 things.

Virus
- I used AVG to scan my primary drive, and it said it found Trojans and stuff in the java\deployment\cache\6.0, etc. But I'm not sure if its a false positive or not. And it also found something in the appdata\local\temp\v.class

Well after using CCleaner and AVG, I no longer have any problems with printing through my 310U nor do I have any bluescreens.

Enjoy, and hope this works for you all.

*Don't forget to reboot after removing any registry errors and viruses.
*If your getting an USB server driver error, you may have to uninstall and reinstall the TP-Link 310U drivers.

AL.
0
0
#2
Options
Windows 10 BSOD running MFP Server App of TL PS310U V2
2015-09-26 23:32:24
Dear All,

For those who have already installed Windows 10 and have difficulties on printing using Printer Server TP Link PS310U V2, below link is how i manage to over come. My MFP Server keep my Windows 10 BSOD once i want to connect the printer. Now, i have the solution that i never has to do with MFP Server application anymore. Just print as normal printer (or actual network printer).

http://www.slideshare.net/andorulez/installing-tplink-ps310u-v2-on-windows-10

Good luck.
0
0
#3
Options
Re:Windows 10 BSOD running MFP Server App of TL PS310U V2
2019-01-03 18:08:35

Try this:

 

The latest firmware 100_085 and software for PS-310U version 1 can be found here:

https://mega.nz/#!lJlQCIrD!c6gIDfvW5wdudJ3jCDQgUglFtrUdforARiJsN_valaI

 

Due to discontinuation of the chip E1868 the software is no more available from the manufacturers website.

 

After that you can upgrade the software to the version 18.1017.0064 (it works as well although not mentioned with the E1868 chip) on the website:

http://www.elitesilicon.com.tw/index.php/en/system-support-en/chip-related-download-en.html

 

Elite Silicon is the manufacturer of the used E1868 chip.

 

For the PS-310U V2 which uses the E2868 chip use the firmware from the Elite Silicon Website under firmware section and the above mentioned software version 18.1017.0064.

0
0
#4
Options