What to do if Deco M5 bricked during an update? Please come in~

Used Products:

I have three Deco M5 units and they are worked fine, I have seen a new firmware available for the Deco M5 thus I try to update the firmware of the Deco M5, during the upgrade process, due to a sudden power failure, the Deco became bricked, and the LED light turned solid yellow. I tried everything I could, such as restarting, resetting, but none of them worked, so I contacted TP-Link technology support. They gave me a detailed guide to get Deco M5 back to normal. After following this guide, my Deco M5 worked again. For those friends who have the same problem as me, I share this guide here, hoping to help these friends to get Deco back online and enjoy the internet.

 

As technical support suggested, first of all, I went to TP-Link official website to download the latest firmware for my Deco M5 V1 that is Deco M5(EU)_V1_200924 and unzip it on my Windows PC, and then I see a .bin file. According to the instruction, I changed this file’s name to “M5v1_tp_recovery.bin”.

I was told if the name of the .bin file is incorrect, I can’t finish the recovery process successfully.

 

Step 2, search and download the TFTP software on the Windows PC, then install it. My Windows OS is 64bit, so I download the tftpd64 application, install it, and then launch it on the PC.

 

Step 3, connect the Windows PC wired to the LAN port of the main Deco unit, then configure a static IP address on the Windows PC. The IP address is 192.168.0.66, the subnet mask is 255.255.255.0, and the default gateway and the DNS server are empty.

https://www.tp-link.com/en/support/faq/14/

 

Step 4, on the tftpd64 application, click on the Browse button, select the Deco M5’s firmware folder, and then switch to the Log Viewer window.

 

Step 5, with the PC wired to the Deco, turn off the Deco unit, press and hold the Reset button on the Deco, and then power on the Deco while still hold on the Reset button. Wait for about 10 seconds until a file transferring process occurs in the Log Viewer windows, and then release the Reset button.

 

During this process, I can see that the LED on the Deco blinking green-blue, then wait for about 2 minutes, the LED on the Deco turns to solid green. I was told it means Deco has updated to the latest firmware successfully, and it’s working again.

 

After the main Deco worked again, I tried the same steps with the two satellite Deco units, and they worked fine either. So excited am I, everything works perfectly again, so I share my experience here to help another person who has the same problem.

 

Edit: I just find a very useful guide on the TP-Link FAQ here, you can refer to that if you got the same issue:

How to use firmware recovery if the Deco become brick

7 Subscribe Bookmark

Comment

Great! Thanks!

Thanks for sharing information about Deco M5 bricked during an update. 

 

Hi, There is also a detailed FAQ about the firmware recovery instructions for all Deco models;

Please have a look:

https://www.tp-link.com/en/support/faq/2958/ 

Thank you.

12
upload
    upload
      Subscriptions