How to let my USB adapter works on the Mac OS big sur

Used Products:

Hi guys,

I found a method that can let my TP-Link adapter work on the Mac OS Big Sur!

I had a Mac book pro (2017) and Archer T2U Nano. And I found the method on the below Git hub link then I download the driver Wireless USB OC Big Sur Adapter-V5 and follow the instructions to install it.

Github link:

In order to let this adapter installed and work, I have to disable the SIP and give the authority of this App to be installed.

Note that Apple doesn't recommend disabling the SIP, but for me, I have to use the adapter to work so I use this method.

So if you have to use the USB adapter on your Mac maybe you can have a try.


Below are the steps I took to make it work properly.

1. Reboot into recovery mode.  For my Mac book pro, hold “command + R” at power on until the display says loading options.

2. Disable the SIP. Go to the utility menu and choose Terminal. Type “csrutil disable” and press enter, then reboot the mac to let this take effect.

3. Give the APP authority in order to installed on Mac.

Open terminal and type this command “sudo spctl --master-disable”

Then you can find the “anywhere” option on the Security & Privacy page.


4. Download and install the driver. For me the latest version 5 works!

Download link:

During the installation, it may ask you for authority. Then go to the system preference, Security & Privacy and click the “details” to give the APP permission to be installed.

After the driver installed successfully, then the Archer adapter can work properly.  



Works great, thank you for sharing!!!


Will wifi functionality be disrupted if SIP and spctl are reenabled after installation has finished?

Thanks For sharing instructions by Marinekkk worked my my Macbook Air with a T2U Nano . <a href= ""></a>

Thanks For sharing best instructions by Marinekkk worked my my Macbook Air with a T2U Nano . <a href="">Best Travel Agency In Hisar, Haryana<a/>

Hello everyone, 

When try the above method, make sure to try the latest release of driver from here :


Or scroll to the button to find the latest release of driver:

Link to V10

Can I activate SIP again after the installation? 

Doesn't work with macOS 11.6.4 for TL-WN821N..