Firmware for TL-WPA4XXX, TP-PA4XXX AV500/AV600 adapters QCA7420-1.5.0.0026

Re:Firmware for TL-WPA4XXX, TP-PA4XXX AV500/AV600 adapters QCA7420-1.5.0.0026
2020-08-27 21:06:53 - last edited 2020-08-28 13:43:43

@PowerlineFW 

I've got trouble with install this FW

One 4010 updated OK

 

But another 4010p (v2) fails all the time - I'm getting "Update failed" on both devices

 

I've found out that the FW filesize differs

 

current MAC-7420-v1.1.0-01-X-FINAL.nvm is 337kB

latest FW-QCA7420-1.5.0.0026-02-CS-20200114.nvm 390kB

 

That may be a reason? But what will means? Seems that it's same chipset.

 

EDIT:
I've tried to flash FW using plctool and i get some more more info :

 

Minor Version Mismatch (0x48): Device refused request

 

But still can't flash

 

@Fitzcarraldo :

Which version of 4010p do You have?
0
0
#12
Options
Re:Firmware for TL-WPA4XXX, TP-PA4XXX AV500/AV600 adapters QCA7420-1.5.0.0026
2020-09-29 17:47:53

@PowerlineFW Please can you or someone else re-upload the latest firmware? Thank you.

0
0
#13
Options
Re:Firmware for TL-WPA4XXX, TP-PA4XXX AV500/AV600 adapters QCA7420-1.5.0.0026
2020-10-14 12:54:08

@alnxx I successfully upgraded all the following Powerline adapters:

 

TL-PA4010P(UK) VER:5.0
TL-PA4010(UK) VER:3.0
TL-PA4020P(UK) VER:4.0

 

Linux user for many years. My blog can be found at https://fitzcarraldoblog.wordpress.com/
1
1
#14
Options
Re:Firmware for TL-WPA4XXX, TP-PA4XXX AV500/AV600 adapters QCA7420-1.5.0.0026
2020-10-20 06:59:53

@Fitzcarraldo Thanks for reply. I've got another 4010p v5.0 and updated with no problems, v2 still refuse to update itself so i think it's hardware related.

 

V5 seems to work way better on this update, however it's still no perfect - while data transfer and ping are fine, dns/dhcp requests are timing out sometimes

But it's still big improvement.

0
0
#15
Options
Re:Firmware for TL-WPA4XXX, TP-PA4XXX AV500/AV600 adapters QCA7420-1.5.0.0026
2020-10-20 16:52:08

@PowerlineFW 

 

hi. what's the latest/last firmware for AR/QCA7400? is it 5-3-5317?

 

cheers

0
0
#16
Options
Re:Firmware for TL-WPA4XXX, TP-PA4XXX AV500/AV600 adapters QCA7420-1.5.0.0026
2020-11-23 18:59:04

@Fitzcarraldo As a complete noob (but willing to learn) I tried to do what you did. But I just don't know how to compile the Github stuff. I tried with ant, mingw and eclipse but nothing works for me. Why can't they just include a bunch of binaries for poorly skilled people like me?

 

Can anyone show me the right commandline stuff to do?

Or provide me an executable files for Win10 to get the pib file. 

Or even better, what I need is the bip file for my TP-TL-WPA4230P.

 

Any help is appreciated. Or a shoulder to cry on.

 

0
0
#17
Options
Re:Firmware for TL-WPA4XXX, TP-PA4XXX AV500/AV600 adapters QCA7420-1.5.0.0026
2020-11-25 03:00:39

@Martijn69 Use the PIB from this firmware:
https://www.tp-link.com/us/support/download/tl-pa4010-kit/#Firmware
 

All other PIBs didn't work for me, but this one works with the NVM from the original post.

1
1
#18
Options
Re:Firmware for TL-WPA4XXX, TP-PA4XXX AV500/AV600 adapters QCA7420-1.5.0.0026
2020-11-25 17:01:24

@PowerlineFW What exactly is the expected result of this procedure?

0
0
#19
Options
Re:Firmware for TL-WPA4XXX, TP-PA4XXX AV500/AV600 adapters QCA7420-1.5.0.0026
2020-12-08 19:57:43

@PowerlineFW No more newer updates?

0
0
#20
Options
Re:Firmware for TL-WPA4XXX, TP-PA4XXX AV500/AV600 adapters QCA7420-1.5.0.0026
2021-01-02 16:06:45 - last edited 2021-01-02 17:01:20

Hi all.

 

I could successfully upgrade my old TP-WPA4230P Kit adapters with the new firmware MAC-QCA7420-1.5.0.26-02-20200114-CS

 

Model : TL-WPA4230P Kit (TL-PA4020P & TL-WPA4230P)
Hardware Version : V1
OLD Firmware Version  : MAC-QCA7420-1.1.0.844-01-20120919-FINAL
NEW Firmware Version : MAC-QCA7420-1.5.0.26-02-20200114-CS 

 

I did the upgrade with the open PLC utils which could be successfully compiled on a Raspberry PI.

Also I had to use the PIB provided by Burggraben (Post #18) from the TL-PA4010-Kit.

 

NOTE: read also the great article: Updating the Powerline adapters in my home network from Fitzcarraldo !!!
(https://fitzcarraldoblog.wordpress.com/2020/07/22/updating-the-powerline-adapters-in-my-home-network/)

 

The following commands did the update and the the status confirmation:

---
Before Upgrade:

$ sudo ./plcstat -t -i eth0
 P/L NET TEI ------ MAC ------ ------ BDA ------  TX  RX CHIPSET FIRMWARE
 LOC STA 002 30:B5:C2:XX:XX:XX B8:27:EB:XX:XX:XX n/a n/a QCA7420 MAC-QCA7420-1.1.0.844-01-20120919-FINAL
 REM CCO 001 30:B5:C2:XX:XX:XX 30:B5:C2:XX:XX:XX 120 064 QCA7420 MAC-QCA7420-1.1.0.844-01-20120919-FINAL

 

Upgrade:

$ sudo ./plctool -i eth0 -P /home/pi/PLC/firmware-tp/QCA7420-WallAdapter-HomePlugAV_CE-ClassB_us_401030.pib -N /home/pi/PLC/firmware-tp/FW-QCA7420-1.5.0.0026-02-CS-20200114.nvm -R 30:B5:C2:XX:XX:XX

$ sudo ./plctool -i eth0 -P /home/pi/PLC/firmware-tp/QCA7420-WallAdapter-HomePlugAV_CE-ClassB_us_401030.pib -N /home/pi/PLC/firmware-tp/FW-QCA7420-1.5.0.0026-02-CS-20200114.nvm -R 30:B5:C2:XX:XX:XX
 

PLCSTAT shows this after both adapters were upgraded:
$ sudo ./plcstat -t -i eth0
 P/L NET TEI ------ MAC ------ ------ BDA ------  TX  RX CHIPSET FIRMWARE
 LOC STA 005 30:B5:C2:
XX:XX:XX B8:27:EB:XX:XX:XX n/a n/a QCA7420 MAC-QCA7420-1.5.0.26-02-20200114-CS
 REM CCO 001 30:B5:C2:
XX:XX:XX 30:B5:C2:XX:XX:XX 068 069 QCA7420 MAC-QCA7420-1.5.0.26-02-20200114-CS
---

@PowerlineFW Special thanks for this great post. 

@TP-Link The adapter are working fine - even after nearly 7 years of operation. So, looks like this is a stable hardware. But as a customer related company which is concerned about user satisfaction you have to provide updates also for legacy products. As we see it's not much effort to provide updates! Be aware that the gain of updates is a much higher trust from customers.

0
0
#22
Options