Driver error when setting up UB-400 for the first time

Driver error when setting up UB-400 for the first time
Driver error when setting up UB-400 for the first time
2020-09-01 13:05:29 - last edited 2020-09-01 13:14:46
Model:Adapter
Hardware Version: V1
Firmware Version:

Upon plugging the UB400 adapter into my Windows 10 PC, it shows a "driver error" in bluetooth devices.  And in device manager, it shows as "Generic Bluetooth Radio".  There is no adapter recognized in device manager.  I've tried searching for and updating the driver software, but it says it's the latest.  My expectation is that this is plug and play and should not require the 400mb software download from TP-Link.

 

Currently running Windows 10 Pro ver 2004.

 

I've tried troubleshooting from other recent threads, but it does not seem to fix the issue.

 

screenshot from bluetooth devices:

 

screenshot from device manager

 

Edit: this happens on 2 other Windows 10 PCs

1
1
#1
Options
3 Reply
Re:Driver error when setting up UB-400 for the first time
2020-09-01 22:36:12

@bmav25 

 

The quick installation guide mentions:

 

"Before you proceed, please disable all existing Bluetooth devices (both built-in and third-party) on your computer"

 

Your existing devices may be getting in the way.

1
1
#2
Options
Re:Driver error when setting up UB-400 for the first time
2020-09-02 13:00:12

@Tony Thank you! I will give this a shot.

0
0
#3
Options
Re:Driver error when setting up UB-400 for the first time
2021-09-04 18:23:14
This fixed it for me!
0
0
#4
Options