What can I do if I unable to configure my Deco?

Released On: 2018-11-27 07:51:57Last update time: 2018-11-27 07:51:57

You may experience issues setting up your Deco for the first time.  If you do please check this guide to see if the issue you are experiancing is covered. 


Case 1: The Deco app cannot find the Deco


1. Disable and then enable Bluetooth on your phone.

2. Make sure LED is pulsing blue on Deco, otherwise, reboot/reset Deco.

3. Move your phone closer to Deco.

4. Disable power saving mode on your phone.

5. Authorize location for Deco on your phone.


Case 2: The Deco is not properly connected


1. The Deco is not connected to the modem. Please check the physical connection.

2. The Deco is connected to modem but is not receiving a WAN IP address. Connect your PC to the modem directly and see if internet works. Also check the LAN's IPv4 address and gateway on PC.


Case 3: Fails to connect to your TP-Link cloud


1. Connect a PC to the other Ethernet port on Deco to test internet connection. If it works, check whether firewall on the modem is set to a High/Medium Level. Set it to Low or disable it.

2. If there is no internet through Ethernet connection, power off and on your modem then router. Once the reboot is complete, test the connection.

Note: If modem is brand new, you may need to call your provider to activate it.  

3. If you cannot connect a PC to the LAN port via Ethernet, reboot the modem and contact your provider to make sure that MAC filtering is not enabled.

4. If your modem is working, and it still works with your old router, then connect the main Deco to a LAN port of the old router. Connect your phone to the Wi-Fi signal from old router, and configure the main Deco by using the Deco app. After configuration finished, connect the main Deco back to the modem.


Case 4: Testing the connection


1. Move the remote Deco next to the main Deco, reset the remote Deco and configure it again.

2. If problem persists, connect the remote Deco to the main Deco via Ethernet and run the setup again.

3. Unplug the main Deco from your modem, reboot both Deco and modem. After that, plug the main Deco back to the modem, wait till the LED light turns solid green, then set up the remote Deco again.


If you are still having issues or your issue is not covered please contact TP-Link support for further assistnace. 


13 Unhelpful Bookmark

I have deco mesh wifi (e4). Then My internet suddenly stopped. When the internet is back. I notice that One of my deco is not working. The color on the top of it is solid red. I dont know why, i tried to unplug and fixed it but its not working. I dont know to do. I dont know how to trouble shoot this. Pls help me guys

@geigartt They state on their website that due to Corona they have limited phone support. I also can't find a number on there, but when I google it (for germany) some numbers pop up. Maybe try doing the same for your country or open a new thread smiley

Actions speak louder than words.

Are there seriously only about 4 options in the Deco software? Its utter garbage

Thanks for sharing this info. 

Disappointed to find out that i cannot change the wifi channel on my deco m9 mesh router. Can you please fix this soon?

Hello, I am facing strange problem with a Deco M5 system. After set-up, all my devices e.g. tablets (android & iOS), mobile (android & iOS), windows laptop+desktop etc. connecting smoothly to WiFi & Internet, except my Apple MacBook (having Norton 360 installed in it) that it says it connects to WiFi but no Internet access, tried upgrading Deco firmware, turning fast Roaming off...no change. Any quick help with steps will be really great.



I have tried sevral time to configure my TpLink Deco M4 to use it in Access Point

The blue light on the m4  is flashing and I have connected the main router to the M4.

Deco should now be ready to configure...

It is connected to the Deco_xxxx network...


Then the search begin..... but it never find the Deco M4


What can I do..... to make it work ?








Hello, World ! Wi-Fi

Ethernet Backhaul can still be accessed in AP mode?