HS105 units don't auto-reconnect after losing WiFi connection

Re:Re:HS105 units don't auto-reconnect after losing WiFi connection
2020-10-23 16:22:42

I came here looking for help for exactly the same problem, new HS105 devices that keep losing wifi connection and won't reconnect.

 

My wifi is fine, all other devices in my house are working fine. Given that people are reporting this issue since 2018 and this is now 2020, I conclude that I have been scammed by buying these and will return them. This isn't rocket science, people. 

1
1
#83
Options
Re:HS105 units don't auto-reconnect after losing WiFi connection
2020-10-28 03:01:09

Same issue: HS105 units loose connection daily. They have to be removed and re-installed every time to re-connect. I saw the note about firmware upgrade ( at 1.0.21), but the app says no update available. My WI-FI is strong. This is a fraud!

0
0
#84
Options
Re:HS105 units don't auto-reconnect after losing WiFi connection
2020-11-03 03:36:15

@NikD63 Im seeing this issue again after a firmwear update to 1.5.6 :o(

0
0
#85
Options
Re:HS105 units don't auto-reconnect after losing WiFi connection
2020-12-10 02:50:54 - last edited 2020-12-10 02:53:08

I have the same issue.  I have 30+ Kasa devices and it's maddening to not have them work after a router restart.  I have a netgear orbi mesh and my other devices seem to be ok.  My Kasa devices, however, come on one or two every 20-30 minutes after a router reboot.

 

I put a battery backup on my router so I don't lose power.  That's decent insurance, but when an inveitable firmware reboot occurs, all the devices go offline.  There needs to be a way to go into the Kasa switches and plugs and tell them to release their IPs and get another one.

 

Also, can anyone at TP-Link advise on what the lease length is on the Kasa devices?  That would be great to know!  Who know when/if they will come back!

0
0
#86
Options
Re:HS105 units don't auto-reconnect after losing WiFi connection
2021-10-21 00:59:36

Anyone know how to fix this issue? I am about throw away the damn plug and never buy anything made by TP link again.

0
0
#87
Options
Re:HS105 units don't auto-reconnect after losing WiFi connection
2021-10-21 01:07:48

@Thematrix310 how many of these switches do you have?  I have 30+ and was having the same problem. I was able to determine the issue was due to all my devices requesting IP addresses at once thereby overwhelming the dhcp server in my Orbi router. 
 

I resolved the issue by giving the switches dhcp reservations (ie static IPs). This resolved my issue. 

0
0
#88
Options
Re:HS105 units don't auto-reconnect after losing WiFi connection
2021-10-21 01:30:29

@elhajj33 They never reconnected for me. Switched to sonoff devices. Easy to program. No issues. Works well with Home Assistant.

0
0
#89
Options