Local only

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
1101112...16
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Re:Local only
2021-11-21 19:16:32

The building I live in just put in a fiber system for high speed internet. It is a single SSID sign on with APs in each unit. We have no control over the AP, you can just attach to it. You cannot pick your range of IPs, DNS change etc. You can just attach.

 

I have 7 smart switches and 4 smart plugs. I am able to connect all switches. I cannot connect any plugs. I can get a 'local only' connection to pop up every 30 seconds or so. When I hard reset and re install the plug it finds the device, it connects to it, it then goes to connect to the network, then when it tries to finish, it says ok, and when it tries to get the firmware update, it fails with a java error. 

 

Then it shows 'local only' or not online repeating on and off every 30 60 seconds.

 

Don't know how to fix it. But strange since all the switches work fine.

0
0
#106
Options
Re:Local only
2021-11-27 16:30:22

Everyone, I had a heck of a time yesterday setting up christmas lights on my smartplugs and adding new smartplugs and the whole "local only" problems.  I had 4 of 147existing smart plugs that said local only and would not work. After reading all 11 pages of this tplink thread, with no clear cut answers, I finally I figured out the problem with these smartplugs not working correctly and only showing local only. The problem lies with your router and it getting hung up managing/assigning so many IP addresses and the setup of these smartplugs using 2.4ghz and 5.1 ghz routers. Here is what I did.

 

  1. On your router, 1st reboot it to ensure its running smoothly. If it is a dual 2.4ghz and 5.1ghz router remember that. Your TPlink smartplug only works and connect to 2.4ghz when setting up.
  2. On your kasa app on your phone, delete the smartplug that is not working properly or showing local only and reinstall it.
  3. plug in the smartplug and press and hold for 10 sec until it resets and start blinking.
  4. In Kasa app, add new smartplug. When smarplug is blinking the orange/blue or whatever colors, switch to wifi setting on your phone settings and connect to the smartplug wifi to setup. Don't assume your are already connected to it.
  5.  next the setup will then connect to your wifi network to continue.  On your phone, this must be the 2.4ghz network. now switch to your wifi setting on your phone and make sure or manually connect back to your 2.4ghz wifi network and then switch back to your kasa app to continue setup.  (what I found was my iphone when I switch from the smartplug in setup to the wifi network, my phone sometimes wanted to connect back to the strongest wifi signal(5.1ghz). This screws up the smartplug setup b/c it doesn't work with 5.1ghz. Specially if the smartplug has to do an update during setup) [Make sure you are reconnected back on your 2.4ghz wifi networ on your phone during setup of the smartplug]
  6. Kasa will then complete the setup. you give it a name and will save smart plug settings
  7. The rest is pretty straight forward.  When your are all done with setup and Kasa app and everything works, You can then connect your phone back to whatever wifi network you want 2.4 or 5.1ghz.

 

Good Luck. Don't junk those smartplugs.  They do work and work well.  Those instruction in the smartplug boxes are pretty simplistic and work well for a few smartplugs.  But I have 17 smartplugs and 10 smart switches.  It can confuse and hang up your router when setting up so many at one time 

3
3
#107
Options
Re:Local only
2021-11-30 19:21:02

I recently got a new nest wifi router and had to go through the process and syncing all my smart devices. I have two Kasa smart plugs, one of them worked fine and the other had the local-only issue. I use Google assistant in my home and noticed that the second ( local only) plug wasn't recognized within the Google Home setup. I attempted to go to the Device settings in the Kasa app and switch the Local only toggle, which didn't work. 

 

To fix this:

  1. From the home page of the Kasa app click the hamburger menu on the top left
  2. Click Settings
  3. Click Location and Time
  4. Click Location
  5. Click Sync Location
  6. Now go back to the device and enable the local only

 

This worked for me and now the device is recognized with my Google Home

 

Note if for some reason that doesn't work in step 5, instead of hitting sync location click enter the location manually and save location, then attempt to enable. 

 

2
2
#108
Options
Re:Local only
2021-12-06 03:02:14

To everyone - your issue is the hardware revision. Older T-Link plugs that are version 1.0 have very poor router compatibility. Newer hardware revisions (4.0 or later) don't have this issue. Simply put - time to replace your older plugs. They've failed.  

0
0
#109
Options
Re:Local only
2021-12-12 15:19:03

@DJDDay Sorry, you are wrong and put here wrong messages.  The latest and most updated drivers ans software has the same problem. Devices regularly fall into LOCAL ONLY mode and are not accessible by Alexa, Home etc. They are not seen outside home neither. So those plugins are very bad choice, very expensive and not accessible in most time. 

 

0
0
#110
Options
Re:Local only
2021-12-19 00:58:47 - last edited 2021-12-19 00:59:02

It happened to a smart switch HS200 I have. I simply removed the device from my account through the Kasa app, then re-added it (paired again, etc.). It doesn't show as Local Only anymore. 

0
0
#111
Options
Re:Local only
2021-12-19 01:05:53

@SJI 

 

Since I can't get to any settings on the AP the building provides, I bit the bullet and purchased a $14 wifi repeater/extender. I plugged it into my AP, made a new AP w a new SSID and then connected my smart switch to it. Worked like a champ.

 

Unfortunate that I had to spend $14 for a fix for a plug that I paid $12 for.....

0
0
#112
Options
Re:Local only
2021-12-19 02:49:23

Hey all...

 

Just an FYI.  I recently moved from a residential class router to a business class router (Ubiquiti UDM Pro).  

 

I have yet to assign any of my Kasa plugs static IPs and have bought a few new ones.  They've been running for about 2 months and none have gone to local only status.  

 

Just some new info...

3
3
#113
Options
Re:Local only
2021-12-21 14:22:50

found that unplugging the divice and waiting 30 seconds and plugging back in brought it back online properly

1
1
#114
Options
Re:Local only
2021-12-22 00:14:39

@D-rock That definitely fixes the issue. However, I don't want to have to keep doing that. There's been some power outage in my area recentely. Once power comes back on, everything comes back on and online, except these smart plugs...sorta, but I'll get to that. I don't want to have to power cycle these devices after each outage. I've also noticed this happen when I have to restart my router/AP.

 

Anyway, once the power comes back on,they appear to be connected to WiFi, as I can see them in my Unifi Controller (these are all connected to a Unifi wireless AP). And I can control them locally from the app, since they all say "Local Only."

 

Interestingly, when I go into the App, click on a device, click the Gear icon, and then go to Device Info, the Device time Reads something like: Jan 2, 2000 at 4:02:49 AM.

 

After I unplug and re-plug-in the smart plug, the correct time shows up. And lo and behold, the device can be controlled remotely in the Kasa app, appears in my Google Home app, and I can use my Google Home Mini to control them.

 

Idk why the device time gets reset, but maybe, TP-Link devs, this is causing issues?

1
1
#115
Options