HS200 Failed Invalid Device

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Re:HS200 Failed Invalid Device
2020-10-27 05:06:07

@DAHV87 I have the same problem, i.e., I get "failed: invalid device" when I try to enable remote access. I also noticed that when I go to the Kasa app's Smart Actions page, the app does not seem to recognize that there are any devices associated with my account even though I can see and control the switch locally.

 

Received my HS200 this week from Amazon.

Hardware 3.0, firmware 1.1.3

 

 

 

 

0
0
#12
Options
Re:HS200 Failed Invalid Device
2020-10-27 06:11:33

@DAHV87 It appears they have released a batch of switches that desperately need a firmware update. I was able to get someone on chat regarding this same issue on three new switches I just ordered and installed and they gave me this link to PC/MAC app for forcing the firmware updates. https://static.tp-link.com/2020/202003/20200312/Upgrade_Instruction.zip  However, even after installing and running the software the switches still failed to update. This is definitely something that needs immediate attention. Pretty poor Quality Control to let all these switches out that don't work. 

0
0
#13
Options
Re:HS200 Failed Invalid Device
2020-10-27 15:12:32

@TDG 

 

All,

 

Just minutes ago my two HS200 switches we're magically fixed⁉️ I received a notification from Alexa that my two HS200 connected remotely to my network. Amazing I'm hoping you all have similar results. Something tells me that the care team at TP-Link/Kasa made the correction to the MAC addresses and account association to complete the remote connection.

Now I'm extremely happy😊

 

Kemlyn1
 

1
1
#14
Options
Re:HS200 Failed Invalid Device
2020-10-27 15:16:38

@Kemlyn1 

 

Mine too. After everything else failed and after finding out I cannot change the setting on my Comcast router that the Kasa instructions said to, they magically connected. Lets see if it holds.

0
0
#15
Options
Re:HS200 Failed Invalid Device
2020-10-27 15:29:40 - last edited 2020-10-27 15:31:48

@Kemlyn1 

 

Oh Wow!  Mine were just magically fixed as well. No one was even home when it happened. I just started getting notices from Alexa that my switch was connected. I checked the Kasa app (offsite) and sure enough! Everything connected. Same hardware (V3) same firmware 1.1.3. Nothing changed.

 

I believe TP-Link somehow turned on their cloud support or something. 
 

Glad it finally works!!!

1
1
#16
Options
Re:HS200 Failed Invalid Device
2020-10-28 00:15:43

@DAHV87 after a few days mine just randomly connected to my alexa and is working perfect. No idea what happened but I'm glad it did 

0
0
#17
Options
Re:HS200 Failed Invalid Device
2020-10-28 03:51:57

@DAHV87 

 

I returned my faulty device yesterday.  This company owes me for time and labor.  Wonder how they will respond.

0
0
#18
Options
Re:HS200 Failed Invalid Device
2020-10-28 04:27:28

@BradMcc 

 

I had same problem.  I called yesterday and talked to a support person.  They said they had a fix.  So I gave them my MAC address to the HS200, my router brand and model, the hardware version and serial number of the HS200 off the box. The support person escalated the trouble ticket to a Sr tech, he pushed the fix this morning and sent me an email.  My remote access started working and no longer displays Local Only.  
 

Hopefully this information will be useful when you call.  FYI, I get much better support when I call them vs using live chat.

0
0
#19
Options
Re:HS200 Failed Invalid Device
2020-10-29 03:41:20

@DAHV87 My switch is working now too. I sent an email to TP link support last evening with just the firmware build info (no MAC address or serial number or my account id) and today it is working - I connected it to Google home with no problem. Which is great except I wonder how they did it, i.e. how did they find my switch which supposedly didn't allow remote access? And now in the Kasa App the setting page for the switch no longer shows a Remote Access option. 

 

Anyone have an idea?

0
0
#20
Options
Re:HS200 Failed Invalid Device
2020-10-30 09:10:16

@Joelvh 

These sorts of lousy companies should not be allowed to operate in our great country.

0
0
#22
Options