TL-PA4010PKIT теряет хост, с которым был интенсивный обмен

Эта ветка закрыта для дальнейших ответов. Вы можете создать новую тему, чтобы поделиться своими идеями или задать вопросы.

TL-PA4010PKIT теряет хост, с которым был интенсивный обмен

Эта ветка закрыта для дальнейших ответов. Вы можете создать новую тему, чтобы поделиться своими идеями или задать вопросы.
TL-PA4010PKIT теряет хост, с которым был интенсивный обмен
TL-PA4010PKIT теряет хост, с которым был интенсивный обмен
2014-07-29 12:50:00
Здравствуйте.

Являюсь обладателем TL-PA4010P(EU) Ver.:2.3 KIT. После измнений топологии в домашней сети (в пределах 1ой квартиры) и возросшим трафиком через TL-PA4010PKIT (далее по тексту адаптер) стал наблюдать проблемы с периодической недоступностью хостов, стоящих за адаптерами. Упрощенно топология сети примерно следующая: в корридоре кабель от провайдера воткнут в свитч, туда же воткнут NAS и совственно один из адаптеров. В другой комнате второй комплектный адаптер воткнут во второй свитч, туда же воткнуты основные потребители (пару компов, телик), здесь же раздатся wifi и т.п.
Проблема проявляется так: по прошествию какого-то времени после начала качания (просмотра) чего-то тяжелого с NAS, последний перестает быть виден на потребляющем компе (не пингуется, порты не открываются, единственное в tshark вижу ssdp бродкасты от NAS). В момент недоступности NAS через powerline adapter NAS хорошо виден с того свитча куда от и воткнут, интернет, который в этот же свитч и приходит тоже нормально работает и доступен везде. Через некоторое время - от минуты до 5и минут связь возобновляется, ну и через некоторое время от получаса до часа все работает нормально. Протестировав все сегменты сети по отдельности выяснилось, что проблема не в свитчах, NAS и прочем оборудовании а как раз в powerline адаптерах.
Примерные шаги для воспроизведения проблемы (с учетом моей топологии): на NAS поднимается iperf в режиме сервера, на одном из компов за powerline адаптерами iperf клиент грузит сервер трафиком, понять что связь потеряна можно примерно следующим скриптом:
while true; do ping -c 1 nas 1>/dev/null || echo $(date +"%F %T"); done
Соотвественно печатаем время, когда не было пинга до хоста, т.е. в итоге интервалы времени, когда проблема была, за ночь такого набирается не мало
Исключив адаптеры и подключив свитчи напрямую никаких проблем воспроизвести не удается, т.е. powerline

Почитав описании того, что вроде пофиксано в новой прошивке : [quote]Fixed a bug that IPTV may interrupt for several seconds when STB(Set Top Box) is linked to this Powerline adapter. [/quote] я конечно попробовал ее поставить, но вот не уверен, что это у меня получилось (хотя утилита и рапортует Success), т.к. версия прошивки, которую показывает утилита: 500A-1.1.0.844-01-20120919-FINAL, не менятся после обновления прошивки, т.е. такое впечатление, что либо прошивка не меняется либо у меня уже самая правильная версия, хотя судя по файлам новой прошивки я ожидаю, что она датирована 2013м годом.

Посоветуйте пожалуйста, что можно сделать, чтобы заставить эти адаптеры работать прозрачно и без наблюдаемых багов. И как всеже обновиться на самую свежую версию прошивки?

Заранее Спасибо

update:
FW-QCA7420-1.1.0.844-01-FINAL-20120919:175639-buildbot:OCALA-SW-BUILD-1-1 и тому подобные строки можно найти в самой последней прошивке если открыть ее в hex редакторе, значит у меня самая свежая прошивка и баг воспроизводится на ней.
Печаль...
попробую поменять адаптеры на аналогичные от d-link
  0      
  0      
#1
Опции
1 Ответить
Re: TL-PA4010PKIT теряет хост, с которым был интенсивный обм
2014-08-12 08:50:56
Имеется та же проблема с обновлением прошивки... Устройство(TL-PA6010P/KIT) взял только сегодня. Если официальный форум не поможет с решением вопроса(чего уже не происходит пару недель по наблюдению за топик-стартером) пойду сдавать эти железки.
  0  
  0  
#1
Опции

Информация

Поблагодарили: 0

Просмотры: 3645

Ответы: 1

Статьи по теме