TL-SG108E cannot ping on the same vlan

TL-SG108E cannot ping on the same vlan
TL-SG108E cannot ping on the same vlan
2017-09-03 01:14:50
Model :

Hardware Version :

Firmware Version :

ISP :

Hi All,

Just bought TL-SG108E to accomodate my new Xiaomi pro router.
Currently my setup is like this:

Modem(port 1) -- TL-SG108E (port 1) -- Xiaomi Router pro (port 2)


In order for me to allow the xiaomi to pppoe to modem I need to set up VLAN tagging with ID500 (from internet provider)

The setup of TL-SG108E:

VLAN ID: 500
Member Ports: 1 - 6
Tagged Ports: 1
Untagged Ports : 2-6

I have setup PVID 500 to port 2-6.

Result:
- I can connect wifi through xiaomi router pro and browse internet
- All the device that connected to xiaomi router switch also work

The problem:
- Another host that connected through port 3-6 on TL-SG108E cannot connect to router.
- arp -a doesnt show much info

Any of you could give some solution for this please.

Thanks,
0
0
#1
Options
3 Replies
Re:TL-SG108E cannot ping on the same vlan
2017-09-04 15:46:52
I suggest you upload the screenshots about your configuration. How did you test? used ping command or access the web interface or router?

Did you enable firewall(block ping from WAN port) in xiaomi router? or disable the remote management in xiaomi router?
0
0
#2
Options
Re:TL-SG108E cannot ping on the same vlan
2017-09-05 01:57:16

wsokc wrote


Currently my setup is like this:

Modem(port 1) -- TL-SG108E (port 1) -- Xiaomi Router pro (port 2)

In order for me to allow the xiaomi to pppoe to modem I need to set up VLAN tagging with ID500 (from internet provider)


Not sure what you want to achieve with such a setup. Normal setup for a router connecting a LAN to the Internet via PPPoE on the WAN side is this:

Modem <--> (WAN port) Xiaomi Router (LAN ports) <--> TL-SG108E <--> more devices

Since a modem's PPPoE connection just allows exactly one device at each side of the point-to-point link, a router in between those two devices connected through the ISP's modem does not make any sense to me. Of course the router will block incoming requests from the WAN, so no wonder that you can't ping it through the switch in your setup.

If you insist to carry WAN and LAN traffic through the SG108E, use this setup:

[CODE]
Modem <--> (port 1) TL-SG108E VLAN member 500 PVID=500 (WAN side)
Xiaomi <--> (port 2) TL-SG108E VLAN member 500 PVID=500
TL-SG108E (ports 3-8) <--> more devices Default VLAN 100 PVID=100 (LAN side)
[/CODE]
༺ 0100 1101 0010 10ཏ1 0010 0110 1010 1110 ༻
0
0
#3
Options
Re:TL-SG108E cannot ping on the same vlan
2017-09-05 15:59:36

R1D2 wrote

Not sure what you want to achieve with such a setup. Normal setup for a router connecting a LAN to the Internet via PPPoE on the WAN side is this:

Modem <--> (WAN port) Xiaomi Router (LAN ports) <--> TL-SG108E <--> more devices

Since a modem's PPPoE connection just allows exactly one device at each side of the point-to-point link, a router in between those two devices connected through the ISP's modem does not make any sense to me. Of course the router will block incoming requests from the WAN, so no wonder that you can't ping it through the switch in your setup.

If you insist to carry WAN and LAN traffic through the SG108E, use this setup:

[CODE]
Modem <--> (port 1) TL-SG108E VLAN member 500 PVID=500 (WAN side)
Xiaomi <--> (port 2) TL-SG108E VLAN member 500 PVID=500
TL-SG108E (ports 3-8) <--> more devices Default VLAN 100 PVID=100 (LAN side)
[/CODE]


Hi Thanks for your help...

Yes, that was the dumbest question I ever asked. :)
I totally forgot the Xiaomi only connected to Port 2 on VLAN Switch which is the WAN port, while the LAN port not yet connected.
0
0
#4
Options