CPE510 as Access point - Wifi crashing when connecting

CPE510 as Access point - Wifi crashing when connecting
CPE510 as Access point - Wifi crashing when connecting
2020-05-01 19:44:52
Model: CPE510
Hardware Version: V3
Firmware Version: 2.2.1 Build 20190417 Rel. 34231 (4555)

Hi all,

I have just bought and installed a CPE510 to use it as access point for my garden, where the home wifi doesn't reach properly.

It is connected and working, I have set up the wifi SSID, I have reduced the transmission power to 10dBm since the garnen isn't too big and I can see that the power on the receiver is reasonable (I have been reading of issue at short range due to saturation of the receiver, and I have followed the advices), but I am having some odd issue.

 

If I connect the PC, everything is fine. Fast and stable connection, no issue. But for that, I had to select MCS7 -I couldn't find any information about the compatibility of my wifi on the computer, and this one seems the highest that allows me to connect.

When I try to connect the mobile phone (Android 9, nothing fancy), the phone remains for a few second trying to connect, then it tells me that it is not able to connect to the network. At that point, it doesn't see the network any more for a couple of minutes at least. Now, what is even more odd, the other devices connected to the CPE510 get also disconnected and can't see the network for the same time. And, even if they see it, they can't connect. 

 

So, it looks like that attempting to connect the phone is crashing the access point, for some reason that I cannot understand. Security doesn't make any difference, I get the same behaviour with both no security or WPA-PSK, WPA1 or WPA2. 

 

My settings are

802.11a/n

20/40MHz

MCS7

Channel 100

TX power 10dBm

MAXtrem disabled

Security WPA-PSK

WPA2

Encryption auto

 

From the status, everything looks ok. No entry in the system log.

 

Another strange thing: this is my Firmware Version:

2.2.1 Build 20190417 Rel. 34231 (4555)

 

When I checked on the website, this is indicated as latest one:

CPE510(UN)_3.0-up-ver2-2-0-P9[20190125-rel36276]

 

Is it normal? Version is lower, release is higher? 

Thank you for any help you can provide!

0
0
#1
Options
22 Replies
Re:CPE510 as Access point - Wifi crashing when connecting
2020-05-01 20:01:12

@gpaolo Hi! I think you purchased the wrong device?  That is not a AP?  That is a radio for point to point invisible ethernet device.

 

Here is what you need to try and have wifi in your garden:

TP-Link EAP225-Outdoor

 

That is a access point or AP.

 

 

0
0
#2
Options
Re:CPE510 as Access point - Wifi crashing when connecting
2020-05-01 20:07:15

@Doc2485 Hi, well yes, that is a possibility, I might have got the wrong indication... but the CPE510 is indicated also as access point -it is actually the first mode on TP-Link website. And it is working as access point... as long as I don't try to connect the mobile phone. 

My understanding is that the CPE510 can do also other things compared to the EAP225, not that it cannot be used as access point.

Or are there limitations?

0
0
#3
Options
Re:CPE510 as Access point - Wifi crashing when connecting
2020-05-01 20:13:34 - last edited 2020-05-01 20:14:54

@gpaolo I can verify on Ubitiqi hardware trying to do this did not work well at all??  They stopped making the newer AC models now that ONLY to PtP and PtmP just for wireless bridges like an invisible ethernet cable.  On all my client networks...I user radios = bridges and AP's = wifi

 

Cannot verify with TPLink yet....just bought a couple devices to test on my bench and see how they perform vs Ubitiqi hardware.....

 

https://community.tp-link.com/en/business/forum/topic/205810

0
0
#4
Options
Re:CPE510 as Access point - Wifi crashing when connecting
2020-05-01 22:24:48 - last edited 2020-05-01 23:28:25

@gpaolo, the CPE510 is a Pharos device and as all Pharos devices it is designed for long-range PtP or PtMP directional links. It's intented for WISPs feeding their customers wirelessly or for bridging two networks over a long distance in the kilometers range. It's not well suited for standard clients as a standard AP.

 

That being said, the CPE510 has an antenna beam width of 45º H / 30º E to concentrate RF energy into one direction only (that's the meaning of »directional«).

 

You could use Pharos devices to serve standard consumer devices, but usage is very limited. Due to the nature of the directional antenna beam width of a CPE510 the covered area is only 0.828m (H) × 0.535m (V) at 1m distance from the CPE, that's just 8.28m (H) × 5.35m (E) at 10m distance. If you stand 10m apart from the CPE and the distance of your position is >4m aside from a right-angled line from the CPE, the WiFi signal is lost.

 

If you really want Pharos devices for your garden, then use a WBS210 with omnidirectional antenna TL-ANT2410MO (360º beam width) or with a sector antenna TL-ANT2415MS (120º beam width). But even with a sector antenna you would need to place the WBS 10m away to get ~30m area covered.

 

Do yourself a favour and replace the CPE by an EAP225-Outdoor. What you need in a garden is an access point to extend your network, not a router nor a firewall the Pharos devices provide for WISP applications such as subnetting for different customers.

༺ 0100 1101 0010 10ཏ1 0010 0110 1010 1110 ༻
0
0
#5
Options
Re:CPE510 as Access point - Wifi crashing when connecting
2020-05-01 23:15:06

@R1D2 thank you, I admit that I couldn't guess all these limitations from the website. I understand the coverage issue (it's not really a problem in my case, the garden is long and narrow as most British garden...) and that I haven't got the best model for what I need but... I can't return the CPE510 because I have already installed it and there are things that are not "recoverable" like the cable ties to fix it on the pole and the screws for the PoE adaptor, and the EAP225 costs twice what I have already paid for the CPE510. So, at the moment, spending other £120 is not really an option. 

But, most important, none of these limitations explain why the wifi crashes when an android device tries to connect. 

So, my initial question remains: what could be the reason why what I have explained at the beginning is happening?

0
0
#6
Options
Re:CPE510 as Access point - Wifi crashing when connecting
2020-05-01 23:25:17 - last edited 2020-05-01 23:35:59

@gpaolo, oops, £120 for an EAP225-Outdoor?

 

Hm, but WiFi regulatory provisions in the UK are still the same as in the EU, so I would order an EAP225-Outdoor (EU version) from Amazon in Germany for £70 (I sometimes order gadgets – execpt WiFi gear b/c of different regulatory provisions – from Amazon USA, they deliver also to Germany, so delivery from Germany to UK should be possible, too).

 

But if your garden is long and narrow, you could try to mount the CPE in an ideal distance to cover most of the garden, maybe on the roof pointing down or in your opposite neighbor's garden :-) Here is the formula to compute the covered area:

 

 

Maybe this helps you to find the best position.

༺ 0100 1101 0010 10ཏ1 0010 0110 1010 1110 ༻
0
0
#7
Options
Re:CPE510 as Access point - Wifi crashing when connecting
2020-05-01 23:30:50

@R1D2 I had a quick look on ebay and it was at £120, now I see on amazon is at £100 and there is the 20% less... why people are selling on ebay more expensive than the price new?? Anyway... if there is no way to solve my problem I'll see to get the other one and resell this one. But, again, my problem is not coverage at the moment, my problem is that when I try to connect the phone the whole network crashes, both for the phone and for anything connected to the AP. I don't think this is due to the model, I hope that there is just some issue with the settings.

Any idea on this?

0
0
#8
Options
Re:CPE510 as Access point - Wifi crashing when connecting
2020-05-01 23:39:41 - last edited 2020-05-01 23:50:20

@gpaolo, what exactly do you mean with the whole network crashes/WiFi crashing? If your phone leaves the covered area, it loses the WiFi signal and you can't see it in a survey anymore, but it should still be there. Or do other devices crash, too?

༺ 0100 1101 0010 10ཏ1 0010 0110 1010 1110 ༻
0
0
#9
Options
Re:CPE510 as Access point - Wifi crashing when connecting
2020-05-02 00:03:13

@R1D2 yes, it is what I explained in the first post. I connect the pc, and it's ok. I connect the phone, it doesn't connect, the pc is kicked off the network too, and for a few minutes the wifi is not visible any more. 

0
0
#10
Options
Re:CPE510 as Access point - Wifi crashing when connecting
2020-05-02 01:47:39

@gpaolo, I still don't understand. Is the PC connected wirelessly or on the network wired to the CPE?

 

I never experienced that connecting a device to a WLAN crashes the WLAN or the network. What I could imagine is that DFS caused the CPE to change the channel due to a higher priority service acquiring the channel (weather radar, satellite link, commercial broadcast equipment etc.) and this happened accidently at the same time you tried to connect using the smartphone. This is a normal channel release in the 5 GHz band which causes the WLAN to disappear until a new channel has been found. When I connect a laptop and an Android tablet to the CPE, the WLAN doesn't crash. But even slightly moves of the clients can lead to loss of the signal if the distance is too short (in the 1-5 meters range in my lab). It's a matter of the distance between CPE and the client.

 

The settings of the CPE are o.k. so far, albeit I would recommend 802.11n-only mode if your clients support 802.11n, too. As for the firmware v2.2.1 is latest. Release numbers have no meaning, it's just an internal number.

༺ 0100 1101 0010 10ཏ1 0010 0110 1010 1110 ༻
0
0
#11
Options