CPE220 Firmware crashing/freezing

CPE220 Firmware crashing/freezing
CPE220 Firmware crashing/freezing
2020-10-14 12:56:59
Model: CPE220
Hardware Version: V3
Firmware Version: 2.2.2 Build 20200612 Rel. 51711 (0000)

Hello I have a problem with my CPE220 wich randomly freeze or the firmware is crashing, at random times, but not too often. I cant connect to it by wifi or lan and the solution is to reboot the CPE. All the leds act normal like its working normally. Operation mode is AP Clent Router.

0
0
#1
Options
6 Replies
Re:CPE220 Firmware crashing/freezing
2020-10-15 00:07:33 - last edited 2020-10-15 00:10:05

@cristianvdr, might be caused by wrong settings. Are you really connecting to a WISP?

 

AP Client Router mode uses a wireless client connection as the WAN and turns on routing from LAN to WAN.

This means you have to carefully set up two networks, especially the LAN network:

 

 

༺ 0100 1101 0010 10ཏ1 0010 0110 1010 1110 ༻
0
0
#2
Options
Re:CPE220 Firmware crashing/freezing
2020-10-15 12:24:19

@R1D2 Hello and thx for replying. I know what you mean but my LAN and WAN settings are properly done, the CPE works as intended but from time to time (it can be once in a week or twice in a month), when it just freeze and wifi dissapears, I cant connect to web interface by any way WLAN or LAN. If my settings were bad would not work at all, it has to be some firmware bug. I had the old WA-7210N and never had such problems.

0
0
#3
Options
Re:CPE220 Firmware crashing/freezing
2020-10-15 13:18:24 - last edited 2020-10-15 13:20:50

@cristianvdr, ok. I have only CPE V1 hardware in the field running firmware version 2.2.1, but not V3 hardware. Maybe the new model or the firmware v2.2.2 has a bug. I recommend to open a ticket with your local TP-Link support (see your country's TP-Link website for contact info of the support department).

༺ 0100 1101 0010 10ཏ1 0010 0110 1010 1110 ༻
0
0
#4
Options
Re:CPE220 Firmware crashing/freezing
2020-10-15 15:42:10 - last edited 2020-10-15 15:43:13

@R1D2 I already did a few months back, regarding stuck beacons and radar_bbpanic errors found in log but they said its because of my settings.They wanted to connect trough TeamViewer to make them for me, wich I refused to. PharOS firmware has some annoying bugs for V3 hardware for example latency spikes with local devices. This is my phone's latency when i ping it from my pc

 

And this is from PharOS

The firmware has few problems and this is just one of them.

 

0
0
#5
Options
Re:CPE220 Firmware crashing/freezing
2020-10-15 17:52:22 - last edited 2020-10-15 18:01:18

 

cristianvdr wrote

The firmware has few problems and this is just one of them.

 

Maybe the firmware v2.2.2 has issues which causes freezes (I never experienced this and we have several installations at customer sites running flawlessly since years). But spikes in latency is definitively not a bug. It is pretty normal over every WiFi link, which is a half-duplex shared medium where only one device can send at the same time, especially if you serve standard consumer devices with omnidirectional antennas using a CPE with directional antennas which can easily lead to re-transmissions. In fact, CPEs are not designed to serve standard wireless clients and they don't perform well doing so.

 

If you want an Ethernet-like latency < 1ms over the air, then you must use specially designed full-duplex systems like AirFiber AF24 which uses a proprietary RF protocol and two simultaneous links between two APs. But those devices are a bit more expensive compared to CPEs.

 

BTW, the software is called Pharos, it is named after the first lighthouse in history which was Pharos of Alexandria. Yes, I know that even the TP-Link document department writing Pharos user guides isn't aware of this fact.

༺ 0100 1101 0010 10ཏ1 0010 0110 1010 1110 ༻
0
0
#6
Options
Re:CPE220 Firmware crashing/freezing
2020-10-15 20:46:44

@R1D2 I guess I will have to use the old WA-7210N wich has no problems, till new firmware is released for CPE220.

0
0
#7
Options