VLAN ID not passed to router

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

VLAN ID not passed to router

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
VLAN ID not passed to router
VLAN ID not passed to router
2014-04-17 15:47:58
Region : Netherlands

Model : TL-SG2216

Hardware Version : V1

Firmware Version : 1.0.2 Build 20131031 Rel.32673

ISP : Ziggo


This is probablyl a newbie question, but I'll try anyways.

We have a small network, with one TL-SG2216 the connects to our NetGear internet router. At our desks we have small TP-Link switches (TP-Link TL-SG108). To these small computers we have our computers AND phones connected. This all had to do with the wiring. So I set the voip phones to use VLAN ID 100.

Now this had worked, but after a small power outage, this didn't work anymore. When I patch the small switches directly to my netgear, it works perfectly, and the phones get their IP for vlan 100.

So it must be something in the TL-SG2216 switch.

The setup should be really easy: all ports on the TL-SG2216 have to be member of vlan 1 and vlan 100. When the port receives a package with vlan 100, it should just forward it as such. If it received 1 of nothing, it should forward as such. Howcome the VLAN 100 isn't getting through? I was hoping somebody could post me an example. Port 15 connects to my netgear router.

I tried:

- Default VLAN 1: all ports untagged, vlan 100: all ports untagged, all PVID 1
- Default VLAN 1: all ports but 15 untagged -- 15 tagged, vlan 100: all ports untagged, all PVID 1
- Default VLAN 1: all ports tagged

I figured I may need to configure the ports as "trunk" or "general", but the port config has been removed from this firmware version.

Hope somebody can help.

Thanks in advance!
  0      
  0      
#1
Options
2 Reply
Re:VLAN ID not passed to router
2014-05-07 16:44:07
Hi, rolandow

rolandow wrote

[COLOR=#000000]Region : Netherlands
- Default VLAN 1: all ports untagged, vlan 100: all ports untagged, all PVID 1
- Default VLAN 1: all ports but 15 untagged -- 15 tagged, vlan 100: all ports untagged, all PVID 1
- Default VLAN 1: all ports tagged

I figured I may need to configure the ports as "trunk" or "general", but the port config has been removed from this firmware version.


1. Read the Port VLAN configuration of your phones and router

2. Reset the configuration of your switch:

TP-Link TL-SG2424 Guide -> System Reset
http://tplink-manuals.org/tplink-tl-sg2216-sg2424-sg2424p-sg2452-user-guide/30/

3. Configure VLANs on the switch:
TP-Link TL-SG2424 Guide -> 802.1Q VLANs
http://tplink-manuals.org/tplink-tl-sg2216-sg2424-sg2424p-sg2452-user-guide/64/

If your phones/router send untagged packets - use Untagged and PVID,
if tagged - use Tagged and .add required port to all VLANs.
  0  
  0  
#2
Options
Re:VLAN ID not passed to router
2014-05-07 19:43:28
Yes, you are right. I should have configured the ports as "tagged" for vlan 100, because the phones are setting the vlan ID already. Then with all the ports as PVID 1 and default vlan 1 all untagged ports, the configuration is finally working.
  0  
  0  
#3
Options

Information

Helpful: 0

Views: 1569

Replies: 2

Related Articles