DHCP on Client mode

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
12
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
DHCP on Client mode
DHCP on Client mode
2015-02-25 09:05:30
Region : UnitedStates

Model : CPE510

Hardware Version : V1

Firmware Version : 1

ISP : Charter


I do have 2 buildings connected through CPE 510 within about 500 meters distance. First of all I have to tell you guys I have been working on any single option it has
and in comparison to other brands, its working flawlessly. The only problem I do have is that when I give a same range ip on the DHCP between 100 numbers
like 31 to 130 some times the CPE 510 as client starts to pick DHCP out of the defined parameters and serve them which brings the band with down since packets fly around
from CPE 510 access point one to client one. Interesting most of them are Iphones. See the below mesh and configuration for a better understanding of my network.


Main router DD-wrt Netgear R7000 192.168.1.254 DHCP 132 to 240 lease time 6 hours
L2 switch as backbone TL-SG3216 192.168.0.2 installed in the first building
CPE 510 as access point First building node 192.168.0.10
CPE 510 as client router Second building node 192.168.1.131 DHCP enabled from 30 to 130
Smart switch TL-SG2424 192.168.0.3 installed in the second building
both CPE 510's are just connected (locked) to each other and there is no other usage from them.(Just P2P)
My question is that why the CPE 510 as client/router should start giving ips to clients on the other side (first building) clients?
0
0
#1
Options
13 Reply
Re:DHCP on Client mode
2015-03-07 23:37:20
Hi,

there is an Bug with DHCP and Client-Mode. I have opened an Support-Request, but i only get an Workaround. The Bug might be fixed with next Firmware.


Daniel
0
0
#3
Options
Re:DHCP on Client mode
2015-03-09 16:45:36
Hi @JamesIT
It sounds like you are using Client mode. Both AP mode and Client mode work as a pure switch which will pass through the DHCP traffic from the front network (Netgear R7000) to the client side. That's normal, it is how it is designed.:eek:

A wireless bridge cannot split broadcast traffic..So you cannot stop the DHCP traffic passing through from the Netgear router (building_A) to the client side (building_B).



danielhainich wrote

Hi,

there is an Bug with DHCP and Client-Mode. I have opened an Support-Request, but i only get an Workaround. The Bug might be fixed with next Firmware.

Daniel


Hi Daniel. I don't think @JamesIT had encountered the same problem as yours. What bug do you find in client mode?
0
0
#4
Options
Re:DHCP on Client mode
2015-03-09 20:38:16

Tobacco wrote



Hi Daniel. I don't think @JamesIT had encountered the same problem as yours. What bug do you find in client mode?



CPE210 and CPE510 does not passthrough DHCP-Traffic.
I have tested it with both Models. Mode is set to Client-Mode. All Clients behind the AP didnt received an dynamic IP-Address.Problem was repeated by TP-Link Support.
0
0
#5
Options
Re:DHCP on Client mode
2015-03-10 11:13:25
Hi Daniel

Thank you very much for your feedback.:)

If the access point (client mode) is connected to a RE200, the client devices connected to the AP(client mode) will fail in obtaining addresses by DHCP.
RE200 deals with DHCP packets in a particular method, which does not consider the situation of being connected by another access point in client mode.
But it is a compatibility issue between RE200 and access point products in client/repeater mode.

And it is not a bug in client mode of CPE or other access point models. For example, the problem won't occur if we connect CPE210(client mode) to a TL-WA850RE instead of a RE200.

To eliminate this compatibility issue will require a lot of modification on the current chipset driver. So it won't be improved very soon.

This kind of scenario is not common. But if users do need to connect an access point to a RE200, here are three workaround:

1. Enable DHCP server on the AP(client mode) with separate IP range. For example, the main router's DHCP pool is 192.168.0.100~192.168.0.150, then the DHCP on the AP can be 192.168.0.151~192.168.0.250
2. Manually assign static IP addresses on the client devices which are connected to the AP.
3. Configure the AP as AP client router mode (also called Wisp client mode) instead of Client mode.
0
0
#6
Options
Re:DHCP on Client mode
2015-03-10 15:14:15
Hi,

thank you for your information. there was no feedback on my support-request. exists the problem only in high-speed-mode? or also in concurrent-mode?
0
0
#7
Options
Re:DHCP on Client mode
2015-03-12 08:53:34

danielhainich wrote

Hi,

thank you for your information. there was no feedback on my support-request. exists the problem only in high-speed-mode? or also in concurrent-mode?


Sorry for the delay. Unfortunately it exists in both high-speed-mode and concurrent-mode.
0
0
#8
Options
Re:DHCP on Client mode
2015-04-06 06:57:40
Sorry I was late, I have not received any emails as you left your comments guys!
Actually as I mentioned, for all my access points and L switches I do use 192.168.0.XXX to isolated them from the other clients who sometimes don't have DHCP on and make IP conflicts inside the network,
and I don't see any reason to rule out my L2 switch because there are about 20 (PC and IP phones) inside building_A (main) and the are working pretty fine(we are talking about a school environment).
For the second reason, I tried to set up a transparent bridge by giving out of range IPs but since the main router is DHCP the packet latency dropped). For recommended setting depending on clients in second side sometimes it went
between 250 to 400 ms, but right now with current settings in worst case its not more than 45ms. (Ip phones in second building were acting up on Client mode\ DHCP off and CCQ was between 20-30 %, literally it was a mess, Google took to load for 2 mins
inside building_B clients (PCs).
Anyway you need to give an Ip inside the range when you are setting the DHCP on Client side! so Again Since I am sharing printers and IP phones I would prefer to assign same range inside both buildings(192.168.1.X).
Thanks for reading and responding to my post.
My settings:
http://imgur.com/a/eYIJT
0
0
#9
Options
Re:DHCP on Client mode
2015-04-06 14:53:17

tplink wrote

Hi Daniel

Thank you very much for your feedback.:)

If the access point (client mode) is connected to a RE200, the client devices connected to the AP(client mode) will fail in obtaining addresses by DHCP.
RE200 deals with DHCP packets in a particular method, which does not consider the situation of being connected by another access point in client mode.
But it is a compatibility issue between RE200 and access point products in client/repeater mode.

And it is not a bug in client mode of CPE or other access point models. For example, the problem won't occur if we connect CPE210(client mode) to a TL-WA850RE instead of a RE200.

To eliminate this compatibility issue will require a lot of modification on the current chipset driver. So it won't be improved very soon.

This kind of scenario is not common. But if users do need to connect an access point to a RE200, here are three workaround:

1. Enable DHCP server on the AP(client mode) with separate IP range. For example, the main router's DHCP pool is 192.168.0.100~192.168.0.150, then the DHCP on the AP can be 192.168.0.151~192.168.0.250
2. Manually assign static IP addresses on the client devices which are connected to the AP.
3. Configure the AP as AP client router mode (also called Wisp client mode) instead of Client mode.


Thanks,
Look I can not use WIPS because I am sharing the internet through an smart switch with wired clients (Pc and IP phone) in the second building (priority) and the building does not let me to use the CPE510's wifi (neither does not have omni direction antennas)
For static DHCP, the envioronment doesnot let me to do it since we do have a lot of wifi connected guests!
Im going to do Radius wifi server and Vlans soon!
0
0
#10
Options
Re:DHCP on Client mode
2015-04-06 14:57:55
Thank you all freinds,
I do have another question, Is there a way I could schedule a reboot on CPE 510?, anyway NTP is not functioning correctly, I have added time.nist.gov and other time pools but its giving me random time segments and date!
Regards
0
0
#11
Options
Re:DHCP on Client mode
2015-04-06 20:53:18

JamesIT wrote


1-Is there a way I could schedule a reboot on CPE 510?,
2-NTP is not functioning correctly

1-answer, no, you can enable Ping Watch Dog on Tp-Link only
2-right, but have you tried latest Beta FW here http://forum.tp-link.com/showthread.php?80137-TP_PharOS_1.1.0_150324_Beta-multi-language-and-wider-frequency-range

I dont want to read the whole thread,again, but from what I read before, it seems you have double NAT on your network
0
0
#12
Options