TL-SG108E VLan question Uplink P1 and Downlink P2

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

TL-SG108E VLan question Uplink P1 and Downlink P2

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
TL-SG108E VLan question Uplink P1 and Downlink P2
TL-SG108E VLan question Uplink P1 and Downlink P2
2017-01-17 05:17:07
Model :

Hardware Version :

Firmware Version :

ISP :

Hey

I have a question about VLAN and hope someone in here might help.
I have a router which is configured with 3 VLAN's
one port is assigned to VLAN 1, 2 & 3 as a downlink port to a TL-WA901ND access point where 3 SSID are taged to each VLAN. All work fine.
Now I would like to add the SG108E switch between, so port 1 at the switch will be my uplink to the router and port 2 will be my downlink to the access point.

How should the switch be configured to allow tagged packets from the access point to enter at port 2 and exits at port 1, and the replay going back

kind regards
Jens
  0      
  0      
#1
Options
3 Reply
Re:TL-SG108E VLan question Uplink P1 and Downlink P2
2017-01-17 09:30:40

JensKofoed wrote


How should the switch be configured to allow tagged packets from the access point to enter at port 2 and exits at port 1, and the replay going back


Just enable 802.1Q VLAN mode, add port 1 and 2 of the switch to VLANs 1, 2 and 3 and mark them tagged.
༺ 0100 1101 0010 10ཏ1 0010 0110 1010 1110 ༻
  0  
  0  
#2
Options
Re:TL-SG108E VLan question Uplink P1 and Downlink P2
2017-01-17 22:40:26
I've tried. But it is not possible to change settings for vlan 1. So port 1 and 2 can only have vlan 2 & 3 as taged and vlan 1 as untagged. It is not possible to set vlan 1 as tagged.
From the web gui. I don't know if is is possible in another way
/Jens
  0  
  0  
#3
Options
Re:TL-SG108E VLan question Uplink P1 and Downlink P2
2017-01-18 20:20:39
Yes, you're right. I was under impression that the web UI of TL-SG108E is a subset of the web UI of other switches such as the TL-SG2008 for example, which lets one indeed select VLAN 1 (the "default" VLAN) to modify ports from untagged to tagged. But with TL-SG108E it is not possible.

As discussed in another thread already, IMHO it's a very bad idea from TP-Link to use VID=1 for untagged packets. As I understand the 802.1Q standard, untagged packets should have VID=0 (or more precisely: no tag at all), b/c that's the "reserved" VID to use as PVID for untagged ports/traffic.

Not being able to use VID=1 on TL-SG108E for own, separate VLANs or at least not being able to delete ports from it or make them tagged ports creates lot of problems with existing VLAN setups and also is not consistent with the possibility to use VID=1 on WiFi APs.

I have already filed a bug report last year to the German support, but did not get a positive answer about possibly changing the default VLAN policy from TP-Link engineering. Maybe we should open a new ticket about this issue. I did so already today.
༺ 0100 1101 0010 10ཏ1 0010 0110 1010 1110 ༻
  0  
  0  
#4
Options

Information

Helpful: 0

Views: 797

Replies: 3

Related Articles