RE650 failed to connect to the 5GHz of Virgin Media Hub?

Used Products:

Maybe a week ago, I bought a RE650 from Amazon to enhance the wireless signal strength on my house. But something happened which I’ve never expected.


The 2.4GHz works well as it should be, while the 5GHz won’t connect to my modem with the error message “Connection Failed. Please check the Host SSID or password, and connect again”. That is so weird, my other devices work well with my host 5GHz network. I have tried messing around with all the settings I can think of, double check the wireless settings of the 5GHz, change another password, even I hard reset my modem but no avail. I was so frustrated and I contacted TP-Link for some help.



The TP-Link tech supports are very kind and professional, they tried to gather some necessary information to do further analysis, but I was abroad on vacation at that time so I failed to reply in time; Once I got back, I found that the 5GHz led came on, and verified that it has connected to my modem successfully; So amazing, I did nothing but it works automatically.


Kept that in mind, I did some work, and I just found something different on my modem. The software was updated automatically.

The old one is CH7465LG-NCIP-

The new one is CH7465LG-NCIP-


I suspect that this may be related to the software update on my Virgin Media Hub. Because there is no any change happened on RE650. Then I googled the software CH7465LG-NCIP- and found many posts about this:


Their devices failed to connect to the modem 5G wifi with this 2p3 software, but the issue disappears when updated to the new 2p4 one.

Yes, I am lucky that RE650 is working well with my modem.


I also noticed that there are some people posted that they have the similar issues with CH7465LG-NCIP-, but their modem is Compal box. But as you can see, the two software versions almost have the same name. They must be related. However, I don’t have much more time to do further troubleshooting on this.


So here is my advice, even though the internet service provider or location varies, the modem/router is produced by the same manufacturer, if you have the similar issue, just check the software on your modem and update it.


Hope it will help you guys who in needed.



i have a AC1750 RE450 model. i changed my wifi system and no idea how to get my system connected to wifi. the videos i watch are no working and i have been on the phone with tech support on hold for over an hour.anyone got an idea would be very happy tks

Why is there so much spam? I don't have any of the devices in the article, but nice job!

i was already looking for this information

@vietcanvas Feel so bad, hope to use it soon