SG105PE: connected devices will not connect via router

SG105PE: connected devices will not connect via router

SG105PE: connected devices will not connect via router
SG105PE: connected devices will not connect via router
2022-09-08 09:47:04 - last edited 2022-09-15 06:14:09
Model: TL-SG105PE  
Hardware Version:
Firmware Version:

Dear community,

 

I searched but couldn't find a solution in here, so please bear with me in case I missed one.

 

I have newly purchased a TP-SG105PE with the intention to connect a wireless access point and some other devices. The switch is directly connected to my router, which is in fact a cable modem (vodafone).

 

All connecting devices are set to receive an IP via DHCP, as is the switch, so my assumption was that i just "plug and play", but it will not work: the switch gets a proper IP in local range (192.168.0.xxx), but for example connecting a laptop will grant it a completely different IP. I tried manually assigning a local IP in the same segment (192.168.0.yyy), but pinging my gateway/router at 192.168.0.1 times out.

 

I am by no means an expert, so any help would be highly appreciated.

 

Thanks in advance and best regards,

-bio

  0      
  0      
#1
Options
1 Accepted Solution
Re:SG105PE: connected devices will not connect via router-Solution
2022-09-14 18:17:20 - last edited 2022-09-15 06:14:09

  @Virgo 

Virgo wrote

  @biodegradable 

 

It is difficult to say if this is a problem with this switch, and there is a simple way to verify that the switch ports are transmitting data properly:

 

Disconnect the switch from the router, use two PCs to connect to different ports of the switch, set the static IP of the 192.168.0.X network segment for the PCs, if the two PCs can't ping each other, then the probability is that there is an abnormality in the switch port forwarding data.

 

Suggest reset the switch firstly before do the above test.

 

I was suspecting an incompatibility between the old router and the switch, so I replaced the Arris with a new Fritzbox. Now it works. :)

 

Thanks all for reading and helping out, this can be closed I guess.

Recommended Solution
  0  
  0  
#5
Options
6 Reply
Re:SG105PE: connected devices will not connect via router
2022-09-09 07:28:28

  @biodegradable 

 

biodegradable wrote

I have newly purchased a TP-SG105PE with the intention to connect a wireless access point and some other devices. The switch is directly connected to my router, which is in fact a cable modem (vodafone).

 

If the switch connect to the cable modem directly, but where is the DHCP and NAT device in your network?

Or the cable modem is a modem router?

If so, the modem router's IP is 192.168.0.1? You can try to change the switch's IP to 192.168.0.X to in case the IP conflict.

  0  
  0  
#2
Options
Re:SG105PE: connected devices will not connect via router
2022-09-09 13:01:17

  @Virgo 

Virgo wrote

  @biodegradable 

 

biodegradable wrote

I have newly purchased a TP-SG105PE with the intention to connect a wireless access point and some other devices. The switch is directly connected to my router, which is in fact a cable modem (vodafone).

 

If the switch connect to the cable modem directly, but where is the DHCP and NAT device in your network?

Or the cable modem is a modem router?

If so, the modem router's IP is 192.168.0.1? You can try to change the switch's IP to 192.168.0.X to in case the IP conflict.

 

Thanks a lot for taking the time to answer, Virgo.

 

My cable modem actually is an Arris TG44DE, so a cable modem with router, sorry for not being clear.

The router is set to IP 192.168.0.1, I configured the DHCP server to start distributing IP starting at 192.168.0.10 and set the switch's IP manually to 192.168.0.2. Didn't help, I can't ping 192.168.0.1.

 

Additionally I had assumed that plugging in the switch in default setting (so receiving an IP via DHCP enabled) it would automatically be set up properly.

 

I tried using different ports to no avail.

 

I am using another TP-Link switch (no PoE) without issues for so long that I forgot the model number. :)

  0  
  0  
#3
Options
Re:SG105PE: connected devices will not connect via router
2022-09-14 03:55:06

  @biodegradable 

 

It is difficult to say if this is a problem with this switch, and there is a simple way to verify that the switch ports are transmitting data properly:

 

Disconnect the switch from the router, use two PCs to connect to different ports of the switch, set the static IP of the 192.168.0.X network segment for the PCs, if the two PCs can't ping each other, then the probability is that there is an abnormality in the switch port forwarding data.

 

Suggest reset the switch firstly before do the above test.

  0  
  0  
#4
Options
Re:SG105PE: connected devices will not connect via router-Solution
2022-09-14 18:17:20 - last edited 2022-09-15 06:14:09

  @Virgo 

Virgo wrote

  @biodegradable 

 

It is difficult to say if this is a problem with this switch, and there is a simple way to verify that the switch ports are transmitting data properly:

 

Disconnect the switch from the router, use two PCs to connect to different ports of the switch, set the static IP of the 192.168.0.X network segment for the PCs, if the two PCs can't ping each other, then the probability is that there is an abnormality in the switch port forwarding data.

 

Suggest reset the switch firstly before do the above test.

 

I was suspecting an incompatibility between the old router and the switch, so I replaced the Arris with a new Fritzbox. Now it works. :)

 

Thanks all for reading and helping out, this can be closed I guess.

Recommended Solution
  0  
  0  
#5
Options
Re:SG105PE: connected devices will not connect via router
2022-09-20 04:09:55

biodegradable wrote

I was suspecting an incompatibility between the old router and the switch, so I replaced the Arris with a new Fritzbox. Now it works. :)

 

Thanks all for reading and helping out, this can be closed I guess.

Dear  @biodegradable 

 

Thank you for your kindly feedback! 

 

To better help other customers who may face the same issue, if possible, may I get more details about your switch? 

1. What is the hardware version and firmware version of your switch? (it can be found on the switch web interface main page)

2. You mentioned you tried to set up static IP 192.168.0.2 on your switch. If you configure static IP on your PC(and connect PC to the switch), will you be able to Ping the router 192.168.0.1 from the PC?

 

2022 TP-Link Wi-Fi 7 Product Launch Event | Watch the Replay at https://www.tp-link.com/us/wifi7/event/.
  0  
  0  
#6
Options
Re:SG105PE: connected devices will not connect via router
2022-09-20 19:21:34

Hank21 wrote

biodegradable wrote

I was suspecting an incompatibility between the old router and the switch, so I replaced the Arris with a new Fritzbox. Now it works. :)

 

Thanks all for reading and helping out, this can be closed I guess.

Dear  @biodegradable 

 

Thank you for your kindly feedback! 

 

To better help other customers who may face the same issue, if possible, may I get more details about your switch? 

1. What is the hardware version and firmware version of your switch? (it can be found on the switch web interface main page)

2. You mentioned you tried to set up static IP 192.168.0.2 on your switch. If you configure static IP on your PC(and connect PC to the switch), will you be able to Ping the router 192.168.0.1 from the PC?

 

  

Hi Hank,

 

I have the version 2 of the TL-SG105 PE with the most recent firmware (for V2 there is only one available): TL-SG105PE(UN)_V2_1.0.0 Build 20220414 (1.0.0 Build 20220414 Rel.52733)

 

I had set up my static IP 192.168.0.2 and my laptop to 192.168.0.3. I was not able to ping the router at 192.168.0.1.

 

I might have been too enthusiastic about my solution though, it only worked for 30 mins, but: I finally really fixed it. It seems to be connected to the cable I used (fixed line in the wall). When using the switch directly at the router or at the current location (I switched place with the previous non-PoE TPLink switch) it works absolutely fine!

 

I could really slap myself for not checking the obvious earlier.

 

BR,

-bio

 

  2  
  2  
#7
Options