EAP245 2.3 Firmware problems

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

EAP245 2.3 Firmware problems

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
EAP245 2.3 Firmware problems
EAP245 2.3 Firmware problems
2019-10-20 16:14:40 - last edited 2020-02-12 07:12:51
Model: EAP245  
Hardware Version: V3
Firmware Version: 2.3.0

Updated from the EAP245v3_2.2.0 firmware via controller (to 190731), all installed fine, but could no longer connect via iphone/ipad and perhaps other devices.  Tried rebooting but again no luck, trying many times to connect, I reverted to the prior firmware without further issue.  Also noticed the new firmware on the 2.4 band was choosing the same channel (6) as my other 245 (v1) AP.  After reinstalling the older version, it immediately chose 11.  Cheers.

APs: EAP225v3, EAP245v3, EAP670, Controller: Linux, Primary Switch: T2600-28TS, Routing: OPNsense
  0      
  0      
#1
Options
1 Accepted Solution
Re:EAP245 2.3 Firmware problems-Solution
2019-10-22 18:34:47 - last edited 2020-02-12 07:12:51

@GPB I have a untagget(Deafult vlan) 300 wher i have a lott of Iot Devices and access point on the same vlan.  and on that ssid I have to remove vlan settings on ssid, when i remove vlan settings I steel was on the same vlan because this was the defult vlan for accesspoint.

so try to remove vlan from ssid if you have vlan 10 untagged (defult vlan) 

 

 

Recommended Solution
  1  
  1  
#6
Options
9 Reply
Re:EAP245 2.3 Firmware problems
2019-10-21 09:08:12 - last edited 2020-02-12 07:13:09

@GPB 

 

I had a test in our lab by using the iPhone and Android devices, all devices can work well. So it should be not the issue of the firmware. 

You say you cannot connect iphone/ipad to the new firmware. Normally the Apple devcies cannot connect to the SSID when the signal is very weak. So please make sure the clients have a good signal. 

By the way, after you upgrade the new firmware, you can try to reset the EAP245 V3.0, just to check if the clients can connect to it. 

As the channel, when we choose "Auto", the EAP devices will choose the channel automatically. In my lab, the EAP choose channel 11. 

  0  
  0  
#2
Options
Re:EAP245 2.3 Firmware problems
2019-10-21 12:58:29 - last edited 2020-02-12 07:12:51

@forrest Thanks for the reply and appreciate you testing.  Yes, I'm about 20 feet from the AP so signal strength is very strong, I have a second AP (245v1) on the second floor both managed by the controller.  I performed a manual upgrade via the controller (manual as in I had to download the file and then point the controller to it) as the controller was reporting the firmware was already up-to-date (with v2.2).  When I get some time I'll retest.  Cheers.

 

PS: should have mentioned iphone 7 and ipad 5th gen...if that matters to anyone.

APs: EAP225v3, EAP245v3, EAP670, Controller: Linux, Primary Switch: T2600-28TS, Routing: OPNsense
  0  
  0  
#3
Options
Re:EAP245 2.3 Firmware problems
2019-10-22 18:12:22 - last edited 2020-02-12 07:12:51

@GPB Do you have any vlan? I have a untaged vlan wher I have accesspoint and I have to remove vlan settings on ssid on that vlan after update. you can't longer use vlan settings on ssid with untagged vlan anymore after latest bug fix.

So my configuraton was wrong but worked with the old firmware.

 

2. Fixed the bug that untag packets can be transferred to SSIDs with different VLANs.

 

 

  0  
  0  
#4
Options
Re:EAP245 2.3 Firmware problems
2019-10-22 18:24:55 - last edited 2020-02-12 07:12:51

@shberge I do have a VLAN on one SSID.  On the SSID page I have the VLAN ID entered (10), how would this change with the new firmware?  I wasn't trying to connect to that VLAN though, it's only used for IoT devices.  I'm not fully understanding what you changed to make it work with the new f/w.  Thanks!

APs: EAP225v3, EAP245v3, EAP670, Controller: Linux, Primary Switch: T2600-28TS, Routing: OPNsense
  0  
  0  
#5
Options
Re:EAP245 2.3 Firmware problems-Solution
2019-10-22 18:34:47 - last edited 2020-02-12 07:12:51

@GPB I have a untagget(Deafult vlan) 300 wher i have a lott of Iot Devices and access point on the same vlan.  and on that ssid I have to remove vlan settings on ssid, when i remove vlan settings I steel was on the same vlan because this was the defult vlan for accesspoint.

so try to remove vlan from ssid if you have vlan 10 untagged (defult vlan) 

 

 

Recommended Solution
  1  
  1  
#6
Options
Re:EAP245 2.3 Firmware problems
2019-10-22 18:43:02 - last edited 2020-02-12 07:12:51

@shberge Oh, now I understand.  In my case, VLAN 10 is tagged and my default (primary LAN SSID) would be VLAN 1 and is untagged (configured like your VID 300).  So this is a different setup and issue I seem to have (still need to retest at some point).  Thanks for the clarification. 

APs: EAP225v3, EAP245v3, EAP670, Controller: Linux, Primary Switch: T2600-28TS, Routing: OPNsense
  0  
  0  
#7
Options
Re:EAP245 2.3 Firmware problems
2019-10-24 12:58:07 - last edited 2020-02-12 07:12:51

@shberge Reinstalled 2.3 this morning, problem was I had the switch configured as tagged default VLAN instead of untagged.  It was correct on the AP, but the switch was wrong but still worked with 2.2...didn't occur to me to check this (until you posted about the VLAN).  Switching that to untagged allowed the devices to connect successfully to the network (they were apparently connecting to the AP...just no further connectivity).  Thanks again for the help.  Cheers.  :)

APs: EAP225v3, EAP245v3, EAP670, Controller: Linux, Primary Switch: T2600-28TS, Routing: OPNsense
  1  
  1  
#8
Options
Re:EAP245 2.3 Firmware problems
2019-10-24 14:03:04 - last edited 2020-02-12 07:12:51

@GPB You can use tagged vlan1 but then you have to configure vlan settings on ssid to vlan 1

 

  1  
  1  
#9
Options
Re:EAP245 2.3 Firmware problems
2019-10-24 14:21:04 - last edited 2020-02-12 07:12:51

@shberge That makes sense, didn't bother trying that once I changed the switch setting.  My 245v1 continues fine working like the v3 on the 2.2 firmware; that's probably why I set up the v3 as I did.  Wonder if we'll ever see an update for that v1...thinking not.  I appreciate the clarification.  

APs: EAP225v3, EAP245v3, EAP670, Controller: Linux, Primary Switch: T2600-28TS, Routing: OPNsense
  0  
  0  
#10
Options

Information

Helpful: 0

Views: 1529

Replies: 9

Related Articles