AP cannot connect to Omada Controller (IP address issue)

AP cannot connect to Omada Controller (IP address issue)
AP cannot connect to Omada Controller (IP address issue)
2019-11-08 04:09:18
Model: EAP245
Hardware Version: V3
Firmware Version:

Hi,

 

I have a router Asus AC3200, the Omada Controller OC-200 and 4 AP's (two EAP 225 and two EAP245). One of the AP's (EAP245) located at level 2 cannot connect to the Omada Controller. The issue is that it gets an IP address outside the router's range. My router's IP address is 192.168.1.1, with a pool from 192.168.1.2 to 192.168.1.254.

Once I plug in the new AP, it connects to the internet and I can configure it manually with a Windows laptop, but its IP address is 192.168.107.1, outside the router's range. I cannot see the AP in the router clients list and the AP cannot connect to the controller. I have tried to assign a static IP to the AP, but it doesn't work. If i move it near the router an connect with a short network cable, it works fine and I can configure it without problems. I have manually assigned an IP address of 192.168.1.204 to the AP from the router (no conflicts there).

Once I move it back upstairs, it obtains the wrong IP adress again. I have tried resetting it, move it downstairs and upstairs again, I have even exchanged it and the new AP reacts the same way. There is a direct CAT5 cable from the router at the main floor to the AP at level 2. Because the AP has internet when I set it up at level 2, I assumed that there is nothing worng with the cable. I did try to check the cable with a network cable tester, but it seems that I have all green lights upstairs and no lights at all downstairs, so I am not sure if the tester has enough power to push the signal for testing (probably 30-50 feet length). But because the AP has internet, it seems to not be a cable issue.

I am considering changing the cable terminations, in case there is a physical issue or change the ASUS router, as a last resort, but this really weird and I could use some ideas on how to fix this.

Any help would be greatly appreciated.

Thank you.

 

0
0
#1
Options
4 Replies
Re:AP cannot connect to Omada Controller (IP address issue)
2019-11-08 13:58:06 - last edited 2019-11-08 14:03:23

 

GRX wrote

The issue is that it gets an IP address outside the router's range. My router's IP address is 192.168.1.1, with a pool from 192.168.1.2 to 192.168.1.254.

Once I plug in the new AP, it connects to the internet and I can configure it manually with a Windows laptop, but its IP address is 192.168.107.1, outside the router's range. I cannot see the AP in the router clients list and the AP cannot connect to the controller. I have tried to assign a static IP to the AP, but it doesn't work.

 

Why should it not work to assign a static IP to an EAP? I always use static IPs for EAPs and such static assignments work fine. You only need to ensure to assign the static IP through Omada Controller, but not through the web UI which would put the EAP automatically in stand-alone mode rather than in managed mode.

 

I also don't understand why connecting the EAP to the 192.168.1.0 subnet should "assign the EAP an IP" from within the 192.168.107.0 subnet. Which service is it which assigns an IP from the latter subnet to the EAP? How do you notice this IP if your devices are in the 192.168.1.0 subnet? How should your Windows laptop connect to 192.168.107.1 if it is in the 192.168.1.0 subnet? Is there a second DHCP server running somewhere?

 

༺ 0100 1101 0010 10ཏ1 0010 0110 1010 1110 ༻
0
0
#2
Options
Re:AP cannot connect to Omada Controller (IP address issue)
2019-11-08 14:33:02

@R1D2 I have tried several different ways:

1. I connected the AP near the router. In this case the Omada Contreller sees it and it adopts it smoothly. I then went into the Asus router interface and assigned an IP adress (192.168.1.204, as the controller and the other 3 APs have IP adresses from 192.168.1.200 to 203). Then I disconnected it and moved it to level 2, but there it disconnects from the controller and it disapears from the Asus clients list. I connected my laptop to the ethernet port of the AP and ran an ipconfig command to find the IP adress of the router, and this is when I found the 192..168.107.0 (sometimes it is different, but always in the format 192.168.xxx.x, outside the router's range). I went then in the AP's web interface (via its IP adress) and try to change the IP to 192.168.1.204 as static IP address), and it would take the command, but not really do the change.

2. I have installed it straight at level 2, connect to its wifi, went into the web interface of the AP and found the out of range IP address. Then I have tried to change the IP address to static and give it the 192.168.1.204 IP address to force it back in the range. This also didn't work.

 

Like I've said, I have internet from the AP, so the network cable seems to work. I don't have a second DHCP server, as far as I know.

It is really odd why it works near the router (connect with a 4' CAT5 cable), but it doesn't work at Level 2 with 40-50' of cable.

I am not sure if I tried this (too many attempts to remember), but I will try today to reset the AP, connect it near the router and assign a stayic IP address via the Omada controller and the same (fixed) IP address in the router, then move it to level 2.

I have had similar issues with the other 3 routers, but they ended up working after several attempts. All other AP's have a fixed IP address in the router, but they are not set up with static IP in the controller and they work ok. I thought that their issue is because they come through a network switch, and the last one isn't.

 

 

 

0
0
#3
Options
Re:AP cannot connect to Omada Controller (IP address issue)
2019-11-08 15:54:02 - last edited 2019-11-08 16:09:00

 

GRX wrote

1. I connected the AP near the router. In this case the Omada Contreller sees it and it adopts it smoothly. I then went into the Asus router interface and assigned an IP adress (192.168.1.204, as the controller and the other 3 APs have IP adresses from 192.168.1.200 to 203).

 

That's not assigning an EAP a static IP, that's a static mapping of an IP for the EAP in the router's DHCP server (makes a BIG difference).

 

To assign an EAP a static IP, connect it to Omada Controller (nearby the router or directly connected to the OC200 or system running the SW controller) and adopt it. Then change the EAP's IP in Omada Controller to save it permanently in the EAP's flash memory. Next try again to connect the EAP to the controller from level 2.

 

Regarding the EAP's web UI: as soon as you log into the web UI the first time, you choose stand-alone mode for this EAP permanently. The EAP cannot be adopted anymore by the controller unless it is reset to factory defaults. Therefore, setting a static IP in the web UI makes no sense if the EAP should later become adopted by the controller.

༺ 0100 1101 0010 10ཏ1 0010 0110 1010 1110 ༻
1
1
#4
Options
Re:AP cannot connect to Omada Controller (IP address issue)
2019-11-08 16:51:31

@R1D2 Regarding the IP adress, I was assigning a fixed address in the router and also a static IP in the AP to match, but now I know to do the latter in the Omada Controller, not in the AP's web interface. Thank you,  I will try this tonight and let you know if it worked.

R1D2 wrote

 

GRX wrote

1. I connected the AP near the router. In this case the Omada Contreller sees it and it adopts it smoothly. I then went into the Asus router interface and assigned an IP adress (192.168.1.204, as the controller and the other 3 APs have IP adresses from 192.168.1.200 to 203).

 

That's not assigning an EAP a static IP, that's a static mapping of an IP for the EAP in the router's DHCP server (makes a BIG difference).

 

To assign an EAP a static IP, connect it to Omada Controller (nearby the router or directly connected to the OC200 or system running the SW controller) and adopt it. Then change the EAP's IP in Omada Controller to save it permanently in the EAP's flash memory. Next try again to connect the EAP to the controller from level 2.

 

Regarding the EAP's web UI: as soon as you log into the web UI the first time, you choose stand-alone mode for this EAP permanently. The EAP cannot be adopted anymore by the controller unless it is reset to factory defaults. Therefore, setting a static IP in the web UI makes no sense if the EAP should later become adopted by the controller.

 

0
0
#5
Options