Date/Time setup is missing from web interface CLI system-time also doesn't work

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
12
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Date/Time setup is missing from web interface CLI system-time also doesn't work
Date/Time setup is missing from web interface CLI system-time also doesn't work
2019-12-06 08:40:10 - last edited 2019-12-06 11:20:49
Hardware Version: V2
Firmware Version: 2.0.0 Build 20160922 Rel.61508(s)

Hello,

I have two from this switch and would be nice to see logs with correct date/time, but there is no possibility to set correct Time in web interfce.

i tried ssh /telnet also without success:

1. SSH: if i login with ssh and go to privileged mode with enable than cant go into config with configure command , it tells : bad command.

2. Telnet: i can go to privileged mode than i can run configure and i am in config# but i get bad command again if i try to set date with system-time command.

i tried : system-time dst Europe and system-time ntp UTC+01:00 132.163.97.5 12 both gives me bad command

 

 

any hint from someone????

0
0
#1
Options
1 Accepted Solution
Re:Date/Time setup is missing from web interface CLI system-time also doesn't work-Solution
2019-12-06 09:57:19 - last edited 2019-12-06 11:20:49
If you use CLI command, you can try to enter two IP addresses. Another IP address is backup-ntp-server. If you use web interface, is there any error message when you configure NTP server? Please note that if you use NTP server, you need to set up gateway for switch. If you use static IP for L3 interface, you need to set up static routing 0.0.0.0 / 0.0.0.0 next hop x.x.x.x as default gateway. Otherwise, switch cannot access NTP server.
Recommended Solution
1
1
#3
Options
16 Reply
Re:Date/Time setup is missing from web interface CLI system-time also doesn't work
2019-12-06 09:14:07

@Darksigns 

Hi, first of all, I really advise you to upgrade your switch to v3 firmware with new design. Your v2 is ready to be updated to v3.

Always use "?" to check, which commands are possible and what switch is waiting for the next step.

 

I can't check now old version fw, but in new design I also have the "Missing parameter" error, not bad command!

 

myswitch(config)#system-time ntp UTC+01:00 132.163.97.5 12
---------------------------------^
Error: Missing parameter
 

 

It happens, because switch wants secondaty IP for NTP server

myswitch(config)#system-time ntp UTC+01:00 132.163.97.5
 <WORD>               - NTP backup server IP address
 

Something like this works absolutely normally

myswitch(config)#system-time ntp UTC+01:00 132.163.97.5 132.163.97.6 12
myswitch(config)#

1
1
#2
Options
Re:Date/Time setup is missing from web interface CLI system-time also doesn't work-Solution
2019-12-06 09:57:19 - last edited 2019-12-06 11:20:49
If you use CLI command, you can try to enter two IP addresses. Another IP address is backup-ntp-server. If you use web interface, is there any error message when you configure NTP server? Please note that if you use NTP server, you need to set up gateway for switch. If you use static IP for L3 interface, you need to set up static routing 0.0.0.0 / 0.0.0.0 next hop x.x.x.x as default gateway. Otherwise, switch cannot access NTP server.
Recommended Solution
1
1
#3
Options
Re:Date/Time setup is missing from web interface CLI system-time also doesn't work
2019-12-06 11:17:23

@Mitya at my telnet it also not works:(( where do i find the new firmware to download?

 

0
0
#4
Options
Re:Date/Time setup is missing from web interface CLI system-time also doesn't work
2019-12-06 11:20:14 - last edited 2019-12-06 11:28:17

@Andone your solution helped , i set up the static route and it automatically took the right date with wrong time zone:))

 

so half of it already ok.

I tried the "system-time ntp UTC+01:00 132.163.97.5 132.163.97.6 12" and  "system-time dst Europe"  commands but still getting bad command error

i will try to upgrade to firmware 3 if i find out where can i download it

 

 

 

THANK YOU

0
0
#5
Options
Re:Date/Time setup is missing from web interface CLI system-time also doesn't work
2019-12-06 11:37:44

@Mitya 

in the meanwhile i run ? for the commands i have on the switch and that is why the command comes back with error that i have no such a command:))

0
0
#6
Options
Re:Date/Time setup is missing from web interface CLI system-time also doesn't work
2019-12-06 11:58:49

@Darksigns 

 

dafaq?))

Upgrade your FW. I will just say one more time, that I advise you to upgrade your v2 switch with v3 firmware, which has different design on some features, e.g. vlans, but it is pretty OK and I feel it is really better.

https://www.tp-link.com/en/support/download/t1600g-52ps/v3/#Firmware

0
0
#7
Options
Re:Date/Time setup is missing from web interface CLI system-time also doesn't work
2019-12-06 12:07:50

@Darksigns 

 

by the way, if you do not want to update and Andone's solution is OK for you, you still can try to check full configuration by "show run" and you will see, what commands switch used for NTP configuration via WebGUI.

0
0
#8
Options
Re:Date/Time setup is missing from web interface CLI system-time also doesn't work
2019-12-06 12:18:01 - last edited 2019-12-06 12:20:37

@Mitya downloading FW v3:)) is there a manula how to patch the firmware ? there is no menu for it in the GUI:)))))

 

show run doesn't work either:)))))

0
0
#9
Options
Re:Date/Time setup is missing from web interface CLI system-time also doesn't work
2019-12-06 12:19:51

@Darksigns 

Ok, I think I've got it. Go to full admin mode by "enable-admin".

0
0
#10
Options
Re:Date/Time setup is missing from web interface CLI system-time also doesn't work
2019-12-06 12:35:35

@Mitya Hm,,,

in console i logged in with admin user

T1600G-52PS>enable-admin

gave error bad command

if i just use enable than i am in elevated console with #

here i tried enable-admin than i get an error:

T1600G-52PS#enable-admin
Authentication fail. You should enable AAA first.

Error password!

 

0
0
#11
Options

Information

Helpful: 0

Views: 2334

Replies: 16

Related Articles